Umstellung auf PHP 5.5.* - Forum geht nicht mehr

Probleme bei der regulären Arbeiten mit phpBB, Fragen zu Vorgehensweisen oder Funktionsweise sowie sonstige Fragen zu phpBB im Allgemeinen.
Forumsregeln
phpBB 2.0 hat das Ende seiner Lebenszeit überschritten
phpBB 2.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 2.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Benutzeravatar
Dungeonwatcher
Mitglied
Beiträge: 635
Registriert: 11.07.2004 10:04
Wohnort: Berlin

Umstellung auf PHP 5.5.* - Forum geht nicht mehr

Beitragvon Dungeonwatcher » 21.03.2014 13:02

Hi! 8)

Ich nutze weiterhin phpBB2 in der letzten Version 2.0.23 mit PHP 5.2.17. Das läuft bisher bestens. Ich würde gerne PHP auf die aktuelle Version umstellen. Nur leider läuft dann das Forum nicht mehr. D.h. es gibt nur die einsame Fehlermeldung: Could not connect to the database, nichts weiter. Weder PHP noch MySQL geben mehr dazu preis. PMA z.B. läuft klaglos.

Was läuft hier vermutlich schief?

Bye

Benutzeravatar
Miriam
Valued Contributor
Beiträge: 12309
Registriert: 13.10.2004 07:18
Wohnort: Ammerland
Kontaktdaten:

Re: Umstellung auf PHP 5.5.* - Forum geht nicht mehr

Beitragvon Miriam » 21.03.2014 17:49

Zu allererst möchte ich Dir dazu gratulieren, daß Du es geschafft hast, ein phpBB Forum der Version 2 bis heute ohne einen wie auch immer gearteten Gau, am Laufen zu halten.

Prinzipiell sollte das Forum auch auf einer Version PHP 5.5.x laufen. Ich habe es mit PHP 5.5.6 getestet.
Es kann natürlich sein, daß Variablen in der althergebrachten Form des phpBB2 nicht mehr mit den Einstellungen des dann neuen PHP 5.5.x übergeben werden. Z.B. durch register_globals = off oder ähnlichem.

Es gilt auch hier: Never change a running system.
Gruss, Miriam.
Ich schmeiß' alles hin und...
... lasse es liegen

Benutzeravatar
Dungeonwatcher
Mitglied
Beiträge: 635
Registriert: 11.07.2004 10:04
Wohnort: Berlin

Re: Umstellung auf PHP 5.5.* - Forum geht nicht mehr

Beitragvon Dungeonwatcher » 21.03.2014 18:40

Hi! 8)

Miriam hat geschrieben:Zu allererst möchte ich Dir dazu gratulieren, daß Du es geschafft hast, ein phpBB Forum der Version 2 bis heute ohne einen wie auch immer gearteten Gau, am Laufen zu halten.


U.a. mittels GeoIP gehört da nicht viel dazu das zu schaffen. Da das Forum nur einen kleinen Insider- bzw. Kollegenkreis bedient habe ich alle IP außer D geblockt. Das klappt nahezu perfekt. Selten zwar, aber ab und zu wird halt mal eine Deutsche IP geblockt, ansonsten war letztmalig vor über 7 Jahren eine auländische IP auf meinen Seiten. Dazu Google und Co. verbieten und schon ist man "einsam". :wink:

Es kann natürlich sein, daß Variablen in der althergebrachten Form des phpBB2 nicht mehr mit den Einstellungen des dann neuen PHP 5.5.x übergeben werden. Z.B. durch register_globals = off oder ähnlichem.


Stimmt, da hat sich einiges in PHP geändert. Da muss ich mich mal durch die Dokus arbeiten. :roll:

Es gilt auch hier: Never change a running system.


Darauf wird es wohl erst mal hinauslaufen. Zumindest was den Apache [v2.2.27 gaanz frisch von gestern] und SQL [MariaDB v5.5.36 64-bit] angeht gibt es ja weiterhin Sicherheitsupdates.

Danke und Bye


Zurück zu „phpBB 2.0: Administration, Benutzung und Betrieb“