[PNphpBB 2] Nach Serverumzug kein Login mehr möglich

Probleme bei der regulären Arbeiten mit phpBB, Fragen zu Vorgehensweisen oder Funktionsweise sowie sonstige Fragen zu phpBB im Allgemeinen.
Forumsregeln
phpBB 2.0 hat das Ende seiner Lebenszeit überschritten
phpBB 2.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 2.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
ChristianHAL
Mitglied
Beiträge: 1
Registriert: 19.03.2017 12:18

[PNphpBB 2] Nach Serverumzug kein Login mehr möglich

Beitragvon ChristianHAL » 19.03.2017 12:43

Liebe Nutzer,

ich habe ein sehr großes Problem und hoffe inständig, dass mir hier geholfen werden kann.

Zum Problem: Ich betreibe seit Juni 2006 ein PNphpBB 2 mit einer großen Community und mit heutigem Tag 183.183 Beiträgen.

Eins vorweg: Ich bin bereits seit nunmehr acht Tagen Google hoch und runter gesurft, finde aber einfach keine Lösung, die mir hilft.

Zweites vorweg: Meine Konfiguration

PNphpBB-Version: 1.2i
phpBB-Version: 2.0.22
Server: Apache
SSL: Let's encrytp
PHP: 5.3 (zus. php.ini-Optionen: max_input_vars, auto_prepend_file, zend_extension=ioncube.so)

Zur MySQL (lt. phpmyadmin)

Server: dbmizvep.mariadb.routing.zone via TCP/IP
Server-Typ: MariaDB
Server-Version: 10.1.21-MariaDB - MariaDB Server
Protokoll-Version: 10
Benutzer: dbmizvep_znsnjrz@213.160.71.42
Server-Zeichensatz: UTF-8 Unicode (utf8)

Zum Webserver (lt. phpmyadmin)

nginx/1.11.4
Datenbank-Client Version: libmysql - mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $
PHP-Erweiterung: mysqli Dokumentation
PHP-Version: 5.6.24


Das Forum lief all die Jahre beim Hoster Sysprovide. Ich war immer sehr zufrieden mit dem Hoster, das Forum machte nie Probleme, auch wenn es technisch hier und da natürlich gefühlt Jahrzehnte veraltet ist.

Bereits vor zwei Jahren hatte ich einmal versucht, das Forum auf phpBB 3 zu konvertieren, allerdings war ich hier in der Installation wegen einer für mich nicht nachvollziehbaren Fehlermeldung hängen geblieben und hatte das Forum gemäß dem Motto "never touch a running system" weiter über PNphpBB 2 laufen lassen.

Soweit so gut. Am vorletzten Samstag nun wurden Server und Datenbanken "zwangsweise" zum Hoster Velogrid migriert, da Sysprovide seine Dienste einstellen muss.

Ich habe also alle neuen Zugangs- und Konfigurationsdaten in die einschlägigen Config-Dateien eingepflegt und hoffte inständig, dass alles klappt. Hätte ja funktionieren können ...

Nun ist es so:

Das Forum an sich läuft inzwischen, nachdem zunächst alle Umlaute und Sonderzeichen als Fragezeichen in einer Raute dargestellt waren. Ich vermutete eine Inkompatibilität zum zunächst hosterseitig vorgegebenen PHP 5.6, also bat ich darum, die Version 5.3 freizuschalten, da das Forum unter Sysprovide problemlos mit PHP 5.3 lief. Und siehe da - Umlaute wieder da, alles gut.

ABER: Manche User können sich penetrant nicht mehr einloggen. Es ist so merkwürdig - manche User (so wie ich auch als Admin) bin nach wie vor eingeloggt, also wie vor der Migrierung, andere hatten die Option "Eingeloggt bleiben" nie genutzt und standen nun vor verschlossenen Türen. Wenn sie ihre Nutzerdaten eingaben, kam zunächst "Anmeldung erfolgreich", doch dann wurden sie einfach wieder auf die Startseite geleitet.

Andere Nutzer bekamen die Meldung "Keine Berechtigung für die Aktion (Browser-Back verwendet?)".

Seltsam ist, dass sich manche User z. B. mittels Smartphone einloggen können, mit Chrome, Opera oder Internet Explorer dagegen nicht.

Ich persönlich konnte mich auf dem Dienstcomputer über Internet Explorer immer eingeloggt halten, bis ich mal über eine der beiden Domains, auf denen das Forum läuft (eine Adresse ist http://ABC.biz, die andere http://www.ABZ.biz), die SSL-Funktion mit https:// testen wollte. Danach gab es Probleme, ich stellte alles wieder zurück, und plötzlich konnte ich mich selbst auch nicht mehr über http://ABZ.biz einloggen. Über www. bin ich immer noch eingeloggt und hoffe, dass das noch lange so bleibt.
Am heimischen Firefox bin ich auch über beide Domains eingeloggt und hoffe, dass ich das noch lange bleibe. Über Opera und Safari komme ich dagegen auch nicht rein.

Es ist so merkwürdig. Nicht mal eine Neuregistrierung mit einem weiteren Account bekomme ich hin, da auch dann die Meldung "Keine Berechtigung für die Aktion (Browser-Back verwendet?)" einsetzt. Ich habe keine schlüssige Erklärung dafür, würde das Problem aber bei den Cookies bzw. Sessions verorten.
Ich habe es aus benannten Gründen unterlassen, selbst bei mir die Cookies zu löschen, um die Gefahr zu umgehen, am Ende selbst vor verschlossenen Türen zu stehen. Andere Nutzer jedoch haben intensiv alle Möglichkeiten bei sich getestet (Cache geleert, Cookies gelöscht), doch das Ergebnis bleibt das selbe: Sie kommen nicht rein.

Ich brauche dringend Hilfe und hoffe, dass hier Hinweise genannt werden können, wie ich wieder allen Nutzern den Zugang zum Forum ermöglichen kann.

Wenn noch Informationen von mir benötigt werden, schreibt gern hier, dann werde ich diese sofort nachreichen.

Ich wünsche Euch einen schönen Sonntag!

Beste Grüße
Christian

Zurück zu „phpBB 2.0: Administration, Benutzung und Betrieb“