Erweiterung die von einer anderen abhängt

In diesem Forum gibt es Starthilfe zum neuen Extension-System von phpBB 3.1/3.2. Fragen zur Entwicklung von Extensions und zur Konvertierung von phpBB 3.0.x MODs sind ebenfalls willkommen.
Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 5926
Registriert: 24.05.2010 08:31
Kontaktdaten:

Erweiterung die von einer anderen abhängt

Beitragvon Kirk » 23.09.2018 13:00

Hallo
Für meine EXT B3P Who was here Modul habe ich eine ext.php (Siehe Eintrag in Pastebin) erstellt, damit sollte diese EXT nur installiert werden wenn diese Erweiterung mit der Version 1.3.1 instaliert ist.
Wenn die EXT in der Version 1.3.0 von LukeWCS per FTP hochgeladen wurde und man diese Modul installieren möchte, erhält man die Information:
Die ausgewählte Erweiterung kann nicht aktiviert werden. Bitte prüfe die Voraussetzungen, die für die Erweiterung notwendig sind.
Die Erweiterung “Wer war da?” muss zuerst installiert sein.
Falsche Version für die “Wer war da?” Erweiterung installiert. Erforderlich >= 1.3.1

Das ist soweit alles korrekt, wenn dies EXT noch nicht hochgeladen wurde bekomme ich die Fehlermeldung 'FILE_NOT_FOUND' angezeigt.
Lösche ich diesen Teil aus der ext.php erhalte ich die Meldung das die Erweiterung “Wer war da?” muss zuerst installiert sein.

Code: Alles auswählen

      /**
       * And now the metadata...
       * If the VERSION field exists and is set then let's check the version
       */
      $metadata_manager = $ext_manager->create_extension_metadata_manager('bb3mobi/washere', $this->container->get('template'));

      $metadata = $metadata_manager->get_metadata('all');

      $required = $metadata['version'];

      /**
       * If the VERSION field exists and is set then let's check the version
       */
      if ($required && isset($required))
      {
         $clean_required = html_entity_decode($required);

         $version = phpbb_version_compare($clean_required, '1.3.1', '>=');
      }

      /* Wrong VERSION? No party! */
      if ( !($version))
      {
         $lang['EXTENSION_NOT_ENABLEABLE'] .= '<br>' . $user->lang('ERROR_WHO_WAS_HERE_WRONG_VERSION');
         $is_enableable = false;
      }

Ich komme nicht dahinter was an diese Datei falsch ist.

Zurück zu „Extension Bastelstube“