phpBB auf WD MyCloud EX2100 // Von extern nicht erreichbar

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
WoS_BigDaddy
Mitglied
Beiträge: 33
Registriert: 22.07.2015 23:45

phpBB auf WD MyCloud EX2100 // Von extern nicht erreichbar

Beitragvon WoS_BigDaddy » 23.07.2015 12:40

Hallo Zusammen,

wie der Betreff schon beschreibt habe ich ein Problem mit der Erreichbarkeit meines phpBB-Forums von externen PCs die sich nicht in meinem Netzwerk befinden.

Zu der aktuellen Situation:
Ich habe gestern auf meiner NAS (WD MyCloud EX2100) dank der Hilfe der mitgelieferten Apps phpBB und phpmyAdmin installieret. Unter phpmyAdmin habe ich eine Datenbank angelegt und mit diesen Daten erfolgreich das phpBB-Forum zum laufen gebracht. Im internen Netzwerk funktioniert alles reibungslos und alle Funktionen sind vorhanden.

Zu dem Problem:

Das Forum ist wie oben beschreiben leider nicht von außen erreichbar - mein Versuch gestern über NO-IP.com eine FTP-Weiterleitung samt der Portfreischaltung im Router zu machen ist leider gescheitert. Nun knobbel ich schon mehrere Stunden daran das Problem in den Griff zu bekommen und würde mich freuen hier etwas Unterstützung zu bekommen.

Vielen Dank schomal im Vorraus und Grüße
Dennis

Benutzeravatar
BNa
Valued Contributor
Beiträge: 2265
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: phpBB auf WD MyCloud EX2100 // Von extern nicht erreichb

Beitragvon BNa » 23.07.2015 13:43

- erstmal > das nas muss eine feste ip haben (zb 192.168.1.7)
- zweitens > portforwarding auf genau diese ip (port 21 und 80)
- no-ip oder konsorten regelmäßig updaten lassen
- aufrufen > www.no-ip.blub_bla.de/forum/index.php o.ä.

WoS_BigDaddy
Mitglied
Beiträge: 33
Registriert: 22.07.2015 23:45

Re: phpBB auf WD MyCloud EX2100 // Von extern nicht erreichb

Beitragvon WoS_BigDaddy » 23.07.2015 15:35

Danke für die schnelle Antwort.

Leider besteht weiterhin der Fehler und das Forum ist von extern nicht erreichbar.

- portforwarding der Ports 21 und 80 wurden gesetzt
- unter no.ip.com wurde die festgelegte IP eingetragen

Benutzeravatar
gn#36
Administrator
Administrator
Beiträge: 9156
Registriert: 01.10.2006 16:20
Wohnort: Ganz in der Nähe...
Kontaktdaten:

Re: phpBB auf WD MyCloud EX2100 // Von extern nicht erreichb

Beitragvon gn#36 » 23.07.2015 18:19

Zweiteres ist falsch. Du musst deinen Router so einrichten, dass dieser seine aktuelle IP automatisch an deinen DynDNS Anbieter meldet oder die IP Adresse deines Internetanschlusses bei selbigen von Hand eintragen (und dann immer wieder aktualisieren wenn sie sich ändert). Sprich, wenn deine vom Internetanbieter vergebene IP z.B. 100.200.150.250 ist, dann muss genau die beim DynDNS Anbieter eingetragen werden. In deinem Router trägst du die Portweiterleitung auf die interne IP ein.

Wenn du ganz viel Pech hast hat dein Internetanbieter aber nicht genug IP Adressen und setzt selber NAT ein um mehr Kunden ins Internet zu bringen. In dem Fall kriegst du leider eine IP Adresse zugewiesen, die von außen nicht erreichbar ist, weil neben deinem Router noch ein Router deines Internetanbieters dazwischen steht. Ein Zeichen dafür wäre, wenn dein Router eine IP, die dem Muster 10.x.x.x folgt, als externe Adresse hat (die du in dem Fall aber nicht über eine Webseite, die dir deine IP anzeigt herausbekommst, denn die sieht dann nur die IP des Routers des Anbieters, nicht die deines Routers).
Begegnungen mit dem Chaos sind fast unvermeidlich, Aber nicht katastrophal, solange man den Durchblick behält.
Übertreiben sollte man's im Forum aber nicht mit dem Chaos, denn da sollen ja andere durchblicken und nicht nur man selbst.

WoS_BigDaddy
Mitglied
Beiträge: 33
Registriert: 22.07.2015 23:45

Re: phpBB auf WD MyCloud EX2100 // Von extern nicht erreichb

Beitragvon WoS_BigDaddy » 24.07.2015 21:58

Super vielen Dank für die ausführliche Antwort.

Das Problem besteht weiterhin. Was habe ich probiert:

1. Ich habe in meinen Router die Zugangsdaten für meinen DynDNS-Anbieter eingetragen
2. Auf der Seite von dem Anbieter habe ich die IP meines Router eingetragen
3. Innerhalb des Router habe ich die Ports 80 und 21 weitergeleitet und als Gerät die NAS ausgewählt
4. Nun versuche ich unter der festgelegten Adresse das Forum zu erreichen, jedoch ohne Erfolg

EDIT:

Ich habe gerade gesehen das es auch möglich ist auf der NAS einen Dyn-DNS-Anbieter einzutragen.
Selbe Spiel wie oben - IP beim Anbieter geändert und die Daten von NO-IP auf der NAS eingetragen
Dies habe ich auch probiert - leider das selber problem das es nicht erreichbar ist.

Benutzeravatar
gn#36
Administrator
Administrator
Beiträge: 9156
Registriert: 01.10.2006 16:20
Wohnort: Ganz in der Nähe...
Kontaktdaten:

Re: phpBB auf WD MyCloud EX2100 // Von extern nicht erreichb

Beitragvon gn#36 » 25.07.2015 16:17

Das direkt auf dem NAS einzurichten macht meistens keinen Sinn, denn das NAS hängt nicht direkt im Netz. Sprich, der Router muss trotzdem die Portweiterleitung machen sonst geht's nicht, außerdem kennt das NAS die Externe IP nicht an den die Weiterleitung gehen muss.

Wenn es auf einem NAS läuft gehe ich mal davon aus dass der interne Zugriff (nicht über localhost sondern über die IP) klappt. Sofern hier irgendwelche alternativen Portangaben notwendig sind (also z.B. http://192.168.0.1:8080 in der Adresszeile steht), dann muss die Portweiterleitung auf diesen Port zeigen (wäre hier 8080), nicht auf Port 80. Das solltest du ggf. überprüfen.

Die erste Frage die du für den externen Zugriff klären solltest ist, ob es evtl. nicht an den Routereinstellungen sondern an der Namensauflösung liegt. Hierzu kannst du einfach deine Externe IP im Browser aufrufen (also im obigen Beispiel http://100.200.150.250/) und hierüber versuchen auf deine Seite zuzugreifen. Wenn das klappt, dann funktioniert der DynDNS Dienst nicht korrekt und deine Portweiterleitung geht. Wenn das nicht klappt, dann ist deine Portweiterleitung nicht korrekt konfiguriert und du solltest noch mal in das Router Handbuch schauen wie man das korrekt macht. Das mindeste was du brauchst ist eine Weiterleitung auf deinen oben bestimmten Port. Aber du kannst auch einen beliebigen Port auf diesen Port auf deinem NAS weiterleiten. Also könntest du z.B. Port 8008 am Router auf Port 80 (oder eben den jeweiligen anderen Port der verwendet wird) weiterleiten und würdest dann mit http://100.200.150.250:8008/ auf deine Seite zugreifen. Oder du nimmst Port 80 und kannst dir die Zusätze sparen. Wenn es aber mit Port 80 nicht geht würde ich auf jeden Fall mal einen alternativen Port testen.

Falls der Zugriff mit der externen IP Adresse funktioniert, aber über die dyndns Adresse nicht ist offenbar in der DynDNS Konfiguration was falsch. Da dann entsprechend Zugangsdaten im Router überprüfen, eventuell prüfen ob die automatische Meldung bei dem Anbieter den man ausgewählt hat überhaupt funktioniert (es gibt nämlich welche, die das nicht in den kostenlosen Paketen erlauben sondern erst in den Premium Angeboten).
Begegnungen mit dem Chaos sind fast unvermeidlich, Aber nicht katastrophal, solange man den Durchblick behält.
Übertreiben sollte man's im Forum aber nicht mit dem Chaos, denn da sollen ja andere durchblicken und nicht nur man selbst.

WoS_BigDaddy
Mitglied
Beiträge: 33
Registriert: 22.07.2015 23:45

Re: phpBB auf WD MyCloud EX2100 // Von extern nicht erreichb

Beitragvon WoS_BigDaddy » 26.07.2015 10:20

Mit der externen IP und dem richtigen Port ist das Forum problemlos intern erreichbar. Somit funktioniert die Portweiterleitung problemlos. Wenn ich diese Adresse extern aufrufe erhalte ich folgende Nachricht:

Forbidden

You don't have permission to access /phpBB on this server.

Hier fehlen anscheinend bestimmte Rechte was es erlaubt von extern zuzugreifen?

Der Fehler der Erreichbarkeit lag bei dem DynDNS-Anbieter - die angegebene Adresse ist trotz richtiger IP nicht errichbar. Werde mal bei einem alternativ Anbieter rein schauen. Das Problem liegt nun eher an bestimmten Rechten?

Vielen Dank somit bin ich schonmal ein ganzes Stück weiter :D.

Benutzeravatar
BNa
Valued Contributor
Beiträge: 2265
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: phpBB auf WD MyCloud EX2100 // Von extern nicht erreichb

Beitragvon BNa » 26.07.2015 20:23

du musst dem php server oder der entsprechenden wd config "sagen" das public (also aussen) zugriff haben darf

WoS_BigDaddy
Mitglied
Beiträge: 33
Registriert: 22.07.2015 23:45

Re: phpBB auf WD MyCloud EX2100 // Von extern nicht erreichb

Beitragvon WoS_BigDaddy » 27.07.2015 00:11

Ich suche jetzt knapp 3 Stunden alle möglichen Datein und Einstellungen im Forum, Nas und in den Datenbanken von PHPMyAdmin durch und finde keine Einstellungsmöglichkeit einen extenen Zugriff zuzulassen.

Leider findet man nichts über google - gibt es Ideen oder Tipps wo ich suchen kann/sollte damit ich das bisschen eingrenzen kann?

Die MyCloud dient bereits als Datenspeicher für Freunde/Bekannte somit sollte hier der externe Zugriff nicht verweigert sein. (Verwendung des WD MyCloud Programms)

Vermutung liegt also nah das es eine Einstellung im Forum ist - darüber hinaus ist das Forum noch komplett in Englisch (stellt kein Problem da - nur wenn man nach einem Fehler sucht man es sich auf Deutsch leichter) und daher das ich noch nicht durchgeblickt habe wie ich in PHPMyAdmin für die Deutsche Sprache die Datenbank geändert werden kann, muss ich leider so suchen.

Benutzeravatar
gn#36
Administrator
Administrator
Beiträge: 9156
Registriert: 01.10.2006 16:20
Wohnort: Ganz in der Nähe...
Kontaktdaten:

Re: phpBB auf WD MyCloud EX2100 // Von extern nicht erreichb

Beitragvon gn#36 » 27.07.2015 10:50

Eigentlich ist in der Regel für dein NAS jeder Zugriff "extern", denn entweder kommt er von deinem Rechner, oder er kommt vom Router über die Portweiterleitung, von dem NAS selbst aus greifst du ja nicht zu.

Normalerweise sollte es auch keinen Unterschied machen ob du aus dem Internen Netz heraus auf die Externe IP zugreifst oder von woanders. Eine Firewall o.ä. kann den Zugriff auch nicht sperren, wenn die Fehlermeldung vom Webserver kommt - dann hast du ja bereits Zugriff erhalten. Entweder ist also deine Zugriffsadresse falsch (z.B. Groß/Kleinschreibung des Pfads "phpBB" o.ä.) oder auf der Kiste laufen zwei Webserver und du greifst von extern auf den falschen davon zu (gibt's durchaus auch - z.B. einen für die Konfiguration und einen für Clientprogramme oder sowas), weil du den falschen Port für die Portweiterleitung verwendest.
Begegnungen mit dem Chaos sind fast unvermeidlich, Aber nicht katastrophal, solange man den Durchblick behält.
Übertreiben sollte man's im Forum aber nicht mit dem Chaos, denn da sollen ja andere durchblicken und nicht nur man selbst.


Zurück zu „Support-Forum“