Nichts gemacht doch plötzlich Fehlercode...

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
gerbozor
Mitglied
Beiträge: 63
Registriert: 04.09.2011 17:57

Nichts gemacht doch plötzlich Fehlercode...

Beitragvon gerbozor » 18.02.2016 20:19

Hallo...

Bin eine absolute Laie was PHP etc. angeht und hab vor einiger Zeit ein PHPBB auf meinem Webspace zum laufen gebracht. Das Board lief auch einwandfrei und machte nie Probleme. Seit gestern ist nun aber ohne das ich selbst was geändert habe oder so ein Problem da welches bei mir und auch bei den registrierten Benutzern auftritt:


Aufrufen des Boards funktioniert einwandfrei. Wird auch alles so dargestellt wie es sein soll. Allerdings ist man ausgeloggt. Beim Versuch sich einzuloggen erscheint oben über der Header Grafik folgender Code:

Code: Alles auswählen

Strict Standards: Non-static method utf_normalizer::nfkc() should not be called statically in /var/www/web56/html/phpbb/includes/utf/utf_tools.php on line 1663
[phpBB Debug] PHP Notice: in file /includes/session.php on line 1007: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1663)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 1007: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1663)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 1007: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1663)

Warning: Cannot modify header information - headers already sent by (output started at /var/www/web56/html/phpbb/includes/utf/utf_tools.php:1663) in /var/www/web56/html/phpbb/includes/functions.php on line 4183

Warning: Cannot modify header information - headers already sent by (output started at /var/www/web56/html/phpbb/includes/utf/utf_tools.php:1663) in /var/www/web56/html/phpbb/includes/functions.php on line 4185

Warning: Cannot modify header information - headers already sent by (output started at /var/www/web56/html/phpbb/includes/utf/utf_tools.php:1663) in /var/www/web56/html/phpbb/includes/functions.php on line 4186

Warning: Cannot modify header information - headers already sent by (output started at /var/www/web56/html/phpbb/includes/utf/utf_tools.php:1663) in /var/www/web56/html/phpbb/includes


Danach ist man wieder auf der Übersichtsseite, allerdings nicht eingeloggt. Bei der Liste der Benutzer welche zur Zeit online sind wird man aber aufgeführt. Jemand ne Idee was das sein könnte?

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 10256
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: Nichts gemacht doch plötzlich Fehlercode...

Beitragvon Crizzo » 18.02.2016 20:57

Hi,

welche PHP-Version hat dein Server?

Welches Forum-Version (phpBB) nutzt du?

Vermutlich ist deine Forum-Version zu alt und dein Webspace-Anbieter hat die PHP-Version auf dem Server aktualisiert. Da hilft nur phpBB updaten! 8)

Grüße

gerbozor
Mitglied
Beiträge: 63
Registriert: 04.09.2011 17:57

Re: Nichts gemacht doch plötzlich Fehlercode...

Beitragvon gerbozor » 18.02.2016 21:58

Gute Frage, nächste Frage.... Kann ich das auf die schnelle irgendwo sehen ohne mich im Board einzuloggen? Und wie führe ich ein Update durch ohne mich einzuloggen?

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 10256
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: Nichts gemacht doch plötzlich Fehlercode...

Beitragvon Crizzo » 18.02.2016 22:04

Die phpBB-Version kannst du rausfinden über diese Zeile https://github.com/phpbb/phpbb/blob/pre ... ts.php#L31 in der Datei: phpBB/includes/constants.php. Musst du eben mit deinem FTP-Programm auf dem Server die Datei runterladen. "phpBB" ist ein Beispiel, dein Forum kann auch in "forum" oder "kartoffel/" liegen. ;)

Die PHP-Version ist ein wenig schwieriger. Du musst eine Datei erstellen:

Code: Alles auswählen

<?php
phpinfo
();
?>


Und sie z.B. als phpinfo.php hochladen und mitm Browser ansurfen: www.example.org/forum/phpinfo.php Dort steht es dann. :)

Grüße

gerbozor
Mitglied
Beiträge: 63
Registriert: 04.09.2011 17:57

Re: Nichts gemacht doch plötzlich Fehlercode...

Beitragvon gerbozor » 18.02.2016 23:19

PHP Version 5.4.45-0+deb7u2


Und was das PHPBB betrifft:

// phpBB Version
define('PHPBB_VERSION', '3.0.9');

gerbozor
Mitglied
Beiträge: 63
Registriert: 04.09.2011 17:57

Re: Nichts gemacht doch plötzlich Fehlercode...

Beitragvon gerbozor » 19.02.2016 01:08

Hab das Board jetzt wieder laufen... Wie gehe ich nun am besten vor um auf die aktuellste Version zu springen?

Im Administratoren-Bereich wird mir angezeigt ich hätte 3.0.10, hab mir dann also das Update (3.0.10 -> 3.0.14) geladen und auf den Server entpackt. Wenn ich das Update starten will heißt es aber ich hätte 3.0.9. Lade ich mir ein Update für 3.0.9 auf eine höhere Version heißt es ich hätte 3.0.10.???


Edit:

Nachdem ich ein Update auf die nächste Version versucht habe geht nun gar nichts mehr... Sprich ich komme maximal wieder soweit wie im ersten Posting beschrieben. Board lässt sich aufrufen, einloggen geht nicht und der Fehlercode wird oberhalb des Headers angezeigt.

Edit 2: Der Kundendienst vom Webspace-Anbieter hat mir auf Nachfrage folgendes geschrieben:

Guten Tag,

wie wir Ihnen am 26.01.2016 angekündigt haben, wurde am 17.02 das System auf dem Ihr Webhostingpaket liegt aktualisiert, wodurch nun statt PHP5.3 nur noch PHP5.4 zur Verfügung steht.

Vermutlich wird die von Ihnen eingesetzte Version der Software noch nicht mit PHP5.4 kompatibel sein. Bitte prüfen Sie eigenständig welche schritte nötig sind, damit Ihre Software mit PHP5.4 funktionsfähig ist.



Also im Idealfall möchte ich da ich nun eh die Boardsoftware neu einrichten muss natürlich eine aktuelle Version einrichten. Wie gehe ich da nun am besten vor?

gerbozor
Mitglied
Beiträge: 63
Registriert: 04.09.2011 17:57

Re: Nichts gemacht doch plötzlich Fehlercode...

Beitragvon gerbozor » 19.02.2016 12:09

Das Board macht mich fertig lach.... Hab die Nacht den Webspace dann auf PHP 5.4 umgestellt. Die Umstellung dauert scheinbar ein wenig. Jetzt geht alles.

Derzeitige Version ist 3.0.10, möchte nun auf die aktuellste Version updaten. Direktes Upgrade möglich oder muss ich erst auf 3.0.14?

Mods (eigentlich nur Tapatalk Plugin) und ein Style (xandblue) installiere ich besser erst am Schluss nach den Updates?

Benutzeravatar
Mylady
Mitglied
Beiträge: 550
Registriert: 23.02.2009 16:29
Wohnort: Velbert (NRW)
Kontaktdaten:

Re: Nichts gemacht doch plötzlich Fehlercode...

Beitragvon Mylady » 19.02.2016 13:49

in dieser Anleitung wird gesagt, dass ein Update auf minimal 3.0.12 vorher sinnvoll ist.
Außerdem solltest du den MOD vorher ausbauen (schlimmstenfalls über STK das Board bereinigen), um Fehler nachher zu vermeiden, und alle Benutzer auf Standardstyle PROSILVER setzen. Andere Styles löschen -sie funktionieren nicht mehr mit dem neuen phpBB.

Solltest du eigene Gruppen angelegt haben, also Gruppen die nicht "dabei" waren, ist es nach meiner Erfahrung sinnvoll, diese zu löschen und vor der Konvertierung alle Benutzer nur bei "registrierte Benutzer" einzuordnen. Einschließlich Moderatoren/Administratoren.

MODs gibts nicht mehr - die heißen nun EXTENSIONEN für das neue phpBB.

In diesem Forum findest du schon eine große Menge Beiträge zur Konvertierung, zu den Problemen, die dabei aufgetreten sind, und zu den Problemen mit Tapatalk überhaupt.
https://ladyscommunity.de | Deutsche Übersetzungen für Extensionen (ggf. auf Anfrage)
-
Die Bosheit trinkt die Hälfte ihres eigenen Giftes (Lucius Annaeus Seneca)

gerbozor
Mitglied
Beiträge: 63
Registriert: 04.09.2011 17:57

Re: Nichts gemacht doch plötzlich Fehlercode...

Beitragvon gerbozor » 19.02.2016 15:21

Drückt mir die Daumen das dass hinhaut lach... :D Danke für den Tipp!

Benutzeravatar
gn#36
Ehrenadmin
Beiträge: 9271
Registriert: 01.10.2006 16:20
Wohnort: Ganz in der Nähe...
Kontaktdaten:

Re: Nichts gemacht doch plötzlich Fehlercode...

Beitragvon gn#36 » 19.02.2016 17:21

Es gab in den ersten Versionen ein paar unerklärbare Probleme beim Update von Versionen, die älter als 3.0.12 waren. Aber eigentlich sollte selbst ein Update von so steinalten Versionen wie 3.0.6 direkt gehen. Du kannst also einfach mal probieren, das Update direkt zu machen. Ich habe schon erfolgreiche Updates von älteren Versionen gesehen und alle phpBB Versionen ab 3.0.0 enthalten die Datenbankänderungen in Schritten von Version zu Version aller Vorgänger bis zurück nach 3.0.0, können das Datenbankupdate also im Grunde von jeder älteren Version, die mindestens 3.0.0 ist durchführen (ggf. auch noch etwas älter von ein paar 3.0.x Betas oder sowas).

Sprich: Bei einem Update auf 3.0.14 und dann auf 3.1.7-pl1 machst du das Datenbankupdate lediglich in zwei Teilschritten statt in einem großen Gesamtschritt. Die Änderungen die durchgeführt werden sind aber eigentlich die gleichen. Der Mechanismus ist aber nicht hundertprozentig identisch für Updates innerhalb der 3.0.x Reihe und 3.1.x - letztere nutzt Migrations, ersteres hat alle Befehle in einer Datei stehen. Inhaltlich sollten die Ergebnisse aber gleich sein, und das Update nach 3.1.x prüft so oder so ganz grob ab, ob die Datenbankänderungen schon drin sind. Sprich evtl. kannst du mit so einem Update sogar ein Unvollständiges Update innerhalb der 3.0.x reihe retten (aber nicht unbedingt).

Von phpBB 3.0.9 auf 3.0.10 gab es nur eine kleine Änderung an der DB: Es wurde eine neue Konfigurationsvariable eingeführt. Das beeinträchtigt den Betrieb einer älteren Version aber nicht, d.h. es kann durchaus sein, dass deine Dateiversion auf 3.0.9 war und die DB schon auf 3.0.10.
Begegnungen mit dem Chaos sind fast unvermeidlich, Aber nicht katastrophal, solange man den Durchblick behält.
Übertreiben sollte man's im Forum aber nicht mit dem Chaos, denn da sollen ja andere durchblicken und nicht nur man selbst.


Zurück zu „Support-Forum“