probleme bei upgrade von 3.0.5 auf 3.1.10

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
chbeyer
Mitglied
Beiträge: 6
Registriert: 25.02.2009 21:25

probleme bei upgrade von 3.0.5 auf 3.1.10

Beitragvon chbeyer » 05.01.2017 12:18

moin,

das leidige upgrade Thema, ich habe schon einiges probiert und brauche noch ein bischen Zeit bevor ich euch dann mit konkreten Sachen nerven kann bzw. vielleicht & hoffentlich gar nicht mehr nerven muss.

Das Forum ist schon aelter und ich weiss nicht mehr genau was ich an Modulen installiert habe, deshalb die Frage, wenn ich unter phpmyadmin gucke ist alles unter 'php_modules' Erweiterungen fuer module, richtig ?

Im acp finde ich auf anhieb nur das geomap modul, das habe ich mal installiert, den Rest muss ich dann im acp finden und loeschen oder kann ich auch einfach den kompletten inhalt von 'php_modules' loeschen mit phpmyadmin ?

Im moment versuche ich von 3.0.5 auf 3.0.14 zu migrieren (klappt) und dann auf 3.1.10 dabei endet die Datenbankmigration mit:


Die Datenbank wird auf die neueste Version aktualisiert

Datenbank-Typ :: mysql4
Vorherige Version :: 3.0.14
Die Konfigurationseinstellung „captcha_plugin“ existiert unerwarteterweise nicht.

Im web habe ich nichts dazu gefunden ausser zwei personen mit dem gleichen problem (ungeloest) vielleicht hat hier jemand einen heissen tipp (?)

Die bereinigung mit dem STK ist nicht hilfreich gewesen leider :(

Der eigentliche Grund zum updaten ist das mein hoster auf php 5.5 umstellt und da gibt es Probleme mit 3.0.x und nun wollte ich die Gelegenheit beim Schopf greifen und gleich upgraden.

Wenn es einen fix gaebe fuer die 3.0.x Varianten wuerde mir das etwas den Zeitdruck nehmen, daher waere ich da auch fuer Hinweise dankbar !

lg
christoph

chbeyer
Mitglied
Beiträge: 6
Registriert: 25.02.2009 21:25

Re: probleme bei upgrade von 3.0.5 auf 3.1.10

Beitragvon chbeyer » 05.01.2017 15:47

Hallo,

ich bin ein bischen weiter, nach dem STK databas bereinigungstool lande ich bei:

Datenbank-Typ :: mysql4
Vorherige Version :: 3.0.4
Die Migration wurde bereits erfolgreich durchgeführt (übersprungen): \phpbb\db\migration\data\v30x\release_3_0_0
Die Migration wurde bereits erfolgreich durchgeführt (übersprungen): \phpbb\db\migration\data\v30x\release_3_0_1_rc1
Die Migration wurde bereits erfolgreich durchgeführt (übersprungen): \phpbb\db\migration\data\v30x\release_3_0_1
Die Migration wurde bereits erfolgreich durchgeführt (übersprungen): \phpbb\db\migration\data\v30x\release_3_0_2_rc1
Die Migration wurde bereits erfolgreich durchgeführt (übersprungen): \phpbb\db\migration\data\v30x\release_3_0_2_rc2
Die Migration wurde bereits erfolgreich durchgeführt (übersprungen): \phpbb\db\migration\data\v30x\release_3_0_2
Die Migration wurde bereits erfolgreich durchgeführt (übersprungen): \phpbb\db\migration\data\v30x\release_3_0_3_rc1
Die Migration wurde bereits erfolgreich durchgeführt (übersprungen): \phpbb\db\migration\data\v30x\release_3_0_3
Die Migration wurde bereits erfolgreich durchgeführt (übersprungen): \phpbb\db\migration\data\v30x\release_3_0_4_rc1
Die Migration wurde bereits erfolgreich durchgeführt (übersprungen): \phpbb\db\migration\data\v30x\release_3_0_4
Installiere Schema: \phpbb\db\migration\data\v30x\release_3_0_5_rc1.
Installiertes Schema: \phpbb\db\migration\data\v30x\release_3_0_5_rc1; Dauer: 0.17 Sekunden
Richte Daten ein: \phpbb\db\migration\data\v30x\release_3_0_5_rc1.
Daten eingerichtet: \phpbb\db\migration\data\v30x\release_3_0_5_rc1; Dauer: 0.29 Sekunden
Installiere Schema: \phpbb\db\migration\data\v30x\release_3_0_5_rc1part2.
Installiertes Schema: \phpbb\db\migration\data\v30x\release_3_0_5_rc1part2; Dauer: 0.38 Sekunden
Richte Daten ein: \phpbb\db\migration\data\v30x\release_3_0_5_rc1part2.
Daten eingerichtet: \phpbb\db\migration\data\v30x\release_3_0_5_rc1part2; Dauer: 0.00 Sekunden
Installiere Schema: \phpbb\db\migration\data\v30x\release_3_0_5.
Installiertes Schema: \phpbb\db\migration\data\v30x\release_3_0_5; Dauer: 0.00 Sekunden
Richte Daten ein: \phpbb\db\migration\data\v30x\release_3_0_5.
Daten eingerichtet: \phpbb\db\migration\data\v30x\release_3_0_5; Dauer: 0.00 Sekunden
Installiere Schema: \phpbb\db\migration\data\v30x\release_3_0_6_rc1.
Installiertes Schema: \phpbb\db\migration\data\v30x\release_3_0_6_rc1; Dauer: 8.84 Sekunden
Richte Daten ein: \phpbb\db\migration\data\v30x\release_3_0_6_rc1.
Es existieren mehrere Module mit dem angegebenen übergeordneten Namen: ACP_FORUM_BASED_PERMISSIONS. Verwende die Nach-Oben-/Nach-Unten-Schaltflächen, um die Position des Moduls festzulegen.

Hmm, welche schaltflaechen, respektive was muss ich loeschen um das zu umgehen ?

Mein problem ist immer noch das ich nicht weiss welche module ich loeschen darf und welche nicht. Ich habe zwischenzeitlich mal den ganzen inhalt des phpbb_modules ordners geloescht, dann war das acp ganz verschwunden :(

Woran erkenne ich denn welche module 'weg' muessen ?

lg
christoph

Verschoben von [3.0.x] Administration, Benutzung und Betrieb nach Support-Forum am 05.01.2017 19:59 durch Crizzo


Zurück zu „Support-Forum“