Änderung von Text in allen Beiträgen

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Benutzeravatar
Rätselfreund
Mitglied
Beiträge: 353
Registriert: 28.09.2008 21:55
Kontaktdaten:

Änderung von Text in allen Beiträgen

Beitragvon Rätselfreund » 14.02.2017 16:40

Hallo,

es gibt ja hier den Tipp, wie man Text in allen Beiträgen ändern kann:

SQL: Änderung von Texten in allen Beiträgen

Das scheint aber nur für reine Texte und nicht für URLs zu gelten.

Wie kann ich per SQL einen Link in einem Beiträg ändern?

Beispiel:

Code: Alles auswählen

http://www.example.com/test.html


soll geändert werden in

Code: Alles auswählen

https://www.example.com/test.html


Gruß

Cujo

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11448
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: Änderung von Text in allen Beiträgen

Beitragvon Mahony » 14.02.2017 17:08

Hallo
Das macht man so

Code: Alles auswählen

UPDATE phpbb_posts SET post_text = REPLACE(post_text, 'http:', 'https:') WHERE post_text LIKE '%http:%';

Das funktioniert allerdings nur bei Links die nicht in BBCode URL verwendet werden.

Wenn auch diese Links geändert werden sollen, dann geht das so

Code: Alles auswählen

UPDATE phpbb_posts SET post_text = REPLACE(post_text, 'http:', 'https:') WHERE post_text LIKE '%http:%';


Für die komplette URL sähe das dann so aus

Code: Alles auswählen

UPDATE phpbb_posts SET post_text = REPLACE(post_text, 'http://www.example.com/test#46;html', 'https://www.example.com/test#46;html') WHERE post_text LIKE '%http://www.example.com/test#46;html%';


Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

Benutzeravatar
Rätselfreund
Mitglied
Beiträge: 353
Registriert: 28.09.2008 21:55
Kontaktdaten:

Re: Änderung von Text in allen Beiträgen

Beitragvon Rätselfreund » 15.02.2017 09:59

Ja, es ging mir um die URL-Tags.

Hat alles funktioniert. Vielen Dank für die Hilfe :grin:


Zurück zu „Support-Forum“