[3.2] Cache leeren im ACP unter 3.2.x führt zu weißer Index-Seite

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Max Weber
Mitglied
Beiträge: 8
Registriert: 19.03.2017 21:18

[3.2] Cache leeren im ACP unter 3.2.x führt zu weißer Index-Seite

Beitragvon Max Weber » 19.03.2017 21:25

Hallo Leute
Ein paar Freunde und ich sind gerade dabei ein Forum neu aufzubauen, alles ist fast fertig nur ein schlimmer Bug nervt uns noch da bitte ich um Hilfe:
Weil wir Schwierigkeiten mit den vom Forum versendeten Mails lösen wollten gab es die Idee doch mal den Cache zu leeren, da die Texte evtl noch daraus geladen wurden. Das hab ich brav gemacht, erhielt eine Erfolgsmeldung und dann ging gar nihcts mehr, man bekam beim Aufruf des Forums nur noch eine leere weiße Seite als index.php präsentiert.
Bitte dringend um Hilfe!

Benutzeravatar
vfrblue
Junior Supporter
Beiträge: 717
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: [3.2] Cache leeren im ACP unter 3.2.x führt zu weißer Index-Seite

Beitragvon vfrblue » 19.03.2017 22:09

Ein Link zum Forum wäre hilfreich.
Gruß Hermann

Forum VFR-OC
User: phpbbtest PW: vfroc

Max Weber
Mitglied
Beiträge: 8
Registriert: 19.03.2017 21:18

Re: [3.2] Cache leeren im ACP unter 3.2.x führt zu weißer Index-Seite

Beitragvon Max Weber » 19.03.2017 22:18

vfrblue hat geschrieben:Ein Link zum Forum wäre hilfreich.

Äh, was würde dir das bringen ohne auch direkt Admin-Zugang zu haben?

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 2017
Registriert: 15.10.2012 03:27

Re: [3.2] Cache leeren im ACP unter 3.2.x führt zu weißer Index-Seite

Beitragvon Melmac » 19.03.2017 22:56

Hi,

mit den richtigen Tools kann auch manchmal eine "weiße Seite" sehr viel erzählen :wink:

Solche "Erscheinungen" liegen oft auch in unterdrückten PHP-Fehlern begründet, von daher wären zusätzlich auch die entsprechenden Errorlogeinträge (des Servers) hilfreich. Diese müsstest Du normalerweise über das cPanel Deines Hostingaccounts aufrufen können. Falls nicht, kann Dir Dein Hoster bestimmt weiter helfen.
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

Max Weber
Mitglied
Beiträge: 8
Registriert: 19.03.2017 21:18

Re: [3.2] Cache leeren im ACP unter 3.2.x führt zu weißer Index-Seite

Beitragvon Max Weber » 20.03.2017 19:45

Melmac hat geschrieben:Hi,

mit den richtigen Tools kann auch manchmal eine "weiße Seite" sehr viel erzählen :wink:

Na dann... ich hab euch beiden mal nen Link geschickt. Nach dem letzten Crash haben wir allerdings längst ein Backup aufgespielt, sodass aktuell keine weiße Seite da ist. Jedoch erhielten wir den Hinweis, dass der Bug mithilfe irgendwie fehlerhafter Templates zu reproduzieren sei. Vielleicht ein nützlicher Hinweis. :(

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 2017
Registriert: 15.10.2012 03:27

Re: [3.2] Cache leeren im ACP unter 3.2.x führt zu weißer Index-Seite

Beitragvon Melmac » 20.03.2017 21:28

Ein paar Anmerkungen hierzu vorweg, okay?

Die Seite läuft über https, ist aber nicht korrekt konfiguriert:
xxxx verwendet ein ungültiges Sicherheitszertifikat.
Das Zertifikat kommt nicht von einer vertrauenswürdigen Quelle.

Ist es selbst erstellt?

Die Cookieeinstellungen sind ebenfalls nicht korrekt:
- Bei der Cookie Domain fehlt der führende Punkt => .deine-adresse.tld
- wenn schon https dann vielleicht auch sichere Cookies aktivieren

Max Weber hat geschrieben:Nach dem letzten Crash haben wir allerdings längst ein Backup aufgespielt, sodass aktuell keine weiße Seite da ist

Analogon: Du willst Dein Auto wegen eines defekten Motors zur Untersuchung in die Werkstatt bringen, baust aber vorher noch schnell einen neuen/funktionierenden Motor ein (oder nimmst das des Nachbars mit) :D

Jetzt funktioniert ja alles, ergo gibt es auch jetzt nichts zu untersuchen :wink:

----------------------------------

Tante Edith:

Aktuell sehe ich ein 3.1.x Board (entweder 3.1.9 oder 3.1.10 - lässt sich nicht so eindeutig feststellen) ...
... Deine Fragen bezogen sich aber auf phpBB 3.2.0 ...

Ist das jetzt so zu interpretieren, dass Du nicht nur Änderungen an den txt Files der Mailbenachrichtigungen durchgeführt hast, sondern vorher auch noch ein Upgrade auf 3.2.0?
Wenn ja: wie hast Du dies durchgeführt?
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

Benutzeravatar
vfrblue
Junior Supporter
Beiträge: 717
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: [3.2] Cache leeren im ACP unter 3.2.x führt zu weißer Index-Seite

Beitragvon vfrblue » 20.03.2017 21:38

Was mich auch ein wenig stört, ist die User-und Passwort-Abfrage in der .htaccess zu hinterlegen. Diese ist eigentlich nur für den Web-Server gedacht.
Ich bevorzuge die Zugriffs-Abfrage über eine .htpasswd. Da kann ich auch mehrere User und Passwörter hinterlegen.
Gruß Hermann

Forum VFR-OC
User: phpbbtest PW: vfroc

Max Weber
Mitglied
Beiträge: 8
Registriert: 19.03.2017 21:18

Re: [3.2] Cache leeren im ACP unter 3.2.x führt zu weißer Index-Seite

Beitragvon Max Weber » 20.03.2017 21:42

Melmac hat geschrieben:Ein paar Anmerkungen hierzu vorweg, okay?

Die Seite läuft über https, ist aber nicht korrekt konfiguriert:
xxxx verwendet ein ungültiges Sicherheitszertifikat.
Das Zertifikat kommt nicht von einer vertrauenswürdigen Quelle.

Ist es selbst erstellt?

Die Cookieeinstellungen sind ebenfalls nicht korrekt:
- Bei der Cookie Domain fehlt der führende Punkt => .deine-adresse.tld
- wenn schon https dann vielleicht auch sichere Cookies aktivieren

Ah ja, das vergaß ich zu schreiben. Das zertifikat ist selbst erstellt und wird noch gegen ein ordentliches ausgetauscht. Das mit den Cookies muss ich an unseren Admin weitergeben, der liest hier mit.

Melmac hat geschrieben:
Max Weber hat geschrieben:Nach dem letzten Crash haben wir allerdings längst ein Backup aufgespielt, sodass aktuell keine weiße Seite da ist

Analogon: Du willst Dein Auto wegen eines defekten Motors zur Untersuchung in die Werkstatt bringen, baust aber vorher noch schnell einen neuen/funktionierenden Motor ein (oder nimmst das des Nachbars mit) :D

Jetzt funktioniert ja alles, ergo gibt es auch jetzt nichts zu untersuchen :wink:

Oder wenn man krank ist und erst in 3 Monaten nen Arzttermin bekommt... Mal gucken, wann wir es das nächste mal testweise abschießen, evtl heute abend noch. Ich schreibe dann hier.

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 2017
Registriert: 15.10.2012 03:27

Re: [3.2] Cache leeren im ACP unter 3.2.x führt zu weißer Index-Seite

Beitragvon Melmac » 20.03.2017 21:48

Falls Dein Admin dies nicht bereits gefunden und gelesen hat: phpBB 3.2 - Upgrade von phpBB 3.1 :wink:
Solange es nicht zwingend erforderlich ist, nicht die Methode des automatischen Updates wählen.
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

Max Weber
Mitglied
Beiträge: 8
Registriert: 19.03.2017 21:18

Re: [3.2] Cache leeren im ACP unter 3.2.x führt zu weißer Index-Seite

Beitragvon Max Weber » 21.03.2017 22:21

vfrblue hat geschrieben:Ein Link zum Forum wäre hilfreich.

Melmac hat geschrieben:Hi,

mit den richtigen Tools kann auch manchmal eine "weiße Seite" sehr viel erzählen :wink:

Solche "Erscheinungen" liegen oft auch in unterdrückten PHP-Fehlern begründet, von daher wären zusätzlich auch die entsprechenden Errorlogeinträge (des Servers) hilfreich. Diese müsstest Du normalerweise über das cPanel Deines Hostingaccounts aufrufen können. Falls nicht, kann Dir Dein Hoster bestimmt weiter helfen.

Hey Leute mein geliiiebter Bug ist wieder da. Allerdings habe ich diesmal geschafft das Forum abzuschießen, indem ich den Standardstyle auf "prosilver" zurückgestellt hatte und danach die anderen Styles im ACP deinstalliert habe (mit der Option "Dateien vom Dateisystem löschen"). Es gab eine Erfolgsmeldung für alle Styles (Style deinstalliert) und eine Fehlermeldung für alle (Fehler beim löschen der dateien) und beim nächsten Klick zurück zur übersicht der Styles die bekannte weiße Seite. Bitte guckt doch mal drauf. :(


Zurück zu „Support-Forum“