Problem bei der De-Installation von Extensionen

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
edge-admin
Mitglied
Beiträge: 59
Registriert: 07.03.2008 08:41

Problem bei der De-Installation von Extensionen

Beitragvon edge-admin » 31.08.2017 23:45

Ich habe ein Problem bei der De-Installation von Extensionen.

Da ich mein Forum phpbb3.1.10 mit Board 3 Portal auf sden Stand phpbb 3.2 bringen wollte, habe ich das dazugehörige Update eingespielt. Danach gab es aber diverse massive Fehler. Also dachte ich, machst Du alles nackig und entfernst die Extensionen. Danach wollte ich updaten auf phpbb 3.2.

Soweit, so gut.

Allerdings, bei der deinsatalltion gabs wieder Probleme. Das Deaktiveren gelang problemlos. Dann aber bei "Arbeitsdaten Löschen" gab es folgende Fehlermeldung:
Während der Anpassung der Datenbank ist etwas falsch gelaufen und ein Fehler aufgetreten. Die Änderungen, die vor dem Fehler durchgeführt wurden, wurden so weit wie möglich rückgängig gemacht. Du solltest jedoch prüfen, ob dein Board fehlerfrei funktioniert.
Ein erforderliches Modul existiert nicht: WWH_TITLE


Also, habe ich via FTP alle Extensionen gelöscht. Nun stehen die aber immer noch in der Berechtigungsseite unter Extensionen drinn, allerdings oder Möglichkeiten zum Deaktiveren oder aktivieren.

Wie kreige ich die Einträge weg?

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 2170
Registriert: 15.10.2012 03:27

Re: Problem bei der De-Installation von Extensionen

Beitragvon Melmac » 01.09.2017 01:23

edge-admin hat geschrieben:Da ich mein Forum phpbb3.1.10 mit Board 3 Portal auf sden Stand phpbb 3.2 bringen wollte, habe ich das dazugehörige Update eingespielt.

Welches Update meinst Du damit jetzt?
Hast Du versucht, noch vorm phpBB-Upgrade die Board3-Extension upzudaten?
In welcher Version (für 3.1 oder 3.2?) lag die Ext beim Löschen ihrer Dateien vor?



Die Reihenfolge des Vorgehens hätte so aussehen sollen:
  1. Alle Extensions zumindest deaktivieren => siehe phpBB 3.2 - Upgrade von phpBB 3.1
    Aufgrund der gegenüber phpBB 3.1 weiterentwickelten Codebasis kann es beim Einsatz bestimmter für 3.1 entwickelter Extensions zu Inkompatibilitäten beim Betrieb unter phpBB 3.2 kommen. Es wird daher angeraten, noch vor dem eigentlichen Upgrade die im Board installierten Extensions auf bestehende 3.2-Kompatibilität zu prüfen und gegebenenfalls zu deaktivieren oder, falls erforderlich, komplett zu deinstallieren.
    Gleiches gilt für neben prosilver vorhandene Styles.

    (Ist eine gute Gelegenheit zu prüfen, ob welche darunter sind, die weder unter 3.2 lauffähig sind noch für die bereits 3.2-Versionen in der Mache sind - es wäre dann nämlich eine Überlegung wert, diese noch vor dem Upgrade zu deinstallieren.)
  2. Alle Styles bis auf prosilver deinstallieren und entfernen
  3. Erst danach das phpBB-Upgrade durchführen
  4. Wenn dies durchgelaufen ist und phpBB fehlerfrei läuft, geht es an die Extensions:
    • Diejenigen updaten, für die es eine 3.2-Version gibt (wie dies im einzelnen geht, sollte bei den neuen Versionen vermerkt sein)
      Bei allen anderen in deren Supportbereichen nachprüfen/nachlesen, ob sie auch weiterhin unter 3.2 fehlerfrei funktionieren
    • Diejenigen von ihnen, die auch unter 3.2 laufen: eine nach der anderen wieder aktivieren und testen
    • Bei denen, die dann noch übrig bleiben: entweder Du lässt sie deaktiviert, in der Hoffnung, dass es demnächst ein passendes Update gibt, oder Du löscht die Arbeitsdaten und entfernst sie

Die Dateien/Ordner der Extensions immer erst dann löschen, wenn sie vorher auch vollständig deinstalliert wurden, sonst gibt es zwangsläufig das Problem, vor dem Du jetzt stehst.

Lade sie alle wieder hoch und setze danach die unterbrochene Deinstallation fort, indem Du ihre Arbeitsdaten löscht.

btw.: Hast Du Backups der DB und der Ordner/Dateien der phpBB-Installation gemacht, bevor Du mit allem angefangen hast?
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

edge-admin
Mitglied
Beiträge: 59
Registriert: 07.03.2008 08:41

Re: Problem bei der De-Installation von Extensionen

Beitragvon edge-admin » 01.09.2017 20:41

Ich schreibe das morgen mal detailiert auf, das ist sicher sinnvoll.


Zurück zu „Support-Forum“