Seite 1 von 2

[3.2] Update von 3.1 auf 3.2 Timeout unter Xampp

Verfasst: 02.10.2017 11:04
von Death Star
Hallo Zusammen.
Da ich unser Forum bald auf die aktuelle Forenversion Updaten möchte so spiele ich die Routine gerade mit Hilfe von xampp in der neusten Version durch. Das Livesystem unter 3.1 konnte ich mit Eurer Hilfe erfolgreich ins Testsystem einpflegen: viewtopic.php?f=150&t=240277&start=10

Ich habe mich beim Update auf Version 3.2 an dieser Anleitung gehalten: https://www.phpbb.de/kb/phpBB32_upgrade_from_31
Leider erhalte ich dennoch Timeoutfehler:

[ externes Bild ]

Erst nach mehrmaligen aktualisieren des Browsers und neu starten der Routine lief das Update durch:

[ externes Bild ]

Jetzt bin ich ein wenig nervös das ich beim Update am Livesystem Probleme bekommen könnte.

Was meint Ihr ?

LG Thorsten

Re: [3.2] Update von 3.1 auf 3.2 Timeout unter Xampp

Verfasst: 02.10.2017 11:20
von Kirk
Hallo
Welche Update Methode hast du angewendet?

Re: [3.2] Update von 3.1 auf 3.2 Timeout unter Xampp

Verfasst: 02.10.2017 12:26
von Death Star
Manuelles Update wie in Schritt zwei der Anleitung....

Re: [3.2] Update von 3.1 auf 3.2 Timeout unter Xampp

Verfasst: 02.10.2017 12:50
von vfrblue
Es kann auch sein, dass in deiner lokalen Installation der Wert max_execution_time in der "php.ini" zu klein ist. Der Wert sollte mindestens "60" sein.
Das kannst du mit einer "phpinfo.php" überprüfen:

Code: Alles auswählen

<?
php phpinfo();
?>

Diese Datei kopierst du ins Root-Verzeichnis deiner Installation und rufst sie im Browser auf.
Im Live-Board hast du die Möglichkeit, diese Infos im ACP unter "PHP-Information" abzurufen.

Re: [3.2] Update von 3.1 auf 3.2 Timeout unter Xampp

Verfasst: 02.10.2017 18:19
von Death Star
Vielen Dank. Werde ich testen und berichten

Re: [3.2] Update von 3.1 auf 3.2 Timeout unter Xampp

Verfasst: 03.10.2017 07:43
von Death Star
vfrblue hat geschrieben:Es kann auch sein, dass in deiner lokalen Installation der Wert max_execution_time in der "php.ini" zu klein ist. Der Wert sollte mindestens "60" sein.
Das kannst du mit einer "phpinfo.php" überprüfen:

Code: Alles auswählen

<?
php phpinfo();
?>

Diese Datei kopierst du ins Root-Verzeichnis deiner Installation und rufst sie im Browser auf.
Im Live-Board hast du die Möglichkeit, diese Infos im ACP unter "PHP-Information" abzurufen.



Das aufrufen der erstellten Datei hat leider nicht geklappt.
Ich habe im Testsystem die Datei php.ini gefunden, diese zeigt den Wert 30 bei max_execution_time.

Im Backend des Livesystems konnte ich den Wert 60 finden.....

Gruß Thorsten

Re: [3.2] Update von 3.1 auf 3.2 Timeout unter Xampp

Verfasst: 03.10.2017 10:17
von chris1278
wenn du probleme hast die datei zu erstellen mache folgendes öffne einen einfachen texteditor. kann auch der editor von windows sein.

dort fügst du das:

Code: Alles auswählen

<?
php phpinfo();
?>


ein.

dann gehst du auf Datei speichern unter und als name gibst du ein "name.php" hierbei wichtig die anführungszeichen mit eingeben am anfang und am ende name kannst du wählen was du willst. das mit den anführungszeichen hat den vorteil das der die datei die du anlegen willst dann als name.php abspeichert egal was du als datei type ausgewält hast. wobei dieses vorgehen unter windows anzuwenden ist. ob das unter linux auch geht weis ich nicht.


kann sein das wenn du datei speichern unter machst und name.php ohne anführungszeichen schreibst der dann die datei endung anhängt die unter dateitype eingestellt ist. in nem editor bsp. .txt

Re: [3.2] Update von 3.1 auf 3.2 Timeout unter Xampp

Verfasst: 03.10.2017 10:43
von vfrblue
Den normalen Editor von Windows sollte man nicht verwenden, da dieser nicht die Anforderungen erfüllt: https://www.phpbb.de/kb/dateiedit

Der Wert "30" in deiner lokalen Installation kann zu niedrig sein. Bitte auf "60" ändern.

Re: [3.2] Update von 3.1 auf 3.2 Timeout unter Xampp

Verfasst: 03.10.2017 11:19
von Death Star
Hallo Zusammen, erneut, vielen Dank für die Tipps.

Beim nächsten Test mit dem Testsystem werde ich den Wert auf 60 erhöhen und schauen ob ich wieder einen Timeout erhalte.
Die Datei konnte/habe ich erstellt mit dme Editor Proton. Konnte sie nur nicht per Browser aufrufen. Sollte aber nun egal sein, da ich die Stellschraube gefunden habe, oder ?

Vorgreifend: Wenn ich das Update später im Livesystem durchführe, soll ich vorher oder nachher von PHP 5.6 auf 7.0 wechseln ?

LG Thorsten

Re: [3.2] Update von 3.1 auf 3.2 Timeout unter Xampp

Verfasst: 03.10.2017 11:28
von canonknipser
Death Star hat geschrieben: Konnte sie nur nicht per Browser aufrufen
Das liegt wohl daran, dass sie, so wie sie her steht:
chris1278 hat geschrieben:

Code: Alles auswählen

<?
php phpinfo();
?>



falsch ist und keine gültige php-Datei ist (auch wenn in den php-Einstellungen die veraltete Option "ShortOpenTags" noch aktiv ist).
sie muss so aussehen:

Code: Alles auswählen

<?php 
  phpinfo();
?>