[3.2] Anhänge und Avatare

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 927
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Anhänge und Avatare

Beitragvon canonknipser » 13.10.2017 21:40

vfrblue hat geschrieben:Dann muss dieses Verzeichnis die Zugriffsrechte "777" haben.

Jein, nur dann, wenn der hochladende Prozess und der Besitzer des Verzeichnisses nicht identisch sind. Siehe auch Was ist ein CHMOD?

notburga hat geschrieben:Und Codeschnipsel habe ich keine gesetzt, ausser die core.disable_super_globals: false
WARUM hast du das gemacht? Bei einem unmodifiziertem Board ist das nicht notwendig. Außer du hast eine veraltet programmierte Modifikation oder Extension im Einsatz, die die sogenannten "superglobals" $_POST, $GET, $_SERVER etc. anstelle der von phpBB bereitgestellten request-Klasse verwendet.

Ist vielleicht ein Verzeichnisschutz aktiv? Ist der Link im Profil korrekt? Hast du eine Fehlermeldung (404 = notfound, 403 = forbidden etc.) zu dieser Datei im server-Log - NICHT im phpBB-Log?

Da wir keinen Link und keinen Testuser zu deinem Board haben, ist das aktuell nur Glaskugelleserei.
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;)
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
notburga
Mitglied
Beiträge: 8
Registriert: 13.10.2017 13:01

Re: [3.2] Anhänge und Avatare

Beitragvon notburga » 14.10.2017 10:35

Hallo
Warum habe ich

Code: Alles auswählen

core.disable_super_globals: false
das geändert?
Weil nach dem Update die ganzen Dateianhänge nicht mehr sichbar waren und ich dann einen Beitrag von Mahony über die Fehlermeldung gefunden habe. Nach der Änderung waren die Dateianhänge auch sofort ok.

Ich habe nun einen AdminUser "Testadmin" angelegt.
Das Bord ist unter http://www.bsd-ev.com/phpBB3/ zu erreichen. Ddas Passwort reiche ich vielleicht über PN nach, oder ein Helfer registriert sich neu.
Wenn weitergehende FTP Zugang benötigt sein sollte, kann ich das auch einrichten.

Danke für jede Hilfe.

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 927
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Anhänge und Avatare

Beitragvon canonknipser » 14.10.2017 11:16

Das deutet für mich darauf hin, dass entweder ein zu strenger Verzeichnisschutz via .htaccess auf dieses Verzeichnis aktiv ist oder dein Webserver-User nicht berechtigt ist, in diesem Verzeichnis zu lesen. Ggf. spielt hier auch eine Sicherheitseinstellung deines Hosters einen Streich (open_basedir o.ä.).
Die Berechtigungen für das Verzeichnis images/avatars/upload müssen auf 755 (oder 777), die für die Dateien in diesem Verzeichnis auf 644 (oder 666) stehen.

Du solltest auf jeden Fall zu der einer Datei mit _100.gif am Ende (das ist der Avatar deines User Nummer 100 = admin) in deinem Webserver-Error-Log oder -Zugriffs-Log eine entsprechende Fehlermeldung finden, die dir Genaueres mitteilt.

Kannst du mir mal einen Link auf den Tip von Mahony geben? Ich finde den nämlich aktuell nicht und kann darum auch nicht bewerten, in welchem Zusammenhang dieser gegeben wurde.
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;)
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
notburga
Mitglied
Beiträge: 8
Registriert: 13.10.2017 13:01

Re: [3.2] Anhänge und Avatare

Beitragvon notburga » 14.10.2017 12:55

Der Link dazu ist http://phpbb3.pytalhost.com/viewtopic.php?f=36&t=725
Ich hatte im Explorer die Illegal use of $_SERVER Fehlermeldung gefunden.
Wie gesagt, danach gingen die Anhänge sofort.

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 927
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Anhänge und Avatare

Beitragvon canonknipser » 14.10.2017 15:01

Dann hast du sicherlich auch diesen Satz gelesen:
Bei Einbindung eines externen PHP-Scriptes


Das ist das, was ich dir auch schon oben geschrieben habe
canonknipser hat geschrieben: Bei einem unmodifiziertem Board ist das nicht notwendig. Außer du hast eine veraltet programmierte Modifikation oder Extension im Einsatz, die die sogenannten "superglobals" $_POST, $GET, $_SERVER etc. anstelle der von phpBB bereitgestellten request-Klasse verwendet.
Zu den von dir verwendeten Erweiterungen hast du bisher nichts geschrieben ...


Also, überprüfe doch bitte die Fehlermeldungen in deinem Server-Log zu den Avatar-Dateien.
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;)
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
notburga
Mitglied
Beiträge: 8
Registriert: 13.10.2017 13:01

Re: [3.2] Anhänge und Avatare

Beitragvon notburga » 14.10.2017 17:13

Hallo,
ih habe keinerlei Extensions geladen.
Das Board läuft mit Standard Prosilver.

So, Server log gibt manchmal folgendes preis:
[Sat Oct 14 10:48:27.816011 2017] [access_compat:error] [pid 817:tid 139954881902336] [client 217.88.58.81:41894] AH01797: client denied by server configuration: /usr/www/users/bsdtec/cms27/phpBB3/images/avatars/upload/100_1507911877.gif

Dies würde Deine Vermutung stützen.
Welche Einstellung könnte das sein, damit ich mit dem Hoster checken kann?

Ich glaube danach kann ich wieder die core.disable_super_globals: false auf true stellen. War wohl etwas irreführend.

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 927
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Anhänge und Avatare

Beitragvon canonknipser » 14.10.2017 17:42

Das liegt möglicherweise an der .htaccess in den entsprechenden Verzeichnissen - du schriebst ja, du hättest gemäß Anleitung von einer 3.0.-Version upgedatet.
Also: ersetze die .htaccess in den Verzeichnissen files und images/avatars/upload durch die entsprechenden Dateien aus dem Komplettpaket.

Wenn das nicht hilft, schau mal ob du z.B. hier Google-Suche eine Lösungsmöglichkeit findest, ggf. in Zusammenarbeit mit deinem Hoster
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;)
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
notburga
Mitglied
Beiträge: 8
Registriert: 13.10.2017 13:01

Re: [3.2] Anhänge und Avatare

Beitragvon notburga » 15.10.2017 21:55

Zunächst vielen Dank für die Hilfe.

Das Thema ist beendet.
Ich habe das Board nochmal neu installiert auf neues Verzeichnis und die alte Datenbanken übertragen.
Dann die diversen Anhänge und Bilder kopiert und alle Einstellungen nochmal gecheckt.

Das war dann von Erfolg gekrönt.
Die eigentliche Ursache lag sicher nicht bei den Servereinstellungen.
Ich kenn den Grund nicht.

:oops: :grin:


Zurück zu „Support-Forum“