Probleme beim Update

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Benutzeravatar
Mahony
Ehemaliger
Beiträge: 10940
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: Probleme beim Update

Beitragvon Mahony » 19.10.2017 15:37

Hallo
sani007 hat geschrieben:auf 3.2.1 aber mit dem komplette paket

Ich nehme an, dein altes Forum basiert auf phpBB 3.0.x ?
Dann nimm mal diese Anleitung >>> phpBB 3.2 - Upgrade von phpBB 3.0

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

sani007
Mitglied
Beiträge: 12
Registriert: 04.12.2015 18:48

Re: Probleme beim Update

Beitragvon sani007 » 19.10.2017 15:47

Jetzt kommt die Fehlermeldung:

Die Installations-Routine hat eine Zeitüberschreitung festgestellt
Die Installations-Routine hat festgestellt, dass eine Zeitüberschreitung aufgetreten ist. Du kannst versuchen, die Seite neu zu laden — dies kann aber zu einer Daten-Korruption führen. Wir empfehlen dir, entweder das Limit für eine Zeitüberschreitung (Timeout) zu erhöhen oder die Kommandozeile (CLI) zu verwenden.

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 10940
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: Probleme beim Update

Beitragvon Mahony » 19.10.2017 16:04

Hallo
Versuche es zuerst einmal mit der Aktualisierung der Seite, bis das Datenbank-Update durch ist.
Ansonsten bleibt dir nur, das Backup einzuspielen, die max_execution_time (Standard sind hier 30 Sekunden - also erhöhen auf z.B. 60 Sekunden) zu erhöhen (oder erhöhen zu lassen) und es dann erneut zu versuchen.

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

sani007
Mitglied
Beiträge: 12
Registriert: 04.12.2015 18:48

Re: Probleme beim Update

Beitragvon sani007 » 19.10.2017 16:30

Wo muss ich die zeit verländern? weil das kommt immer innehalb von 2 sek,

Php.ini ist wo normalerweise zu finden?

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 10940
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: Probleme beim Update

Beitragvon Mahony » 19.10.2017 17:10

Hallo
Wende dich bitte an deinen Hoster und schildere ihm die Sachlage und bitte ihn das Limit (die max_execution_time) zu erhöhen.

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

sani007
Mitglied
Beiträge: 12
Registriert: 04.12.2015 18:48

Re: Probleme beim Update

Beitragvon sani007 » 19.10.2017 17:22

Das haben sie über die .htaccess gemacht. aber die Fehlermeldung kommt gleich wieder nach 2 sek. hat nichts daran geändert


php_value max_execution_time 60
<IfModule mod_rewrite.c>
RewriteEngine on

#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/20 ... pache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
<IfVersion < 2.4>
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>
</IfVersion>
<IfVersion >= 2.4>
<Files "config.php">
Require all denied
</Files>
<Files "common.php">
Require all denied
</Files>
</IfVersion>
</IfModule>
<IfModule !mod_version.c>
<IfModule !mod_authz_core.c>
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>
</IfModule>
<IfModule mod_authz_core.c>
<Files "config.php">
Require all denied
</Files>
<Files "common.php">
Require all denied
</Files>
</IfModule>
</IfModule>

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 10940
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: Probleme beim Update

Beitragvon Mahony » 19.10.2017 17:33

Hallo
Versuche mal folgendes:

1. Das cache Verzeichnis leeren NICHT LÖSCHEN SONDERN LEEREN (per FTP-Programm ALLES außer der .htaccess und der index.htm löschen).

2. Das vendor-Verzeichnis vom Server löschen und mit dem vendor-Verzeichnis aus dem Komplettpaket ersetzen.

3. Das install-Verzeichnis vom Server löschen und mit dem install-Verzeichnis aus dem Komplettpaket ersetzen.

4. Die Datei store/install_config.php löschen.

Und das ganze bitte mit dem Komplettpaket.


Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

sani007
Mitglied
Beiträge: 12
Registriert: 04.12.2015 18:48

Re: Probleme beim Update

Beitragvon sani007 » 19.10.2017 17:49

Hallo

Im store hatte ich keine Datei install_config.php.

Die anderen spiele ich wieder hinauf. hab jetzt die Zip Datei noch mal runtergeladen. Aber diese Dateien sind vom komplettt paket schon..... Hab ja alles bis auf files und Imagenes gelöscht gehabt....
lg.

Update:

Leider noch immer die Fehlermeldung
Die Installations-Routine hat eine Zeitüberschreitung festgestellt
Die Installations-Routine hat festgestellt, dass eine Zeitüberschreitung aufgetreten ist. Sie können versuchen, die Seite neu zu laden — dies kann aber zu einer Daten-Korruption führen. Wir empfehlen Ihnen, entweder das Limit für eine Zeitüberschreitung (Timeout) zu erhöhen oder die Kommandozeile (CLI) zu verwenden.

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 10940
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: Probleme beim Update

Beitragvon Mahony » 19.10.2017 18:22

Hallo
Dann erhöhe eben das Limit noch einmal.
In der. htaccess musst du folgenden Eintrag ändern

php_value max_execution_time 60

nach

php_value max_execution_time 120


Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

sani007
Mitglied
Beiträge: 12
Registriert: 04.12.2015 18:48

Re: Probleme beim Update

Beitragvon sani007 » 19.10.2017 22:48

Ja aber der Fehler kommt gleich nach 2 Sekunden


Zurück zu „Support-Forum“