[3.2] Ext-Problem nach Update auf 3.2.1

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11009
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Ext-Problem nach Update auf 3.2.1

Beitragvon Mahony » 21.11.2017 18:10

Hallo
eumelchen hat geschrieben:Kann da was beim Datenbank-Upgrade passiert sein?

Liest du eigentlich auch, was man dir schreibt?

Da es den von dir genannten String Standardmäßig nicht gibt, muss er demnach nachträglich eingefügt worden sein (vermutlich stammt er von einer Extension).

Also suche nach dem String und schau woher er kommt. Falls von einer Extension, dann deaktiviere diese Extension testweise.

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 9362
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: [3.2] Ext-Problem nach Update auf 3.2.1

Beitragvon Crizzo » 21.11.2017 20:11

Mahony hat geschrieben:Hallo
Wahrscheinlich funkt da eine Extension dazwischen.
In einem Standard-phpBB 3.2.1 - Forum gibt es keinen solchen String in den Sprachdateien
Die Information über die aktuelle Version enthält eine ungültige Version



Doch!
Und zwar in: phpBB-3.2.1-deutsch\phpBB3\language\de\acp\common.php: ca. Zeile 450

Code: Alles auswählen

   'VERSIONCHECK_INVALID_ENTRY'   => 'Die Information über die aktuelle Version enthält einen nicht unterstützten Eintrag.',
   'VERSIONCHECK_INVALID_URL'      => 'Die Information über die aktuelle Version enthält eine ungültige URL.',
   'VERSIONCHECK_INVALID_VERSION'   => 'Die Information über die aktuelle Version enthält eine ungültige Version.',


Wird ausgegeben in der Funktion public function validate_versions in \phpbb\version_helper.php

Mal zurück zu deiner PHP-Config. Hast du Einsicht in die php.ini? Kannst du mal schauen, ob da Einträge bei disable_functions definiert sind, und wenn ja, welche?
phpBB Translations & International Support Teams Manager

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11009
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Ext-Problem nach Update auf 3.2.1

Beitragvon Mahony » 21.11.2017 20:20

Hallo
Crizzo hat geschrieben:Doch!
Und zwar in: phpBB-3.2.1-deutsch\phpBB3\language\de\acp\common.php: ca. Zeile 450

Ja stimmt...Sorry..ich hatte in phpBB 3.2.0 gesucht (ich hatte versehentlich das falsche Verzeichnis zum suchen ausgewählt :oops: ) und dort gab es den natürlich noch nicht.

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

eumelchen
Mitglied
Beiträge: 463
Registriert: 09.02.2008 08:28
Wohnort: Gottin

Re: [3.2] Ext-Problem nach Update auf 3.2.1

Beitragvon eumelchen » 08.12.2017 10:38

Hallo liebe Community,

leider habe ich mein Problem immer, gibt es denn Niemanden der eine Idee hat was die Ursache sein könnte,
oder besser gesagt wie die aktuelle Version wieder gelesen werden kann?

Es kommt ja keine Fehlermeldung, der Browser "rödelt" eine Zeit lang rum und nichts passiert.

Bei den vielen Extensions die ich eingebaut habe ist es sehr umständlich alle immer aktuell zu halten.

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1027
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Ext-Problem nach Update auf 3.2.1

Beitragvon canonknipser » 08.12.2017 11:15

Nach dem, was ich im Source von phpBB gefunden habe, wird zum Abruf der Versionsinformationen die Funktion fsockopen verwendet. Dort hat es scheinbar eine Änderung gegeben, das Transportprotokoll ist jetzt tls statt vorher ssl. Prüfe bitte mal, ob das Protokoll tls bei deinem Hosting-Paket aktiv ist (php-Inof im ACP, suche nach Stream Socket, dort sollten die Protokolle stehen).


Edit: Hast du auch mal in das Error-Log im ACP und das Error-Log deines Web-Servers geschaut? Vielleicht gibt es dort auch Hinweise ..
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;)
Kein Support via PN, nur im Board und (manchmal) im IRC

eumelchen
Mitglied
Beiträge: 463
Registriert: 09.02.2008 08:28
Wohnort: Gottin

Re: [3.2] Ext-Problem nach Update auf 3.2.1

Beitragvon eumelchen » 08.12.2017 11:19

Hallo canonknipser,

das steht bei mir:
Registered Stream Socket Transports
tcp, udp, unix, udg, ssl, sslv3, tls, tlsv1.0, tlsv1.1, tlsv1.2

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1027
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Ext-Problem nach Update auf 3.2.1

Beitragvon canonknipser » 08.12.2017 11:20

Ich hatte noch einen Edit nachgesetzt:

canonknipser hat geschrieben:Edit: Hast du auch mal in das Error-Log im ACP und das Error-Log deines Web-Servers geschaut? Vielleicht gibt es dort auch Hinweise ..
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;)
Kein Support via PN, nur im Board und (manchmal) im IRC

eumelchen
Mitglied
Beiträge: 463
Registriert: 09.02.2008 08:28
Wohnort: Gottin

Re: [3.2] Ext-Problem nach Update auf 3.2.1

Beitragvon eumelchen » 08.12.2017 12:35

Im ACP ist der Error-Log leer und auf dem Webserver kann ich auch keinen Fehler für die Forums-Domain sehen.

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1027
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Ext-Problem nach Update auf 3.2.1

Beitragvon canonknipser » 08.12.2017 12:43

Such mal im Log nicht nach der Forums-Domain, sondern nach version.phpbb.com - das ist die Domain, wo die Versionsdaten gehostet werden
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;)
Kein Support via PN, nur im Board und (manchmal) im IRC

eumelchen
Mitglied
Beiträge: 463
Registriert: 09.02.2008 08:28
Wohnort: Gottin

Re: [3.2] Ext-Problem nach Update auf 3.2.1

Beitragvon eumelchen » 08.12.2017 13:02

canonknipser hat geschrieben:Such mal im Log nicht nach der Forums-Domain, sondern nach version.phpbb.com - das ist die Domain, wo die Versionsdaten gehostet werden

Das kann ich den Server-Logs nicht finden.
Ich habe jetzt noch einmal versucht im ACP die Extension-Versionen abzurufen.
Bei den Fehler-Logs war kein Eintrag, bei den "Laufenden Access-Files" habe ich zu dem Versions-Abfrage-Zeitpunkt folgende Zeile gefunden:
[08/Dec/2017:12:53:00 +0100] "GET /adm/index.php?i=acp_extensions&sid=644a5345a442be93a340f1dec12024bf&mode=main&action=list&versioncheck_force=1 HTTP/1.1" 200 43117 "http://chiforum.de/adm/index.php?sid=644a5345a442be93a340f1dec12024bf&i=acp_extensions&mode=main" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0" "chiforum.de"


Zurück zu „Support-Forum“