[3.2] Fehler bei Vorschau im Admin-Bereich [gelöst]

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Antworten
Benutzeravatar
Wolkenbruch
Mitglied
Beiträge: 359
Registriert: 04.11.2010 16:56
Kontaktdaten:

[3.2] Fehler bei Vorschau im Admin-Bereich [gelöst]

Beitrag von Wolkenbruch » 12.01.2018 16:58

Hallo,

ich musste bei einem Mitglied eine unerlaubte Signatur ändern. Im Admin.Bereich habe ich dies über die Benutzer Verwaltung getan.

Nach Absenden der Vorschau kommt folgende Fehlermeldung:
Content-Encoding-Fehler
Die Webseite, die Sie öffnen möchten, kann nicht angezeigt werden, da sie eine ungültige oder unbekannte Form der Kompression verwendet.
Kontaktieren Sie bitte den Inhaber der Website, um ihn über dieses Problem zu informieren.
Das gleiche habe ich bei einem anderen Forum probiert - hier sieht die Fehlermeldung so aus:
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_content.php on line 789: A non-numeric value encountered
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_content.php on line 790: A non-numeric value encountered
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_content.php on line 791: A non-numeric value encountered
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 137: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3268)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 137: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3268)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 137: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3268)
Forenversion: 3.2.2
php Version: Forum 1 = 7.1.5 - Forum 2 = 7.1.11 nmm1

Absenden geht normal ohne Fehlermeldung.

Weiss jemand was?
Zuletzt geändert von Wolkenbruch am 12.01.2018 17:46, insgesamt 1-mal geändert.
Kolumbien Freunde treffen sich im » Kolumbienforum «

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 2053
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Fehler bei Vorschau im Admin-Bereich

Beitrag von canonknipser » 12.01.2018 17:29

Den Preview-Error kann ich bestätigen und ich habe glaube ich auch schon den Fehler gefunden.
Suche in includes/acp/acp_users.php (Zeile 2.100)

Code: Alles auswählen

                if ($request->is_set_post('preview'))
                {
                    $decoded_message = generate_text_for_edit($signature, $bbcode_uid, $bbcode_bitfield);
                }

 
Ersetze mit

Code: Alles auswählen

                if ($request->is_set_post('preview'))
                {
                    $decoded_message = generate_text_for_edit($signature, $bbcode_uid, $bbcode_flags);
                }

 

Ich mache ein Ticket auf.
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
Wolkenbruch
Mitglied
Beiträge: 359
Registriert: 04.11.2010 16:56
Kontaktdaten:

Re: [3.2] Fehler bei Vorschau im Admin-Bereich [gelöst]

Beitrag von Wolkenbruch » 12.01.2018 17:45

Funktioniert. Danke für den schnellen Fix ;-)
Kolumbien Freunde treffen sich im » Kolumbienforum «

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 2053
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Fehler bei Vorschau im Admin-Bereich [gelöst]

Beitrag von canonknipser » 31.01.2018 15:57

Ganz vergessen :o

Ticket: https://tracker.phpbb.com/browse/PHPBB3-15513
Pull-Request, gemerged in 3.2.3: https://github.com/phpbb/phpbb/pull/5097
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

Antworten

Zurück zu „Support-Forum“