[3.2] [Erledigt] Dringend Hilfe bei php-Problem benötigt

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Andimp3
Mitglied
Beiträge: 87
Registriert: 26.01.2018 13:00

Re: [3.2] Dringend Hilfe bei php-Problem benötigt

Beitragvon Andimp3 » 16.02.2018 00:24

Ist ja vorher auch mit dieser Config und dem gleichen Umfeld gelaufen... damit sollte es also nichts zu tun haben.

Das sind die fehlermeldungen die ich aktuell bekomme
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/db/driver/mysql.php on line 275: mysql_fetch_assoc(): 104 is not a valid MySQL result resource
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/db/driver/mysql.php on line 275: mysql_fetch_assoc(): 123 is not a valid MySQL result resource

Im moment überschreibe ich vom Installationspaket her die Daten auf dem Server (also nur die aus dem Paket)

Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 1924
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: [3.2] Dringend Hilfe bei php-Problem benötigt

Beitragvon Joyce&Luna » 16.02.2018 00:25

Schaue hier unter dem Abschnitt Glosar https://www.phpbb.de/kb/phpBB32_upgrade_from_30

Hast Recht, erst ab php 7
phpBB-Style-Design.de

Keine Antwort ist die eindeutigste Antwort, die man kriegen kann.
Bitte stellt die Fragen im Forum und nicht per PN. Danke!

Andimp3
Mitglied
Beiträge: 87
Registriert: 26.01.2018 13:00

Re: [3.2] Dringend Hilfe bei php-Problem benötigt

Beitragvon Andimp3 » 16.02.2018 00:29

Ich vestehe nicht was Du mir damit sagen willst.

Ich habe kein Update oder dergleichen gemacht, das Forum wurde vor etwas ca. 14 tagen eingerichtet und mysqli war da nie gesetzt.

Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 1924
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: [3.2] Dringend Hilfe bei php-Problem benötigt

Beitragvon Joyce&Luna » 16.02.2018 00:32

Ich habe nur bei mir verglichen, ich habe ein 3.1.7 Board noch am laufen wo php 5.6 läuft, da steht es auch schon auf mysqli.
Mit Plesk habe ich noch nie was zu tun gehabt, vielleicht meldet sich ein anderer dazu.
phpBB-Style-Design.de

Keine Antwort ist die eindeutigste Antwort, die man kriegen kann.
Bitte stellt die Fragen im Forum und nicht per PN. Danke!

Andimp3
Mitglied
Beiträge: 87
Registriert: 26.01.2018 13:00

Re: [3.2] Dringend Hilfe bei php-Problem benötigt

Beitragvon Andimp3 » 16.02.2018 00:34

Am Plesk sollte es nict liegen... das dient ja nur der Serververwaltung und da wurde nichts geändert. Fehlermeldung kommt ja auch von phpbb.

Da ich vorin nur das Hosting restored hatte versuche ich es jetzt mit einem Restore des kompletten Server... dann ist er wieder auf dem Stand von gestern 2:10 Uhr... danach sollte ich mit restore der Datenbank vom Abend und des Ordners /files vom Abend genau auf dem Stand sein wie er war bevor ich löschte ... ich hoffe es läuft dann wieder.

Ansonsten - werden ich wohl phpbb neu installieren und dann den Inhalt von httpdocs und der Datenbank aus dem Backup drüber kopieren.

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 3245
Registriert: 15.10.2012 03:27

Re: [3.2] Dringend Hilfe bei php-Problem benötigt

Beitragvon Melmac » 16.02.2018 01:02

Ändere trotzdem mal in der config.php den Datenbanktreiber auf mysqli und leere danach manuell den Cache.
mysql wurde zwar erst in PHP 7 endgültig in Rente geschickt, aber schaden kanns ja nicht.


Andimp3 hat geschrieben:bin noch auf php-Version 5.5.9

Kannst Du zumindest auf eine PHP 5.6.x Version umsteigen? 5.5 ist längst EoL und erhält keine Sicherheitsupdates mehr.
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

Andimp3
Mitglied
Beiträge: 87
Registriert: 26.01.2018 13:00

Re: [3.2] Dringend Hilfe bei php-Problem benötigt

Beitragvon Andimp3 » 16.02.2018 01:06

Update von php hatte ich eigentlich für WE geplant... ob ich da nach meinem Murks von heute Abend am WE Lust drauf habe werde ich dann sehen.

Aktuell läuft das komplette Restore des Servers... danach muss es wieder laufen.

Dump der Datenbank und auch alle Dateien aus httpdocs habe ich nochmal separat so dass ich damit ja dann auf den Stand von heute (mittleweile gestern) Abend kommen sollte.

Automatisch dem Beitrag hinzugefügt nach 2 Minuten 38 Sekunden. Bitte Regel für „Topic-Bumping“ beachten. Danke.

So Backup ist oben... ich würde nun wie folgt vorgehen:

Dump der Datenbank vom Abend wieder einspielen.

Inhalt von /files vom Abend wieder einspielen... damit sollten ja alle Beiträge Useranmeldungen usw wieder auf dem aktuellen Stand sein.

Automatisch dem Beitrag hinzugefügt nach 22 Minuten 43 Sekunden. Bitte Regel für „Topic-Bumping“ beachten. Danke.

Soderle... Problem gelöst alle Daten sind wieder da und das System läuft wie zuvor. Vielen Dank für die Unterstützung.


Zurück zu „Support-Forum“