[3.2] Probleme mit view exif

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1678
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Probleme mit view exif

Beitragvon canonknipser » 19.02.2018 18:18

Kannst du leider nicht, das können nur Mods und Supporter ;)


Musst du auf einen externen Webspace packen und dann als Image verlinken, oder in einfach mein Supportforum hochladen: http://canonknipser.com/viewforum.php?f=11 (User und Passwort stehen in den Forumsregeln)

Automatisch dem Beitrag hinzugefügt nach 21 Minuten 46 Sekunden. Bitte Regel für „Topic-Bumping“ beachten. Danke.

OK, danke, das sieht soweit gut aus (auch wenn 100px Kantenlänge für ein Vorschaubild etwas nach Briefmarke aussieht ;) ) - kannst du mir noch mal den Wert für "Maximale Dateigröße" unter "Board-Konfiguration" -> "Dateianhänge" nennen? Der muss auch mindestens 250KiB sein, kann aber auch ruhig größer sein.
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

bienhoff
Mitglied
Beiträge: 21
Registriert: 27.05.2015 10:03

Re: [3.2] Probleme mit view exif

Beitragvon bienhoff » 19.02.2018 18:44

habe dir noch ein Screenshots geschickt

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1678
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Probleme mit view exif

Beitragvon canonknipser » 19.02.2018 18:51

OK, das passt soweit.

Hast du noch eine Antwort zu
canonknipser hat geschrieben:sonstige Erweiterungen , die sich mit Bildern oder Anhängen befassen?
?
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

bienhoff
Mitglied
Beiträge: 21
Registriert: 27.05.2015 10:03

Re: [3.2] Probleme mit view exif

Beitragvon bienhoff » 19.02.2018 19:11

hab dir noch ein Screenshots geschickt.
Ist das wirklich die letzte Version die ich installiert habe?
Dort steht phpbb 3.1 und ist von 2017

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1678
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Probleme mit view exif

Beitragvon canonknipser » 19.02.2018 19:37

Ja, das ist die letzte Version. Ich habe die im Dezember 2017 eingereicht und sie ist kompatibel zu allen phpBB-Versionen ab Version 3.1.6-RC1, also auch zu 3.2.2
Ich habe mal deine Einstellungen auf einem frisch installierten phpBB 3.2.2 nachgestellt, als einzige Extension ist viewexif installiert und siehe da, keine Probleme.
Die Exif-Daten werden wie gewünscht angezeigt.

Wie gesagt, meine Vermutung ist, dass durch ein Problem im Upload-Prozess bereits die Exif-Daten verloren gehen.

Wie hast du denn den Update von 3.1 nach 3.2 gemacht?
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

bienhoff
Mitglied
Beiträge: 21
Registriert: 27.05.2015 10:03

Re: [3.2] Probleme mit view exif

Beitragvon bienhoff » 19.02.2018 19:42

FTP Programm = FileZilla

bis auf den Ordner images files und der config.php alles gelöscht und die neue Version rauf kopiert ....

soll ich das evtl noch mal machen?
Zuletzt geändert von bienhoff am 19.02.2018 20:24, insgesamt 1-mal geändert.

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1678
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Probleme mit view exif

Beitragvon canonknipser » 19.02.2018 19:59

ne, warte noch mal, ich gucke mir noch mal die code-changes an
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1678
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Probleme mit view exif

Beitragvon canonknipser » 19.02.2018 23:03

Wenn ich bei dir zum Upload javascript deaktiviere, werden die EXIF ohne Probleme angezeigt. Also liegt es definitiv nicht an der Extension, sondern an den javascript-Upload-Funktionen.
Ich habe die js-Scripte, soweit es mir möglich war, mit denen aus dem Originalpaket verglichen, die sind identisch.

Hast du nach dem Update den Cache via ACP geleert?

Mach das mal bitte. Ansonsten würde ich (morgen abend) auf dein Angebot mit dem acp-Zugang zurückkommen (kannst dem Benutzer canon einfach als "Gründer" markieren) dann kann ich mir das im ACP mal im Detail ansehen
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

bienhoff
Mitglied
Beiträge: 21
Registriert: 27.05.2015 10:03

Re: [3.2] Probleme mit view exif

Beitragvon bienhoff » 19.02.2018 23:24

den Cache wurde mehrmals via ACP geleert

Du bist als "Gründer" eingetragen

Verschoben von Extension Support nach Support-Forum am 20.02.2018 08:38 durch canonknipser

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1678
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Probleme mit view exif

Beitragvon canonknipser » 20.02.2018 08:38

ICE sei Dank habe ich ein bisschen Netz ;)
Ich habe mich mal bei dir in den ACP-Einstellungen umgesehen, teilweise etwas umkonfiguriert:
"Rekompilieren veralteter Style-Komponenten" war auf ein, das brauchst du nur, wenn du am Style bastelst und nicht jedesmal den Cache leeren musst. Erzeugt zusätzliche Last auf dem Server
Die maximal Größe für Dateianhänge habe ich auf 60MiB gesetzt, weil dein PHP eine upload_max_filesize von 65MB hat. 256MiB waren da zuviel.

Aber leider hat das nichts daran geändert, dass die Dateianhänge bei dir immer noch neu gerechnet werden.
Was klappt, ist die Dimensionsprüfung für Bild-Anhänge komplett abzuschalten. Dann wird das Bild nicht verändert.

Ich denke, das liegt an der veränderten Bild-Prüfungsroutine von marc (Image-Dimensionen aus den EXIF statt die echten Dimensionen). Da gibt es schon entsprechende Tickets zu, ich gucke mal, ob ich die finde.

Automatisch dem Beitrag hinzugefügt nach 12 Minuten 28 Sekunden.

Kannst du bitte mal folgende Datei aus deinem Board hier in das Pastebin packen
/vendor/marc1706/fast-image-size/lib/Type/TypeJpeg.php
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC


Zurück zu „Support-Forum“