[3.2] Probleme mit view exif

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
bienhoff
Mitglied
Beiträge: 21
Registriert: 27.05.2015 10:03

Re: [3.2] Probleme mit view exif

Beitragvon bienhoff » 20.02.2018 09:58

Datei hochgeladen ... hoffe es hat funktioniert

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1689
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Probleme mit view exif

Beitragvon canonknipser » 20.02.2018 19:50

Jupp, hat funktioniert.

Ich hab dann mal weiter gestöbert, möglicherweise funktioniert es mit dieser Lösung (ich kann es leider nicht testen, da ich bei mir die Probleme nicht habe):
Öffne vendor/marc1706/fast-image-size/lib/Type/TypeJpeg.php
Suche (Zeile 18)

Code: Alles auswählen

const JPEG_MAX_HEADER_SIZE = 124576

ersetze mit

Code: Alles auswählen

const JPEG_MAX_HEADER_SIZE = 62914560
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

bienhoff
Mitglied
Beiträge: 21
Registriert: 27.05.2015 10:03

Re: [3.2] Probleme mit view exif

Beitragvon bienhoff » 20.02.2018 20:05

nein leider nicht

Code geändert (habe nur ein ; ... oder sollten es zwei sein?
Cage gelert und probiert

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1689
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Probleme mit view exif

Beitragvon canonknipser » 20.02.2018 20:07

nur ein ; Tippfehler von mir


Dann muss ich mal weitersuchen
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1689
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Probleme mit view exif

Beitragvon canonknipser » 21.02.2018 12:39

Ich denke, ich habe es gefunden (warum ich das zuerst bei mir auf dem Testboard nicht nachstellen konnte? Kein Ahnung. Testboard noch mal frische installiert, dann konnte ich es nachstellen)

Ursache ist ein geändertes Verhalten der plUpload-Funktionen: Wenn der Quality-Parameter mitgegeben wird, wird ZWINGEND die Resize-Routine aufgerufen, auch wenn das Bild von den Maßen her passt.
Der Quality-Parameter ist fix in den Source codiert. Durch das Resize werden außerdem die Metadaten entfernt.
Also:
öffne phpbb/plupload/plupload.php
suche (Zeile 269):

Code: Alles auswählen

                'resize: {width: %d, height: %d, quality: 85},',
 

ersetze mit:

Code: Alles auswählen

                'resize: {width: %d, height: %d},',
 

(Quality-Parameter weg, der ist im plupload-Default bei 90)
Dann werden die Bilder nur dann verkleinert, wenn sich der User nicht an die vorgegebenen Dateigrößen hält, dabei muss allerdings in Kauf genommen werden, dass die Metadaten verloren gehen. Ich hab es auch mit dem Parameter preserve_headers versucht, aber scheinbar beachtet plupload den nicht korrekt.
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

bienhoff
Mitglied
Beiträge: 21
Registriert: 27.05.2015 10:03

Re: [3.2] Probleme mit view exif

Beitragvon bienhoff » 21.02.2018 18:15

vielen DANK

so funktioniert es auch mit eingeschalteter Überwachung

Wird die Änderung beim nächsten Update (3.2.2 nach 3.X.X) berücksichtigt
oder muss ich mir das merken?

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1689
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Probleme mit view exif

Beitragvon canonknipser » 21.02.2018 22:03

Freut mich, dass es geklappt hat. Ich versuche in den nächsten Tagen die erforderlichen Code-Changes einzureichen, dann sollte es bei den nächsten Releasen berücksichtigt werden ;)
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

bienhoff
Mitglied
Beiträge: 21
Registriert: 27.05.2015 10:03

Re: [3.2] Probleme mit view exif

Beitragvon bienhoff » 25.09.2018 16:51

Moin canonknipser,

habe gerade ein Update von 3.2.2 auf 3.2.3 gemacht .... und siehe da ... der Fehler (fehlende Exifdaten) ist wieder da.
Habe dann deinen gemachten Vorschlag befolgt und es funktioniert wieder.

bitte die erforderlichen Code-Changes einzureichen, damit es bei dem nächsten Release berücksichtigt werden kann.

Viele Grüsse aus Norden
Hans


Zurück zu „Support-Forum“