[3.2] CLI update

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Benutzeravatar
Mahony
Ehemaliges Teammitglied
Beiträge: 12044
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] CLI update

Beitrag von Mahony »

Hallo
tracer hat geschrieben:Werden eigentlich Extensions validiert, die sich "vorsätzlich" nicht an die Coding-Styleguides vom phpBB halten?
Nein, definitiv nicht.

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

Benutzeravatar
tracer
Mitglied
Beiträge: 87
Registriert: 02.12.2004 21:37
Wohnort: Kollmar
Kontaktdaten:

Re: [3.2] CLI update

Beitrag von tracer »

Mahony hat geschrieben:Hallo
tracer hat geschrieben:Werden eigentlich Extensions validiert, die sich "vorsätzlich" nicht an die Coding-Styleguides vom phpBB halten?
Nein, definitiv nicht.
OK, danke.

Ich werde meine Sachen eh durch meine eigene Infrastruktur vertreiben, schade ist es schon, wer auch immer sich die Styleguides ausgedacht haben mag …

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 2053
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] CLI update

Beitrag von canonknipser »

tracer hat geschrieben:Äh, nicht durch meins :)

Schau mal die Zeilen 290 bis 315 an. Da passiert genau das.
das kommt davon, wenn das im rüttelnden IC liest, da übersieht man mal schnell was. :oops:
tracer hat geschrieben:Werden eigentlich Extensions validiert, die sich "vorsätzlich" nicht an die Coding-Styleguides vom phpBB halten?
Ich finde die teilweise unzumutbar, und werde meinen Stil, den ich seit über 20 Jahre habe nicht ändern.
Na ja, es macht schon Sinn, für so große multinationale Projekte einheitliche und verbindlich Coding-Rules zu haben. Das gibt es nicht nur bei phpBB, sondern auch bei vielen anderen Projekten.
Kannst du im Detail sagen, was du an den aktuellen Regeln unzumutbar findest?
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
tracer
Mitglied
Beiträge: 87
Registriert: 02.12.2004 21:37
Wohnort: Kollmar
Kontaktdaten:

Re: [3.2] CLI update

Beitrag von tracer »

canonknipser hat geschrieben:
tracer hat geschrieben:Äh, nicht durch meins :)

Schau mal die Zeilen 290 bis 315 an. Da passiert genau das.
das kommt davon, wenn das im rüttelnden IC liest, da übersieht man mal schnell was. :oops:
:-)
tracer hat geschrieben:Werden eigentlich Extensions validiert, die sich "vorsätzlich" nicht an die Coding-Styleguides vom phpBB halten?
Ich finde die teilweise unzumutbar, und werde meinen Stil, den ich seit über 20 Jahre habe nicht ändern.
Na ja, es macht schon Sinn, für so große multinationale Projekte einheitliche und verbindlich Coding-Rules zu haben. Das gibt es nicht nur bei phpBB, sondern auch bei vielen anderen Projekten.
Ja, klar.
Aber ich lasse mir ungerne für mich unsinnige Regeln aufzwingen.
Kannst du im Detail sagen, was du an den aktuellen Regeln unzumutbar findest?
Klar. Aber das meiste steht hier schon drin:
https://www.kernel.org/doc/html/v4.10/p ... style.html

Also, für mich besonders relevant: Die Platzierung der brackets, die Benamsung der Variablen (da gehe ich mit Linus nicht da core, orientiere mich an den Vorgaben von Apple).

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 2053
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] CLI update

Beitrag von canonknipser »

Ich kenne die Vorgaben von apple nicht, und du hast da die Regeln für den Liniux-Kernel verlinkt ;) phpBB ist hier:
https://area51.phpbb.com/docs/32x/codin ... .html#code
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
tracer
Mitglied
Beiträge: 87
Registriert: 02.12.2004 21:37
Wohnort: Kollmar
Kontaktdaten:

Re: [3.2] CLI update

Beitrag von tracer »

canonknipser hat geschrieben:Ich kenne die Vorgaben von apple nicht, und du hast da die Regeln für den Liniux-Kernel verlinkt ;) phpBB ist hier:
https://area51.phpbb.com/docs/32x/codin ... .html#code
Danke, dass Du mir schreibst, was ich gemacht habe. :-)

Die vom Linux Kernel sind sinnvoll und gut zu lesen, die von phpBB sind nicht sinnvoll, die Syntax ist sehr schlecht zu lesen.

Darum werde ich mich auch nicht an die phpBB Styleguides halten.

Den Usern ist es egal, solange es funktioniert, und so kann ich meinen eigenen Code wenigstens vernünftig lesen.

Aber Du hast meine binäre Frage hinreichend beantwortet, das Für und Wider der Styleguides wurde andernorts sicher schon mehrfach diskutiert.

phpBB hat sich für eine Form entschieden, die werden das für mich nicht ändern, umgekehrt werde ich meinen Stil nicht ändern, da ich auch noch andere Sachen als phpBB mache.

Zu der mobiquo Sache:

Ja, Tapatalk bringt immer noch das eigene Verzeichnis mit. Warum auch immer, ich finde es unschön.
Ich habe aber auch kein Verständnis, warum man mit einem Handy im Forum unterwegs sein muss.
Muss ich aber auch nicht, aber man muss die Kunden da abholen, wo sie sind, also bekommen sie ihr Tapatalk.

Benutzeravatar
tracer
Mitglied
Beiträge: 87
Registriert: 02.12.2004 21:37
Wohnort: Kollmar
Kontaktdaten:

Re: [3.2] CLI update

Beitrag von tracer »

Sorry, habe den Server von Jessie auf Stretch gezogen, "nebenbei" gitlab von nginx auf apache umgestellt …
Irgendwas klappt mit dem gitlab noch nicht.

Ich hoffe, das heute Nacht wieder hinzubekommen.


Edit, OK, erledigt, die Doku vom gitlab ist wirklich etwas "eigen", wenn man den Apachen nehmen will …

Benutzeravatar
tracer
Mitglied
Beiträge: 87
Registriert: 02.12.2004 21:37
Wohnort: Kollmar
Kontaktdaten:

Re: [3.2] CLI update

Beitrag von tracer »

Noch mal eine Frage:

Gibt es ein "semaphore" oder so, an dem man erkennen kann, ob ein phpBB vom Original (.com) installiert wurde oder die schon eingedeutschte Version von .de?

Ich habe ein paar Änderungen am Script gemacht, wollte es jetzt gerne auch noch so überarbeiten, dass es mit beiden Versionen klarkommt.

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 10626
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: [3.2] CLI update

Beitrag von Crizzo »

Die beiden Pakete unterscheiden sich nur durch die zusätzlichen Sprachpakete z. B. language/de/ und language/de_x_sie/

Ergo sehe ich keine Probleme, die austreten sollten, wenn du Anpassung von A nach B bringst, wenn sie nicht nur das Sprachpaket betreffen.

Benutzeravatar
tracer
Mitglied
Beiträge: 87
Registriert: 02.12.2004 21:37
Wohnort: Kollmar
Kontaktdaten:

Re: [3.2] CLI update

Beitrag von tracer »

Crizzo hat geschrieben:
15.12.2019 16:32
Die beiden Pakete unterscheiden sich nur durch die zusätzlichen Sprachpakete z. B. language/de/ und language/de_x_sie/
Ok, danke. Ich hatte jetzt auch mal ein diff auf beide Verzeichnisse, Unterschiede wurden mir nur bei einigen SocialMedia-Profilfeldern angezeigt.
Ergo sehe ich keine Probleme, die austreten sollten, wenn du Anpassung von A nach B bringst, wenn sie nicht nur das Sprachpaket betreffen.
OK, ich sehe dann mal zu, dass ich das in Angriff nehme, derweil ziehe ich noch mein eigenes Board von 3.0.14 (sic) auf 3.2.8, und verliere dadurch leider ganz viele selbstgebaute Mods. :-( Aber einige werde ich als Extensions neu bauen …

Antworten

Zurück zu „Support-Forum“