[3.2] Fehlermeldung Erweiterung

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
wakeme
Mitglied
Beiträge: 14
Registriert: 20.12.2017 23:47

[3.2] Fehlermeldung Erweiterung

Beitragvon wakeme » 07.03.2018 17:08

Ich möchte die Erweiterung „RHTopicTags“ gern in mein Forum integrieren. Die Installation auf meiner Testseite führte zu einer großen Fehlermeldung. Hat jemand Erfahrungen mit der Erweiterung gemacht und läuft sie auf 3.2 ? Gibt's Alternativen ?

https://www.phpbb.com/customise/db/exte ... opic_tags/


Code: Alles auswählen

Fatal error: Uncaught exception 'Twig_Error_Loader' with message 'Unable to find template "@robertheim_topictags/../theme/rh_topictags.css" (looked into: /users/emtopi/www/forum/ext/robertheim/topictags/styles/all/template, /users/emtopi/www/forum/ext/robertheim/topictags/styles/all/template) in "@robertheim_topictags/css_includes.html" at line 12.' in /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:232 Stack trace: #0 /users/emtopi/www/forum/phpbb/template/twig/loader.php(135): Twig_Loader_Filesystem->findTemplate('@robertheim_top...') #1 /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Loader/Filesystem.php(150): phpbb\template\twig\loader->findTemplate('@robertheim_top...') #2 /users/emtopi/www/forum/phpbb/template/twig/environment.php(328): Twig_Loader_Filesystem->getCacheKey('@robertheim_top...') #3 /users/emtopi/www/forum/cache/production/twig/56/56070c21244669f03f48da4eceb5437b1cb23af813235854fb21bc16e0f43746.php(73): phpbb\template\twig\environment->findTemplate('@robertheim_top...') #4 /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Template.php(432): __TwigTemplate_9775ac404f43fca6babbef2a035a22b33acda4aa5a31f39c417226da39b90fc5->doDisplay(Array, Array) #5 /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Template.php(403): Twig_Template->displayWithErrorHandling(Array, Array) #6 /users/emtopi/www/forum/cache/production/twig/f8/f8fbe03c79aa0932ed78bae04a98b311d6b69f80366e6b80a5b955c4370bb070.php(26): Twig_Template->display(Array) #7 /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Template.php(432): __TwigTemplate_8fbf9de8116d288a558b1434e0b43cdf8347fd9432506a6eaca3253696c5c70f->doDisplay(Array, Array) #8 /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Template.php(403): Twig_Template->displayWithErrorHandling(Array, Array) #9 /users/emtopi/www/forum/cache/production/twig/1f/1f8e2d0c88ea0b940a4e25c83ca6d883df5ae4250ab6ddd297f91b02ef6e3dab.php(271): Twig_Template->display(Array) #10 /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Template.php(432): __TwigTemplate_83cd7708092d4b8b91070d in /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 232


Achja ich bekomme im ACP angezeigt, dass ein neues Update verfügbar ist. Ich blicke nicht durch wie das zu installieren ist und welches Packet ich auf der downloadseite herunterzuladen habe...

Benutzeravatar
vfrblue
Junior Supporter
Beiträge: 1080
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: [3.2] Fehlermeldung Erweiterung

Beitragvon vfrblue » 07.03.2018 17:19

Hier die Version für phpBB 3.2: https://github.com/RobertHeim/phpbb-ext-topictags
Gruß Hermann

Forum VFR-OC

wakeme
Mitglied
Beiträge: 14
Registriert: 20.12.2017 23:47

Re: [3.2] Fehlermeldung Erweiterung

Beitragvon wakeme » 07.03.2018 22:12

Vielen Dank. Jedoch bekomme ich auch bei dieser Version auch eine Fehlermeldung.


Code: Alles auswählen

Fatal error: Uncaught exception 'Twig_Error_Loader' with message 'Unable to find template "@robertheim_topictags/../theme/rh_topictags.css" (looked into: /users/emtopi/www/forum/ext/robertheim/topictags/styles/all/template, /users/emtopi/www/forum/ext/robertheim/topictags/styles/all/template) in "@robertheim_topictags/css_includes.html" at line 12.' in /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:232 Stack trace: #0 /users/emtopi/www/forum/phpbb/template/twig/loader.php(135): Twig_Loader_Filesystem->findTemplate('@robertheim_top...') #1 /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Loader/Filesystem.php(150): phpbb\template\twig\loader->findTemplate('@robertheim_top...') #2 /users/emtopi/www/forum/phpbb/template/twig/environment.php(328): Twig_Loader_Filesystem->getCacheKey('@robertheim_top...') #3 /users/emtopi/www/forum/cache/production/twig/56/56070c21244669f03f48da4eceb5437b1cb23af813235854fb21bc16e0f43746.php(73): phpbb\template\twig\environment->findTemplate('@robertheim_top...') #4 /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Template.php(432): __TwigTemplate_9775ac404f43fca6babbef2a035a22b33acda4aa5a31f39c417226da39b90fc5->doDisplay(Array, Array) #5 /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Template.php(403): Twig_Template->displayWithErrorHandling(Array, Array) #6 /users/emtopi/www/forum/cache/production/twig/f8/f8fbe03c79aa0932ed78bae04a98b311d6b69f80366e6b80a5b955c4370bb070.php(26): Twig_Template->display(Array) #7 /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Template.php(432): __TwigTemplate_8fbf9de8116d288a558b1434e0b43cdf8347fd9432506a6eaca3253696c5c70f->doDisplay(Array, Array) #8 /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Template.php(403): Twig_Template->displayWithErrorHandling(Array, Array) #9 /users/emtopi/www/forum/cache/production/twig/1f/1f8e2d0c88ea0b940a4e25c83ca6d883df5ae4250ab6ddd297f91b02ef6e3dab.php(271): Twig_Template->display(Array) #10 /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Template.php(432): __TwigTemplate_83cd7708092d4b8b91070d in /users/emtopi/www/forum/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 232

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 2911
Registriert: 15.10.2012 03:27

Re: [3.2] Fehlermeldung Erweiterung

Beitragvon Melmac » 07.03.2018 22:25

Hast Du nach der Installation den Board Cache geleert?
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

wakeme
Mitglied
Beiträge: 14
Registriert: 20.12.2017 23:47

Re: [3.2] Fehlermeldung Erweiterung

Beitragvon wakeme » 08.03.2018 00:31

Ja habe ich :(

wakeme
Mitglied
Beiträge: 14
Registriert: 20.12.2017 23:47

Re: [3.2] Fehlermeldung Erweiterung

Beitragvon wakeme » 10.03.2018 16:03

Niemand ne Idee ? :cry:

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11320
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Fehlermeldung Erweiterung

Beitragvon Mahony » 10.03.2018 16:18

Hallo
Es wird bemängelt, dass die theme/rh_topictags.css nicht gefunden wurde.
Ist die Datei auf dem Server vorhanden?

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

wakeme
Mitglied
Beiträge: 14
Registriert: 20.12.2017 23:47

Re: [3.2] Fehlermeldung Erweiterung

Beitragvon wakeme » 10.03.2018 16:40

Der Pfad stimmt möglicherweise nicht. Ich verwende prosilver nicht.

ext/topictags/styles/prosilver/theme/rh_topictags.css

Edit; Hab´s lösen können müsste den Ordner verschieben. Die Erweiterung funktioniert jedoch im Großen und Ganzen einfach nicht.
Hat jemand Erfahrungen mit möglichen alternativen ?

Andimp3
Mitglied
Beiträge: 85
Registriert: 26.01.2018 13:00

Re: [3.2] Fehlermeldung Erweiterung

Beitragvon Andimp3 » 19.03.2018 14:37

Ich habe die ext auch mal getestet... Tags hinterlegen ging ja noch. Postings finden für die ein bestimmtes Tag hinterlegt wurde ging über klicken des Tags in der Tag-Cloud - aber nach einem Tag über die Suchfunktion suchen ging nicht.

Somit leider unbrauchbar.

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 2911
Registriert: 15.10.2012 03:27

Re: [3.2] Fehlermeldung Erweiterung

Beitragvon Melmac » 19.03.2018 15:01

wakeme hat geschrieben:Ich verwende prosilver nicht.

Was genau bedeutet dieses "verwende ich nicht"?
prosilver ist aber noch installiert und zumindest deaktiviert vorhanden, oder?

wakeme hat geschrieben:Hab´s lösen können müsste den Ordner verschieben.

Auch hier: was genau meinst Du damit?

Wenn Dien Style X nicht prosilver ist und die Extension an X angepasst werden muss, dann musst Du normalerweise im styles Verzeichnis der Extension einen neuen Ordner mit dem Namen des von Dir verwendeten Styles anlegen und den Inhalt des bereits vorhandenen Ordners prosilver dort reinkopieren.
Danach kannst Du dann alle Anpassungen an den Dateien in diesem neuen stylespezifischen Ordner vornehmen.

wakeme hat geschrieben:Die Erweiterung funktioniert jedoch im Großen und Ganzen einfach nicht.

Falls Du Fragen zu den gezeigten Problemen haben solltest, wäre es auch sehr hilfreich, wenn Du angeben könntest, was genau da im einzelnen nicht funktioniert :wink:

Diese Extension liegt bisher nur in einer validierten Version in der CDB vor: für phpBB 3.1.
Was Du auf GitHub im master Branch findest, ist zwar für phpBB 3.2 vorgesehen, aber Du solltest dabei zwei Punkte berücksichtigen:
  • Diese Version ist noch nicht offiziell validiert und befindet sich daher noch in Entwicklung.
  • Die letzten Änderungen am Code stammen aus dem August 2016 ... wirklich aktiv scheint daran also nicht entwickelt zu werden.

Extensions in Entwicklung, insbesondere dann, wenn daran längere Zeit bereits nicht mehr gearbeitet wird, sind nicht für den Einsatz in einem Live Board zu empfehlen.
Wenn, dann installiert man sie auch nur auf eigenes Risiko - zumindest sollte man sie vorher dann aber auch bereits ausgiebig durchgetestet haben.
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)


Zurück zu „Support-Forum“