[3.2] Internal Server Error

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
ottischwenk
Mitglied
Beiträge: 153
Registriert: 28.02.2018 06:30

Re: [3.2] Internal Server Error

Beitrag von ottischwenk »

Was du jetzt nur noch machen musst: "Flat" via acp deaktivieren, deinstallieren und wieder installieren, damit die in der Datenbank eingetragene fehlerhafte Vererbung korrigiert wird.
Das war das Erste, was ich gemacht habe, nachdem ich wieder ins Forum gekommen bin.
Nochmals vielen Dank
Todi
Mitglied
Beiträge: 34
Registriert: 14.04.2013 16:50

Re: [3.2] Internal Server Error

Beitrag von Todi »

EDIT: Sorry ich bin ja [3.3.x]

Ich muss das wohl aufwärmen, weil ich einen 500er Error habe.
Ich habe mir somit die PHP Error Log File vom Hoster geholt und da stehen folgende Fehler:

Code: Alles auswählen

PHP Fatal error:  Uncaught Twig_Error_Loader: Unable to find template "message_body.html" (looked into: /data/web/e37133/html/BDS/styles/flat-style/template, /data/web/e37133/html/BDS/styles/flat-style/theme, /data/web/e37133/html/BDS/styles/all/template). in /data/web/e37133/html/BDS/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:232

Code: Alles auswählen

PHP Fatal error:  Uncaught Twig_Error_Loader: Unable to find template "chat_body.html" (looked into: /data/web/e37133/html/BDS/styles/flat-style/template, /data/web/e37133/html/BDS/styles/flat-style/theme, /data/web/e37133/html/BDS/styles/all/template) in "@spaceace_ajaxchat/event/index_body_markforums_after.html" at line 3. in /data/web/e37133/html/BDS/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:232

Und auch die Meldung vom Threadersteller.
Ich habe mir bereits die verwendeten style.cfg durchgesehen. Hier ist überall prosilver als parent gesetzt.

HTML Files habe ich vom Backup bereits neu eingespielt. Bei der Datenbank bin ich mir überhaupt nicht mehr sicher ob die .sql Datei noch die vor dem ganzen Chaos war.

Dieses verwendete SDK Tool - da ist leider der Link tot zum Testen. Welche Möglichkeiten gibt es den noch?

Danke Todi
Benutzeravatar
Scanialady
Junior Public Relations-Team
Beiträge: 871
Registriert: 23.02.2009 16:29
Wohnort: Velbert (NRW)
Kontaktdaten:

Re: [3.2] Internal Server Error

Beitrag von Scanialady »

Es scheint sich um eine fehlerhafte Chat-Extension zu handeln

"@spaceace_ajaxchat/event/index_body_markforums_after.html"

Ist die unter 3.3.x lauffähig? Update vergessen? Nicht wieder korrekt hochgeladen?
https://ladyscommunity.de | Deutsche Übersetzungen für Extensionen (ggf. auf Anfrage)
-
Die Bosheit trinkt die Hälfte ihres eigenen Giftes (Lucius Annaeus Seneca)
-
Wenn von etwas kein Backup existiert, dann ist es nicht wichtig.
Todi
Mitglied
Beiträge: 34
Registriert: 14.04.2013 16:50

Re: [3.2] Internal Server Error

Beitrag von Todi »

Der Ajax Chat glaub ich läuft mit 3.1 und 3.2. Jedoch hatte ich den schon bei 3.3.2 aktiviert gehabt im ACP jedoch im Forum selbst deaktiviert.
Die ganzen Ext kann ich gern alle irgendwie per FTP deaktivieren. Die sind alle nicht mehr zwingend erforderlich.

Aktuell möchte ich die defekten Verknüpfungen reparieren und den Fehler irgendwie nachstellen. Auch ich vermute, dass ich beim Theme FlagStyle die Vererbung geändert habe. Jedoch sagt das style.cfg etwas anderes.
Wüsste nicht, was ich noch gemacht habe. Ausschlaggebend war ein Auto Update, welches nicht funktioniert hat von 3.3.2 auf 3.3.3. Danach habe ich das Backup zurückgespielt und nach einer Zeit kam der 500er Error.

Ich werde mal die Ext. - sind 2 Stück - umbenennen und den Cache leeren. Eventuell kann ich da unnötige Fehler entfernen?!
Todi
Mitglied
Beiträge: 34
Registriert: 14.04.2013 16:50

Re: [3.2] Internal Server Error

Beitrag von Todi »

Ich habe nun ein neues Forum (v3.3.3) erstellt mit Prosilver und Flat Style und folgende Schritte wurden durchgeführt um hier irgendetwas zu schrotten.

- Flat Style installiert und aktiviert
- Board Einstellungen:
Standard-Style: Flat Style
Style für Gäste: Flat Style
Benutzer-Style überschreiben: Ja

Dann wieder zurück zu Style und bei Flat Style unter Details "geerbt von" auf "-" gestellt --> Kein Crash / Crash
Dann bei Flat Style ganz hinten den "Haken" setzen und "aktivieren" drücken und sobald man raus geht vom ACM gibt es einen 500er Fehler.

In der php_error.log sind die gleichen Fehler wie beim anderem Forum.
In der jeweiligen Style.cfg steht immer das gleiche:

Code: Alles auswählen

parent = prosilver
Kann ich nun das Problem irgendwie beheben oder ist das Forum nun kaputt?

Edit: Beim 2ten Versuch war der Crash beim umstellen auf geerbt von "-"
Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 7071
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: [3.2] Internal Server Error

Beitrag von Kirk »

Wenn du einstellst "geerbt von "-"" kommt es natürlich zu Fehlern weil dieser Style die Template Dateien von Prosilver benötigt.
Von daher sollte bei "geerbt von" prosilver stehen.
Todi
Mitglied
Beiträge: 34
Registriert: 14.04.2013 16:50

Re: [3.2] Internal Server Error

Beitrag von Todi »

Guten Morgen und schönen Oster Sonntag Krik,

das ist mir aktuell jetzt bewusst, jedoch ist jetzt die Frage wie ich der PHP Verknüpfung wieder sagen kann, dass in Prosilver gesucht werden soll und nicht in Flat Style.

EDIT:
Habe gestern in der php_config Tabelle noch den Default Style auf Prosilver gesetzt dann war zwar das Forum wieder da, jedoch konnte ich mich nicht einloggen. Habe dann den Cache wieder geleert und es wra wieder der 500er Error da
LG
Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 7071
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: [3.2] Internal Server Error

Beitrag von Kirk »

Geh in deiner Datenbank auf "phpbb_styles" und klicke bei Flat Style auf Bearbeiten, in der Spalte style_parent_id sollte "1" und bei "style_parent_tree" sollte prosilver drin stehen.
Hinweis: Das hier phpbb ist dein Datebank Präfix, sollte diese anders lauten z.B. xyz so müsstest du eben nach "xyz_styles" suchen.
Todi
Mitglied
Beiträge: 34
Registriert: 14.04.2013 16:50

Re: [3.2] Internal Server Error

Beitrag von Todi »

Hallo,

alles gefunden und eingestellt; Cache geleert bei FTP ; Browser Cache geleert; Forum bleibt vorhanden; Login funktioniert, ACP funktioniert.

Das ist nun mein Ostergeschenk. Danke Udo, wie kann ich mich erkenntlich zeigen?

DANKE.
Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 16783
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.2] Internal Server Error

Beitrag von Dr.Death »

So vielleicht:
--> Dankes-Sammlung ;-)
Antworten

Zurück zu „Support-Forum“