[3.2] Wie Link in den Schnellzugriff hinzufügen?

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 6470
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: [3.2] Wie Link in den Schnellzugriff hinzufügen?

Beitrag von Kirk » 14.02.2019 20:01

Hier mal ein Beispiel, dieser Bereich hier (
Support-Forum) hat die ID 145 wenn du in diesem Bereich die Links anzeigen möchtest, sähe es so aus:

Code: Alles auswählen

<!-- IF FORUM_ID eq 145 -->
<li>
<a href="https://www." role="menuitem">
<i class="icon fa-shield fa-fw" aria-hidden="true"></i><span>Paypallink</span>
</a>
</li>
<li>
<a href="https://www." role="menuitem">
<i class="icon fa-user-secret fa-fw" aria-hidden="true"></i><span>Datenschutz</span>
</a>
</li>
<!-- ENDIF -->

GVLP
Mitglied
Beiträge: 80
Registriert: 12.02.2019 21:26

Re: [3.2] Wie Link in den Schnellzugriff hinzufügen?

Beitrag von GVLP » 14.02.2019 20:07

/localhost/forum/index.php?sid=93f3eee7b99a6635b3ccef5f646136dd

Ich kann die ID nicht erkennen.

Update:
Ich habe f=5 gefunden, das Skript von oben in die Datei eingefügt und den Cache geleert. Leider stellt sich der Erfolg noch nicht ein.
Zuletzt geändert von GVLP am 14.02.2019 20:17, insgesamt 1-mal geändert.

Benutzeravatar
Mahony
Ehemaliges Teammitglied
Beiträge: 12005
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Wie Link in den Schnellzugriff hinzufügen?

Beitrag von Mahony » 14.02.2019 20:16

Mahony hat geschrieben:Die Foren-ID findest du, wenn du das betreffende Forum öffnest und dir die URL ansiehst. Das was hinter f= steht, ist die Foren-ID. Zum Beispiel hat das Forum Support hier auf phpbb.de die ID 145
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

GVLP
Mitglied
Beiträge: 80
Registriert: 12.02.2019 21:26

Re: [3.2] Wie Link in den Schnellzugriff hinzufügen?

Beitrag von GVLP » 14.02.2019 20:27

Ich habe f=5 gefunden, das Skript von oben in die Datei eingefügt und den Cache geleert. Leider stellt sich der Erfolg noch nicht ein.

Code: Alles auswählen

<!-- IF FORUM_ID eq 5 -->
<li>
<a href="https://www." role="menuitem">
<i class="icon fa-shield fa-fw" aria-hidden="true"></i><span>Paypallink</span>
</a>
</li>
<li>
<a href="https://www." role="menuitem">
<i class="icon fa-user-secret fa-fw" aria-hidden="true"></i><span>Datenschutz</span>
</a>
</li>
<!-- ENDIF -->

Benutzeravatar
Mahony
Ehemaliges Teammitglied
Beiträge: 12005
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Wie Link in den Schnellzugriff hinzufügen?

Beitrag von Mahony » 14.02.2019 20:36

Kirk hat geschrieben:Danach den Foren UND den Browser Cache leeren!
Leere akso mal das cache-Verzeichnis vom Forum (per FTP-Programm ALLES außer der .htaccess und der index.htm löschen) und vom Browser und schau, ob es dann funktioniert.

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

GVLP
Mitglied
Beiträge: 80
Registriert: 12.02.2019 21:26

Re: [3.2] Wie Link in den Schnellzugriff hinzufügen?

Beitrag von GVLP » 14.02.2019 20:47

cache-Verzeichnis (Ordner production) und Forumscashe gelöscht. Leider hat das nichts geholfen.

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 6470
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: [3.2] Wie Link in den Schnellzugriff hinzufügen?

Beitrag von Kirk » 14.02.2019 21:04

Ich denke es liegt daran \forum\styles\all\template\event\overall_header_navigation_append.html
so kann es nicht funktionieren, lade dir diese Extension runter und lade die Datei overall_header_navigation_append.html nach root/ext/kirk/my_quicklinks/styles/all/template/event/ hoch.
Extension installieren, Foren und Browser Cache leeren!

GVLP
Mitglied
Beiträge: 80
Registriert: 12.02.2019 21:26

Re: [3.2] Wie Link in den Schnellzugriff hinzufügen?

Beitrag von GVLP » 14.02.2019 21:15

Die Extension hatte ich bereits installiert.

Die Datei overall.... habe ich nach Event kopiert und sämtlichen Cashe geleert. Leider kein Erfolg.

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 6470
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: [3.2] Wie Link in den Schnellzugriff hinzufügen?

Beitrag von Kirk » 14.02.2019 21:28

Wenn deine Foren ID stimmt, dann sollte der Code so ausehen:

Code: Alles auswählen

<!-- IF FORUM_ID eq 5 -->
		<li id="my-quick-links" class="quick-links dropdown-container responsive-menu-my-quick-links<!-- IF not S_DISPLAY_QUICK_LINKS and not S_DISPLAY_SEARCH --> hidden<!-- ENDIF -->" data-skip-responsive="true">
			<a href="#" class="responsive-menu-link dropdown-trigger">
				<i class="icon fa-bars fa-fw" aria-hidden="true"></i><span>{L_MY_QUICK_LINKS}</span>
			</a>
			<div class="dropdown">
				<div class="pointer"><div class="pointer-inner"></div></div>
				<ul class="dropdown-contents" role="menu">
					<li class="separator"></li>
						<li>
							<a href="https://www." role="menuitem">
								<i class="icon fa-shield fa-fw" aria-hidden="true"></i><span>Paypallink</span>
							</a>
						</li>
					<li class="separator"></li>
						<li>
							<a href="https://www." role="menuitem">
								<i class="icon fa-user-secret fa-fw" aria-hidden="true"></i><span>Datenschutz</span>
							</a>
						</li>
					<li class="separator"></li>
				</ul>
			</div>
		</li>
Edit:
Versuche mal die Datei overall_header_navigation_append.html in overall_header_navigation_prepend.html umzubenennen.
Danach Foren und Browser Cache leeren!

GVLP
Mitglied
Beiträge: 80
Registriert: 12.02.2019 21:26

Re: [3.2] Wie Link in den Schnellzugriff hinzufügen?

Beitrag von GVLP » 14.02.2019 21:40

Den o. g. Text in c:\xampp\htdocs\forum\ext\kirk\my_quicklinks\styles\all\template\event\overall_header_navigation_append.html kopiert, sämtlichen Cashe geleert.

Fehlermeldung:
Fatal error: Uncaught Twig_Error_Syntax: Unexpected end of template. in C:\xampp\htdocs\forum\ext\kirk\my_quicklinks\styles\all\template\event\overall_header_navigation_append.html:4 Stack trace: #0 C:\xampp\htdocs\forum\vendor\twig\twig\lib\Twig\TokenParser\If.php(42): Twig_TokenStream->next() #1 C:\xampp\htdocs\forum\vendor\twig\twig\lib\Twig\Parser.php(192): Twig_TokenParser_If->parse(Object(Twig_Token)) #2 C:\xampp\htdocs\forum\vendor\twig\twig\lib\Twig\Parser.php(105): Twig_Parser->subparse(NULL, false) #3 C:\xampp\htdocs\forum\vendor\twig\twig\lib\Twig\Environment.php(716): Twig_Parser->parse(Object(Twig_TokenStream)) #4 C:\xampp\htdocs\forum\vendor\twig\twig\lib\Twig\Environment.php(774): Twig_Environment->parse(Object(Twig_TokenStream)) #5 C:\xampp\htdocs\forum\vendor\twig\twig\lib\Twig\Environment.php(452): Twig_Environment->compileSource(Object(Twig_Source)) #6 C:\xampp\htdocs\forum\phpbb\template\twig\environment.php(292): Twig_Environment->loadTemplate('@kirk_my_quickl...', NULL) #7 C:\xampp\htdocs\forum\cache in C:\xampp\htdocs\forum\ext\kirk\my_quicklinks\styles\all\template\event\overall_header_navigation_append.html on line 4

Antworten

Zurück zu „Support-Forum“