[3.2] Update nicht möglich

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
mymomo
Mitglied
Beiträge: 4
Registriert: 16.06.2018 23:57

[3.2] Update nicht möglich

Beitragvon mymomo » 17.06.2018 00:13

Moin!
Für einen Bekannten versuche ich gerade sein Forum auf den aktuellen Softwarestand zu bringen.
Zuvor hatte er Version 3.0.x mit PHP 5.6 laufen. Die Webseite soll nun auf PHP 7 oder höher gestellt werden.
Da schon mein erster Versuch direkt auf phpBB 3.2.2 scheiterte, habe ich das Board nun auf 3.1.12 geupdatet. Leider aber ist ja auch diese Version noch nicht mit PHP 7 kompatibel, wie ich später irgendwo gelesen habe.

Versuche ich nun die Datenbank auf phpBB 3.2.2 zu updaten, kommt es zu massiven Fehlern während des Updates - die Seite ist danach nicht zu gebrauchen.
Siehe: [ externes Bild ]

Ich habe irgendwo gelesen, dass eventuell die Datenbank beschädigt sei. Zufällig stellte sich heraus, dass die alte DB ohnehin noch auf einem alten Server lag, welcher bald abgeschalten wird. Also habe ich eine neue DB auf dem neuen Server des Bekannten erstellt und phpBB 3.2.2 dort komplett neu installiert. Danach bin ich lang gegangen und habe die alten Ordner "files" und "images" rüber kopiert und ein erstelltes DB-Backup dort eingespielt.

Nun sagte mir die Administrationsseite, dass das Update nicht vollständig durchgelaufen sei, da die DB (vermutlich durch das Backup) auf dem Stand von 3.1.12 sei. Also habe ich erneut das Install aufgerufen und wollte jetzt ein DB-Update durchführen. Es kommt erneut zur oben genannten Meldung.

Nun weiß ich ehrlich gesagt nicht mehr so richtig weiter.

Auf 3.1.12 zurück erhalte ich im Board neben anderen Fehlern folgende Hinweise, welche vermutlich auf Grund der Inkompatibilität zu PHP 7 passieren, oder?:
[ externes Bild ]

Benutzeravatar
vfrblue
Junior Supporter
Beiträge: 1171
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: [3.2] Update nicht möglich

Beitragvon vfrblue » 17.06.2018 00:27

Welcher MySQL-Treiber ist in der config.php eingetragen? Wenn du PHP 7.x verwendest, muss dort dieser eingetragen sein:

Code: Alles auswählen

$dbms = 'phpbb\\db\\driver\\mysqli';
Gruß Hermann

Forum VFR-OC

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 3251
Registriert: 15.10.2012 03:27

Re: [3.2] Update nicht möglich

Beitragvon Melmac » 17.06.2018 00:37

Hi,

was das Upgrade (nicht Update :wink: ) von 3.1.x auf 3.2 betrifft, gibt es hier => phpBB 3.2 - Upgrade von phpBB 3.1, Punk "II. Manuelles Update", eine genaue Schritt-für-Schritt-Anleitung.

Wichtig:
Da es noch einige Bugs in 3.2.2 gibt, solltest Du vor dem eigentlichen Upgradelauf noch folgende Anpassungen am Code des zum Upgrade verwendeten Pakets vornehmen => [3.2] Bekannte Probleme in phpBB 3.2.2.

Welche PHP-Version wird aktuell auf dem Server verwendet: bei phpBB 3.2.2 kann es noch zu Inkompatibilitäten mit den neueren 7.2.x-Versionen kommen.
Wenn die 3.1.12-Installation noch unter PHP 5.6 läuft, dann führe das Upgrade besser zuerst durch und stelle danach erst auf 7.x um.
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

mymomo
Mitglied
Beiträge: 4
Registriert: 16.06.2018 23:57

Re: [3.2] Update nicht möglich

Beitragvon mymomo » 17.06.2018 10:09

@vrfblue, guter Hinweis, aber der Treiber ist bereits eingetragen. Schade^^ ;o)

Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 1927
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: [3.2] Update nicht möglich

Beitragvon Joyce&Luna » 17.06.2018 13:29

Wenn ich jetzt richtig lese, hast du ein Update von 3.0.x nach 3.1.12 was erst geklappt hat.
Dann hast du von 3.1.12 nach 3.2.2 updaten wollen, was aber fehl schlug.
Ist das soweit richtig?
Weil dies nicht funktioniert hat, hast du ein neues Forum mit 3.2.2 installiert und die Datenbank von 3.1.12 darauf hoch geladen.
Das kann so gar nicht funktionieren.

Du solltes erst in 3.0.x alle Module entfernen auch Style ect. am besten mit STK. Dann ein manuelles Update durch führen auf 3.1.12 und auch bei der php 5.6 bleiben.
Dann die Datenbank durch schauen, wo noch Reste sind, BBCode Prüfen ob diese noch intakt sind.
Danach würde ich ein weiteres manuelles Update durch führen und auf phpBB 3.2.2 gehen.
Erst wenn das alles geschafft ist, dann erst auf php 7 gehen und nicht vorher. Denn weder phpBB 3.0 oder phpBB 3.1 können mit php 7 umgehen. Erst ab Version phpBB 3.2 ist es möglich auf php 7 zu gehen.

Wenn ich jetzt hier komplett falsch liege, dann den Beitrag ignorieren.
phpBB-Style-Design.de

Keine Antwort ist die eindeutigste Antwort, die man kriegen kann.
Bitte stellt die Fragen im Forum und nicht per PN. Danke!

mymomo
Mitglied
Beiträge: 4
Registriert: 16.06.2018 23:57

Re: [3.2] Update nicht möglich

Beitragvon mymomo » 18.06.2018 11:30

also ich habe jetzt mehrfach alle hier beschriebenen Schritte versucht durchzuführen. Das Datenbankbackup bleibt immer wieder hängen und das Forum ist danach gar nicht mehr zu gebrauchen.

Daher möchte ich nun eine andere Strategie fahren:
ich baue ein zweites Forum mit Version 3.2.2 auf. Da ein komplettes Backup der Datenbank dazu führt, dass ich in eine alte Datenbankversion zurück falle, würde ich gerne gezielt nur die wichtigsten Tabellen übernehmen wollen.

Hierzu müsste ich jedoch wissen, welche das tatsächlich sind?!?
Im Prinzip sollen die User und die Boards und dessen Einträge (mit Anhangverknüpfungen) behalten werden. Einstellungen etc können gerne im Nachgang neu angepasst werden. Lässt sich das realisieren?

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 3251
Registriert: 15.10.2012 03:27

Re: [3.2] Update nicht möglich

Beitragvon Melmac » 18.06.2018 11:37

Hast Du vor dem Upgrade von 3.1 auf 3.2.2 auch die Korrekturen am Code des für das Upgrade verwendeten Paketes durchgeführt und auch alle vorbereitenden Schritte abgearbeitet?

mymomo hat geschrieben:würde ich gerne gezielt nur die wichtigsten Tabellen übernehmen wollen.
[...]
Lässt sich das realisieren?

Nein, das geht so leider nicht: die Datenbanktabellen sind untereinander verknüpft und Datensätze werden teilweise über mehrere Tabellen hinweg verteilt gespeichert.
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11402
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Update nicht möglich

Beitragvon Mahony » 18.06.2018 12:37

Hallo
mymomo hat geschrieben:Versuche ich nun die Datenbank auf phpBB 3.2.2 zu updaten, kommt es zu massiven Fehlern während des Updates - die Seite ist danach nicht zu gebrauchen.

Du solltest VOR dem updaten von 3.1.12 auf 3.2.2 die Änderungen von hier viewtopic.php?f=145&t=240809 durchführen.
mymomo hat geschrieben:Das Datenbankbackup bleibt immer wieder hängen und das Forum ist danach gar nicht mehr zu gebrauchen.


Womit erstellst Du das Datenbankbackup?
Ich empfehle Dir zum erstellen UND zum einspielen des Datenbankbackups den Mysqldumper >>> https://github.com/DSB/MySQLDumper

P.S. Die Umstellung auf PHP7 solltest Du erst vornehmen, wenn das Forum auf phpBB 3.2.2 fehlerlos läuft.

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

mymomo
Mitglied
Beiträge: 4
Registriert: 16.06.2018 23:57

Re: [3.2] Update nicht möglich

Beitragvon mymomo » 21.06.2018 19:25

da bin ich endlich wieder - entschuldigt die später Rückmeldung. Bissl viel um die Ohren derzeit.

Die Backups mache ich mit den Boardeigenen Mitteln.

Inzwischen hab ich es im bestimmt 50. Versuch dann doch hinbekommen. Der einschlagende Hinweis war das STK. Ich wusste ja gar nicht das es das gibt, jedoch hat genau das nun zum Erfolg geführt. Dort habe ich eine Datenbankbereinigung durchgeführt, nachdem ich die DB durch das Einspielen des Backups mal wieder zerschossen habe. Danach konnte ich die DB endlich auf 3.2.2 updaten

Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 1927
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: [3.2] Update nicht möglich

Beitragvon Joyce&Luna » 21.06.2018 23:21

Also doch noch zu viele Modulreste in der Datenbank.
Hauptsache du hast es geschafft.
phpBB-Style-Design.de

Keine Antwort ist die eindeutigste Antwort, die man kriegen kann.
Bitte stellt die Fragen im Forum und nicht per PN. Danke!


Zurück zu „Support-Forum“