[3.2] [3.2.2] unerwünschtes ausloggen bei internen Links

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
f1racer66
Mitglied
Beiträge: 2
Registriert: 03.08.2018 15:17

[3.2] [3.2.2] unerwünschtes ausloggen bei internen Links

Beitragvon f1racer66 » 03.08.2018 15:23

Hallo,

ich habe jetzt drei Tage gesucht und erhoffe mir hier Hilfe!

Problem : Im Forum funktionieren alle originalen Links da das forum hinter die URL die SID des eingelochten Benutzers mitschickt.

Wenn wir selber auf einen anderen internen Beitrag setzen wollen haben wir die SID nicht und lassen die folglich weg :
https://forum.motorrad-zeit.de/viewtopic.php?f=5&t=221

Den Nutzer wird dann ausgelegt sobald er den Beitrag aufruft. Bei Klick auf "zurück" ist der User wieder eingeloggt!

ssl aktiviert
cookie domain = forum.motorrad-zeit.de (habe ich auch mit .forum.motorrad-zeit.de versucht gleiche Wirkung)
cookie name = motorrad_zeit
Pfad = /
sicherer Server = an
cookie Hinweis = an

Was mache ich falsch? Vielen dank für Eure Hilfe und allen ein schönes Wochenende!

Viele Grüße
Frank

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 3395
Registriert: 15.10.2012 03:27

Re: [3.2] [3.2.2] unerwünschtes ausloggen bei internen Links

Beitragvon Melmac » 03.08.2018 17:10

Hi,

da Du auf HTTPS umgestellt hast: prüfe bitte kurz, ob Du dabei so wie hier => phpBB richtig auf HTTPS umstellen beschrieben vorgegangen bist oder ob bei der Konfiguration einer der Schritte nicht übernommen wurde.
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

f1racer66
Mitglied
Beiträge: 2
Registriert: 03.08.2018 15:17

Re: [3.2] [3.2.2] unerwünschtes ausloggen bei internen Links

Beitragvon f1racer66 » 06.08.2018 15:34

Hallo,

vielen Dank, ich habe das Board allerdings gleich unter https installiert und nicht umgestellt :D
Die Einstellungen ware, mit Ausnahme des Erzwingen der Konfiguration anstelle der auto. Erkennung, so eingestellt. Den Haken habe ich nun zusätzlich gesetzt.

Ich glaube das Problem ist seit gestern Abend auch verschwunden, ich habe nur keine Ahnung warum!

Viele Grüße
Frank

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 3395
Registriert: 15.10.2012 03:27

Re: [3.2] [3.2.2] unerwünschtes ausloggen bei internen Links

Beitragvon Melmac » 06.08.2018 16:06

On neu installiert oder erst nachträglich umgestellt: die Konfiguration muss schon stimmen und, zumindest teilweise, neu angepasst werden :wink:

f1racer66 hat geschrieben:Ich glaube das Problem ist seit gestern Abend auch verschwunden, ich habe nur keine Ahnung warum!

Im Zweifel liegt sowas immer am üblichen großen EDV-Voodoo-Zauber - Hauptsache, es funzt jetzt :D
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

FrankD
Mitglied
Beiträge: 3
Registriert: 19.07.2018 15:18

Re: [3.2] [3.2.2] unerwünschtes ausloggen bei internen Links

Beitragvon FrankD » 26.08.2018 17:50

Hallo,

ja das Problem ist weg, obwohl alles unverändert ist!
Ich hatte eine komplette Neuinstallation gehabt, sehr merkwürdig.
Aber Hauptsache jetzt geht es, danke an alle die sich dazu Gedanken gemacht haben!

Viele Grüße
Frank


Zurück zu „Support-Forum“