[3.2] Umzug

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
axyllo
Mitglied
Beiträge: 28
Registriert: 21.12.2018 19:02

Re: [3.2] Umzug

Beitragvon axyllo » 23.01.2019 23:09

So, nun habe nochmal komplett gelöscht und alles nach Anleitung https://www.phpbb.de/kb/Umzug nochmal neu installiert aber der Fehler mit den Extentions bleibt :( "502 Bad Gateway"

Benutzerrechte und Benutzerspezifische Forenrechte kommt übrigens auch die Errorpage

Bin gerne bereit einem der Supporter/Administratoren den Administrationszugriff per PM zukommen zu lassen um sich das Problem anzusehen.

Maverick92
Mitglied
Beiträge: 21
Registriert: 22.01.2019 13:57

Re: [3.2] Umzug

Beitragvon Maverick92 » 23.01.2019 23:25

Ich habe kurz deine anderen Beiträge überflogen, bist du immernoch bei dem Tor-Server?

Wenn ja, wäre mein Vorschlag:
Probier erstmal, dein Forum auf einen lokalen XAMPP zu schmeißen, da ist die langsame Verbindung dann egal.
Wenn die Fehlermeldungen da auch auftreten -> lokale Fehlersuche
Wenn nicht, vermute ich, dass irgendetwas in der Konfiguration vom Tor-Server Probleme macht, dann hätte man aber wenigstens schonmal einen Ansatz mit dem man die Fehlersuche etwas eingrenzen könnte.

axyllo
Mitglied
Beiträge: 28
Registriert: 21.12.2018 19:02

Re: [3.2] Umzug

Beitragvon axyllo » 23.01.2019 23:44

Maverick92 hat geschrieben:Ich habe kurz deine anderen Beiträge überflogen, bist du immernoch bei dem Tor-Server?

Wenn ja, wäre mein Vorschlag:
Probier erstmal, dein Forum auf einen lokalen XAMPP zu schmeißen, da ist die langsame Verbindung dann egal.
Wenn die Fehlermeldungen da auch auftreten -> lokale Fehlersuche
Wenn nicht, vermute ich, dass irgendetwas in der Konfiguration vom Tor-Server Probleme macht, dann hätte man aber wenigstens schonmal einen Ansatz mit dem man die Fehlersuche etwas eingrenzen könnte.


Ja, ist nach wie vor Tor-Freehoster mit identischer Konfiguration wie der alte Hoster, in sofern sollte es doch klappen, will halt nur wechseln weil der neue Hoster bessere Konditionen und Erreichbarkeit bietet. Ist auch nicht wirklich illegal was ich da anbieten möchte, in sofern mein Angebot der Zugangsdaten.

Vielleicht versuche ich auch mal eine komplette Neuinstallation, was natürlich viel Arbeit bedeutet :(

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 3623
Registriert: 15.10.2012 03:27

Re: [3.2] Umzug

Beitragvon Melmac » 24.01.2019 03:13

500er Fehler sind eigentlich Serverfehler - was sagt denn das Errorlog des Servers dazu aus?
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

axyllo
Mitglied
Beiträge: 28
Registriert: 21.12.2018 19:02

Re: [3.2] Umzug

Beitragvon axyllo » 24.01.2019 04:00

Melmac hat geschrieben:500er Fehler sind eigentlich Serverfehler - was sagt denn das Errorlog des Servers dazu aus?


Wie bekomme ich das?

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 3623
Registriert: 15.10.2012 03:27

Re: [3.2] Umzug

Beitragvon Melmac » 24.01.2019 04:16

Im Verwaltungsmodul des Accounts bei Deinem Hoster sollte eine entsprechende Option vorhanden sein, mit der Du das Errorlog des Servers aufrufen bzw. einsehen kannst. Falls nicht, dann müsstest Du ihn kontaktieren und den entsprechenden Log-Auszug von ihm anfordern.

"502 Bad Gateway" heißt, vereinfacht ausgedrückt, dass irgendwo auf dem Weg der Datenpakete über die diversen Server einer davon nicht so reagiert, wie er das sollte.
Da dieser Fehler aber, wenn ich das richtig verstanden habe, nicht prinzipiell ausgegeben wird, sondern nur in bestimmten Bereichen des Boards, gibt das Log vielleicht einen Hinweis darauf, was bei/in Deiner Installation dies auslöst.
Einen Versuch wäre es jedenfalls mal wert.
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

axyllo
Mitglied
Beiträge: 28
Registriert: 21.12.2018 19:02

Re: [3.2] Umzug

Beitragvon axyllo » 24.01.2019 10:51

Hier mal das Errorlog und der Provider https://danwin1210.me/ http://danielas3rtn54uwmofdo3x2bsdifr47 ... pid.onion/

Code: Alles auswählen

2019/01/23 23:00:25 [error] 23088#23088: *24677947 FastCGI sent in stderr: "PHP message: PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /www/forum/vendor/zendframework/zend-stdlib/src/ArrayObject.php on line 426PHP message: PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /www/forum/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 272PHP message: PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /www/forum/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 275PHP message: PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /www/forum/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 281PHP message: PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /www/forum/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 287PHP message: PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /www/forum/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 296PHP message: PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /www/forum/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 314PHP message: PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /www/forum/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 319" while reading response header from upstream, client: unix:, server: wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion, request: "GET /forum/index.php?sid=77b1ddd3d7ccba73be2c36c1e618b00f HTTP/1.1", upstream: "fastcgi://unix:/run/php/wrcty7ive7fzg3erzny4qiooknk42exd:", host: "wrcty7ive7fzg3erzny4qiooknk42exde3q5bj
2019/01/23 23:04:02 [error] 31835#31835: *24680167 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: unix:, server: wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion, request: "POST /forum/adm/index.php?i=acp_extensions&sid=a4223376862f81d109289796bbe622b7&mode=main&action=enable&ext_name=dmzx%2Fyoutubegallery&hash=16c34416 HTTP/1.1", upstream: "fastcgi://unix:/run/php/wrcty7ive7fzg3erzny4qiooknk42exd:", host: "wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion", referrer: "http://wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion/forum/adm/index.php?i=acp_extensions&sid=a4223376862f81d109289796bbe622b7&mode=main&action=enable_pre&ext_name=dmzx%2Fyoutubegallery"
2019/01/23 23:08:33 [error] 31835#31835: *24685607 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: unix:, server: wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion, request: "POST /forum/adm/index.php?i=acp_extensions&sid=a4223376862f81d109289796bbe622b7&mode=main&action=enable&ext_name=dmzx%2Fyoutubegallery&hash=16c34416 HTTP/1.1", upstream: "fastcgi://unix:/run/php/wrcty7ive7fzg3erzny4qiooknk42exd:", host: "wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion", referrer: "http://wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion/forum/adm/index.php?i=acp_extensions&sid=a4223376862f81d109289796bbe622b7&mode=main&action=enable_pre&ext_name=dmzx%2Fyoutubegallery"
2019/01/23 23:10:48 [error] 31835#31835: *24687019 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: unix:, server: wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion, request: "POST /forum/adm/index.php?i=acp_extensions&sid=a4223376862f81d109289796bbe622b7&mode=main&action=enable&ext_name=dmzx%2Fmchat&hash=5d09c2a4 HTTP/1.1", upstream: "fastcgi://unix:/run/php/wrcty7ive7fzg3erzny4qiooknk42exd:", host: "wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion", referrer: "http://wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion/forum/adm/index.php?i=acp_extensions&sid=a4223376862f81d109289796bbe622b7&mode=main&action=enable_pre&ext_name=dmzx%2Fmchat"
2019/01/23 23:18:34 [error] 7824#7824: *24693341 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: unix:, server: wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion, request: "GET /forum/adm/index.php?sid=a4223376862f81d109289796bbe622b7&i=acp_permissions&mode=setting_user_global HTTP/1.1", upstream: "fastcgi://unix:/run/php/wrcty7ive7fzg3erzny4qiooknk42exd:", host: "wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion", referrer: "http://wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion/forum/adm/index.php?i=acp_users&sid=a4223376862f81d109289796bbe622b7&icat=12&mode=overview&u=49"
2019/01/23 23:18:44 [error] 7824#7824: *24693341 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: unix:, server: wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion, request: "GET /forum/adm/index.php?sid=a4223376862f81d109289796bbe622b7&i=acp_permissions&icat=12&mode=setting_user_local HTTP/1.1", upstream: "fastcgi://unix:/run/php/wrcty7ive7fzg3erzny4qiooknk42exd:", host: "wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion", referrer: "http://wrcty7ive7fzg3erzny4qiooknk42exde3q5bju2gygv7y5chkhpyyad.onion/forum/adm/index.php?i=acp_users&sid=a4223376862f81d109289796bbe622b7&icat=12&mode=overview&u=49"

Maverick92
Mitglied
Beiträge: 21
Registriert: 22.01.2019 13:57

Re: [3.2] Umzug

Beitragvon Maverick92 » 24.01.2019 11:49

Das klingt für mich nach einem Problem mit PHP bzw evtl. dem PHP-FPM (Fast-CGI Prozessmanager).

Sicher, dass auf beiden Server die gleiche PHP-Version läuft?

Wenn du nicht weißt, welche auf dem aktuellen Server läuft, erstell mal eine PHP-Datei auf dem Server mit folgendem Inhalt:

Code: Alles auswählen

<?php
echo phpversion();
?>


und ruf die Seite im Browser auf. Ich vermute Version 7.3.x

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11842
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Umzug

Beitragvon Mahony » 24.01.2019 11:51

Hallo
axyllo hat geschrieben:"continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?

Kann es sein, dass auf dem Server PHP 7.3 läuft?
Dann liegt es sicher daran. Siehe >>> https://blog.jkip.de/warning-continue-t ... -to-break/

Lösung: Auf PHP 7.1 oder PHP 7.2 wechseln.

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

axyllo
Mitglied
Beiträge: 28
Registriert: 21.12.2018 19:02

Re: [3.2] Umzug

Beitragvon axyllo » 24.01.2019 12:05

Ja, der Server läuft mit PHP 7.3, dann bleibt mir wohl nichts übrig als auf das nächste phpBB Update zu warten, das dann vielleicht angepasst ist. Der Hoster wird wohl eher nicht downgraden.

Auf alle Fälle Danke für Eure informative Hilfe.


Zurück zu „Support-Forum“