[3.1.10] Error parsing server response.

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
volkerB
Mitglied
Beiträge: 15
Registriert: 24.07.2010 10:54

[3.1.10] Error parsing server response.

Beitragvon volkerB » 07.02.2019 19:53

Hallo zusammen ... Lokale-Dateien in den Server zu laden scheint ein Problem mit langer Historie zusein ... Nun, ich habe von meinem Hoster (Strato) die Version 3.1.10 als Installationsangebot bekommen, installiert und stehe nun vor dem Problem, das ich den Nutzern das Hochladen von Bilder nicht ermöglichen kann. Gibts Vorschläge wie die passenden Einstellungen vornehmen muß ... ???? :-) !!!!

Benutzeravatar
yks
Mitglied
Beiträge: 1240
Registriert: 10.07.2004 02:31

Re: [3.1.10] Error parsing server response.

Beitragvon yks » 07.02.2019 20:00

Hallo volker,

soweit ich weiß, hast du nicht unbedingt alle Rechte, wenn ein Hoster dir etwas vorinstalliert. Das ist nicht das gleiche als wenn du das Forum selbst installierst (nebenbei, aktuell ist 3.2.5).
Evtl kannst du es in deinem Kundenaccount bei strato einstellen, dort schon nachgesehen ?

Gruß
yks
Mit subsilver2 macht es noch viel mehr Spaß ! :)

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1772
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.1.10] Error parsing server response.

Beitragvon canonknipser » 07.02.2019 21:31

Strato MUSS an den 3.1-Dateien was gebastelt habe. phpBB 3.1.x ist von Hause aus NICHT PHP 7.x-fähig, aber Strato nimmt afaik für die Unterstützung von PHP-Versionen < 7.1 inzwischen zusätzliche Gebühren.
Also müssen sie, wenn sie eine Version 3.1 zur Installation anbieten, was an den Dateien geändert haben. Wer weiß, was sie dabei noch verändert haben.
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

volkerB
Mitglied
Beiträge: 15
Registriert: 24.07.2010 10:54

Re: [3.1.10] Error parsing server response.

Beitragvon volkerB » 07.02.2019 21:39

Also, ich habe nichts vorinstalliertes installiert ... es waren die hier angebotenen Programmpakete ... Ich denke mal eher, das ich bestimmte Parameter nicht korrekt habe ... fangen wir doch mal da an ... welche Parameter müssen wie eingestellt sein ? Wäre gut, wenn ich da mal checken kann ...

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1772
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.1.10] Error parsing server response.

Beitragvon canonknipser » 07.02.2019 21:55

volkerB hat geschrieben:Also, ich habe nichts vorinstalliertes installiert
Äh ->
volkerB hat geschrieben: ich habe von meinem Hoster (Strato) die Version 3.1.10 als Installationsangebot bekommen, installiert


Wie passt das zusammen?

Also,
wenn du mit den Installationsdateien von hier, also aus unserem Downloadbereich, ein Paket 3.1.10 (warum eigentlich ein so hoffnungslos veraltetes Paket? Aktuell ist 3.2.5, das neueste und letzte aus der 3.1-Linie ist 3.1.12) installiert hast, musst du natürlich auch die Systemvoraussetzungen beachten. Also PHP-Version kleiner als 7.0 usw.
Die Fehlermeldung in deinem Titel deutet schon auf eine wahrscheinliche Fehlerursache hin: Probleme mit der Server-Konfiguration. Also: Checke die Logdateien des Server (nicht die von phpBB), prüfe die Systemvoraussetzungen bzgl. PHP-Version usw.
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 3623
Registriert: 15.10.2012 03:27

Re: [3.1.10] Error parsing server response.

Beitragvon Melmac » 07.02.2019 21:55

volkerB hat geschrieben:ich habe von meinem Hoster (Strato) die Version 3.1.10 als Installationsangebot bekommen

volkerB hat geschrieben:Also, ich habe nichts vorinstalliertes installiert ... es waren die hier angebotenen Programmpakete

Das widersprichst sich jetzt aber :wink:
Entweder Du hast das Paket von Strato bekommen (dann kann es kein originales phpBB mehr sein), oder Du hast das Paket von hier aus unserem Downloadbereich - was dann aber neue Fragen aufwirft:
  • Wie hast Du es eigentlich zum Laufen gebracht, ohne mit Fehlermeldungen und Warnhinweisen zugedeckt zu werden (phpBB 3.1 ist definitiv nicht kompatibel mit PHP 7.x)?
  • Warum dann ausgerechnet das 3.1.10 Paket - das ist ja noch nicht einmal die aktuellste Version innerhalb der (veralteten) 3.1 Linie ...

------------------

Edit:
Parallelflug :D
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

volkerB
Mitglied
Beiträge: 15
Registriert: 24.07.2010 10:54

Re: [3.1.10] Error parsing server response.

Beitragvon volkerB » 07.02.2019 22:22

Also, ich werde das Upgrade machen ... strato bietet PhP 7.1 als kleinste Version an ... und wenn sich das also beißt, dann liegt hier das Problem ... muß gleich mal etwas zurück schauen ... da stand ein Link zu einem Fahrplan für ein Upgrade ... hoffentlich ist das für einen geschrieben der mit Messer und Gabel zu essen pfelgt ;-)) ... lieben Dank ... (alles andere ist irrelevant !) LG Volker

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 3623
Registriert: 15.10.2012 03:27

Re: [3.1.10] Error parsing server response.

Beitragvon Melmac » 07.02.2019 22:27

volkerB hat geschrieben:(alles andere ist irrelevant !)

???
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

volkerB
Mitglied
Beiträge: 15
Registriert: 24.07.2010 10:54

Re: [3.1.10] Error parsing server response.

Beitragvon volkerB » 09.02.2019 17:12

Ich werde jetzt mal schauen, ob ich ein Update auf 3.2.x hinbekomme. Das ist jetzt angesagt. Deshalb lieben Dank an alle bis hierher ... wie ich so lese, wird das eine spannende Aufgabe für die nächsten Tage werden ... ;-) Ich sag mal, "bis gleich" ... Gruß Volker

volkerB
Mitglied
Beiträge: 15
Registriert: 24.07.2010 10:54

Re: [3.1.10 nach 3.2.5] Error parsing server response.

Beitragvon volkerB » 10.02.2019 17:17

Hallo liebe Helferlein ...

so, ich habe nun in einer 3.1.10 Test-Umgebung mit gleicher Installation, das 3.2.5 (das dt.Paket) per manuellem Update installiert.
Ein Lob an den Schreiber dieser Anleitung. Die war wirklich gut. DANKE !! :-)

Eine Frage bleibt aber noch:
Nach dem ich INSTALL.HTML ausgeführt hatte, wurde zwar eine erfolgreiche Installition vermeldet, aber es wurden auch diese beiden Zeilen ausgeworfen.

[phpBB Debug] "BOARD_DISABLE" in file /mnt/...../benelli-motobi-fan/bmf-forum/phpbb/user.php on line 354

[phpBB Debug] "BOARD_DISABLE" in file /mnt/...../benelli-motobi-fan/bmf-forum/phpbb/user.php on line 354

Meine Frage: Resultiert hieraus etwas besonders für mich ??? gibt's noch was zu tun ???
Ach ja, ein Hinweis vielleicht: Ich habe im Verzeichniss phpBB3 keine .htaccess gehabt ...

Ganz lieben Dank,
Gruß Volker


Zurück zu „Support-Forum“