[3.2] Umzug von 3.0.7.PLI, Äbhängigkeiten bei identischer DB?

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Drachenzuechter
Mitglied
Beiträge: 63
Registriert: 24.09.2010 14:59
Wohnort: Im Winter Shiverpool, im Sommer Pen-Gu Eiland

[3.2] Umzug von 3.0.7.PLI, Äbhängigkeiten bei identischer DB?

Beitrag von Drachenzuechter » 01.05.2019 15:59

Hallo Zusammen,

nachdem mein Forum seit Anfang (2010) an ohne Beanstandungen durchläuft,
ich aber die Foren-Version nie aktualisiert habe, wird es langsam Zeit
dies nach zuholen, nach Möglichkeit auf den allerneusten Stand.

Vorneweg muß ich daraufhin weisen, daß ich weder in PHP noch in anderen
Programmierungen bewandert bin und mich auch selten damit beschäftige.

Das Forum läuft aktuell auf 3.0.7.PLI. bei Strato auf PHP5.6, MySQL 5.6.42

Da ich Mods geladen und Änderungen an den Styles vorgenommen hatte,
möchte ich erst einmal auf einem Testforum die Vorgehnsweise ausprobieren.
(Falls es dazu Tips gibt, zB ob man am Besten schrittweise von Update zu Update
vorgeht oder direkt auf die aktuellste Version updatet, bitte nur zu 8) )

Ich habe das Forum komplett auf Festplatte gesichert und eine neue Datenbank mit
den Daten der Foren-Datenbank gefüllt.

Da ich ja nicht genau weiß, wie ich am Besten update, habe ich zum Probieren
alles in ein Unterverzeichnis des FTP-Servers kopiert und eine bisher
nicht verwendete .com Adresse dahin umgeleitet. Soweit alles gut.

Die Verknüpfung der Datenbank über die config.php funktioniert leider nicht, da das
angeforderte Passwort immer wieder mit dem MySQL-Fehler 1045 quittiert wird.
(Hierzu werde ich noch mal mit Strato Kontakt aufnehmen müssen.) Über phpmyadmin
läßt sich die Datenbank aufrufen und sieht für mich auch soweit gut aus.

Inwieweit kann ich meine Versuche mit den Updates in dem Testforum vornehmen ohne
das alte Forum, damit zu verändern oder schlechtestenfalls lahm zulegen?
Bei einem Test hatte ich einen Thread im Testforum erstellt, welcher Aufgrund
der gemeinsamen Datenbank logischerweise auch im alten-Forum erschien.
Merkwürdigerweise übernahm das alte Forum aber auch das zur optischen Unterscheidung
geänderte Site-Logo. Mir mangelt es an Basis-Wissen um die genauen Abhängigkeiten
bewerten zukönnen und würde mich freuen, wenn mich da Jemand "aufs Pferd holen" könnte.

Herzlichen Dank im Voraus

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 6441
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: [3.2] Umzug von 3.0.7.PLI, Äbhängigkeiten bei identischer DB?

Beitrag von Kirk » 01.05.2019 18:34

Hallo
Was das Update angeht, siehe hier: KB:phpBB32_upgrade_from_30
bedenke aber das es seit 3.1 sogenannte Extesnionen gibt, diese ersetzen die Mods, auch deine Styles sind unter 3.2 nich lauffähig.
Wenn du vorher alles erstmal testen möchtest, dann empfielt sich ein Testboard, dort kannst du eine Kopie des org. aufspielen, siehe dazu KB:Umzug

Drachenzuechter
Mitglied
Beiträge: 63
Registriert: 24.09.2010 14:59
Wohnort: Im Winter Shiverpool, im Sommer Pen-Gu Eiland

Re: [3.2] Umzug von 3.0.7.PLI, Äbhängigkeiten bei identischer DB?

Beitrag von Drachenzuechter » 01.05.2019 19:00

Kirk hat geschrieben:...siehe hier: KB:phpBB32_upgrade_from_30...
Hi Kirk, danke Dir, aber das beantwortet meine Frage leider nicht. :oops:

Zitat aus der KB:
"Sicherheitshalber sollte die gewählte Variante an einer Kopie des Boards durchgespielt werden, um mögliche Probleme beim späteren Upgrade des Live Boards bereits im Vorfeld erkennen und ausschließen zu können. "

Leider greift diese Kopie gerade auf die gleiche DB zu. Da ich auf eine Support-Anfrage beim Provider bereits schon einmal
keine Antwort bekommen habe, möchte ich zeitgleich PlanB bearbeiten können.

Meine Frage war eigentlich: Kann ich die Upgrades auf dem Testforum einspielen ohne das es Rückkopplungen mit dem Life-Forum gibt?
Der Austausch zB des Site-Logo.jpg auf dem Testforum führte zu einem Austausch im Life-Forum, obwohl dort nichts geändert wurde.
Mir erscheint das nicht logisch, es sei denn das auch Bilddaten irgendwo in der DB verankert werden.

Das diverse Dinge anders werden, wenn man den kompletten Unterbau verändert ist mir ganz klar und die diversen KB dazu weiß ich zu schätzen.
Daher ja auch der Wunsch zu testen (...und sich langsam an die Änderungen heranzu arbeiten).
Weitesgehend würde ich das Test-Forum dem alten Forum angleichen und dann nur die URL umswitchen wollen.

Benutzeravatar
Mylady
Mitglied
Beiträge: 585
Registriert: 23.02.2009 16:29
Wohnort: Velbert (NRW)
Kontaktdaten:

Re: [3.2] Umzug von 3.0.7.PLI, Äbhängigkeiten bei identischer DB?

Beitrag von Mylady » 01.05.2019 19:28

Du musst via phpMyAdmin in der Test-Datenbank natürlich die Adressierung anpassen. In der Tabelle phpbb_config (falls dein Tabellenpräfix unverändert phpbb_ lautet) findest du die Einträge zu Server, Cookies und Pfaden. Achte auf

cookie_domain (ändern auf deine .com Domain)
cookie_name (definitiv ändern)
server_name (ändern auf deine .com Domain)

ggf. noch
cookie_path (sollte / sein)
script_path (falls das Testforum aufgerufen wird mit einem Unterordner wie http://www.blabla.de/forum muss dort /forum stehen)
sitename

Dann deutet die Datenbank auch nicht mehr auf das live-Forum

Mache zunächst nach umfangreichem Backup aller Dateien und der Datenbank sämtliche Modifikationen rückgängig, deinstalliere alle Styles außer Prosilver, stelle Captchas auf ein Standardmodell um (z.B. GD-Grafik), sieh zu, dass alle Benutzer in Standardgruppen sind (nicht in selbst erstellten) wenn möglich. Bei den Updates werden alle Dateien ausgetauscht - es sollte dann möglich sein, in einem Zug zu upgraden. Im Zweifel bringe das Forum in einem Zwischenschritt zunächst auf 3.0.14. und erst dann auf 3.2.x

Beachte die oben von Kirk verlinkten Anleitungen.
https://ladyscommunity.de | Deutsche Übersetzungen für Extensionen (ggf. auf Anfrage)
-
Die Bosheit trinkt die Hälfte ihres eigenen Giftes (Lucius Annaeus Seneca)

Drachenzuechter
Mitglied
Beiträge: 63
Registriert: 24.09.2010 14:59
Wohnort: Im Winter Shiverpool, im Sommer Pen-Gu Eiland

Re: [3.2] Umzug von 3.0.7.PLI, Äbhängigkeiten bei identischer DB?

Beitrag von Drachenzuechter » 01.05.2019 22:12

Ahh, es scheint doch tiefer in die Materie zugehen :oops:

Danke Dir, ich probiere es in Kürze aus und melde mich dazu.

Drachenzuechter
Mitglied
Beiträge: 63
Registriert: 24.09.2010 14:59
Wohnort: Im Winter Shiverpool, im Sommer Pen-Gu Eiland

Re: [3.2] Umzug von 3.0.7.PLI, Äbhängigkeiten bei identischer DB?

Beitrag von Drachenzuechter » 19.06.2019 22:11

Ahoi Zusammen,

dank der Hinweise hier im Thread habe ich mein "neues" Forum
kopiert und die zweite Datenbank erfolgreich angedockt.

Ich kann jetzt ändern und testen ohne das Life-Forum anfassen zu müssen.

Alle Beiträge bis zum eingespielten Datenbank-Backup sind auch
inklusive Bilder vorhanden. Nur die Deinstallation der Mods hat nicht geklappt
(Fehlermeldung unter Extensions).

Da das alte Forum noch online ist, kommen auch immer noch
neue Beiträge dazu. Nur wie bekomme ich diese jetzt in die neue,
bereinigte Datenbank? Ich habe über export/import die Datenbank-Teile
_post und _forums eingespielt aber nicht angezeigt bekommen.
Könnt Ihr mir sagen, in was ich noch sichern und einspielen muß oder
ob das in der bereinigten Datenbank überhaupt geht?

Danke im Voraus

Benutzeravatar
Mylady
Mitglied
Beiträge: 585
Registriert: 23.02.2009 16:29
Wohnort: Velbert (NRW)
Kontaktdaten:

Re: [3.2] Umzug von 3.0.7.PLI, Äbhängigkeiten bei identischer DB?

Beitrag von Mylady » 19.06.2019 23:33

Gar nicht. Du testest deinen Umzug, bis du es beherrschst. Dann schaltest du einen Tag dein Forum offline und machst es nach erfolgreicher Datensicherung dort noch einmal für das Liveforum - mit dessen aktueller Datenbank. Thats all.

Es gibt zu viele Abhängigkeiten zu zu vielen Tabellen, um es einfach mit einzelnen Tabellen zu "kopieren"
https://ladyscommunity.de | Deutsche Übersetzungen für Extensionen (ggf. auf Anfrage)
-
Die Bosheit trinkt die Hälfte ihres eigenen Giftes (Lucius Annaeus Seneca)

Drachenzuechter
Mitglied
Beiträge: 63
Registriert: 24.09.2010 14:59
Wohnort: Im Winter Shiverpool, im Sommer Pen-Gu Eiland

Re: [3.2] Umzug von 3.0.7.PLI, Äbhängigkeiten bei identischer DB?

Beitrag von Drachenzuechter » 20.06.2019 00:04

Hi Mylady,

es wäre ja auch zu schön gewesen:
export/import Tabelle1,2,3 und soweiter und fertig. 8)

Na gut, dann werde ich etwas anders planen müssen.

Danke Dir-Du hast mir viel Versuch und Irrtum erspart :P

Benutzeravatar
chris1278
Mitglied
Beiträge: 1527
Registriert: 12.11.2007 06:20
Wohnort: Euskirchen
Kontaktdaten:

Re: [3.2] Umzug von 3.0.7.PLI, Äbhängigkeiten bei identischer DB?

Beitrag von chris1278 » 20.06.2019 08:15

Hallo Drachenzüchter.

Betreffend der Mods, sofern das Forum noch n phpbb 3.0.x läuft, benutze das Support Tool Kit von Phpbb

Damit solltest, du zumindest in der Datenbank sämtliche Einträge die durch Mods gemacht wurden entfernen können. Das setzt im Normalfall die Datenbank Struktur in einen Zustand ohne die Einträge von Mods... Beiträge und Foreneinstellungen, die zum Standard gehören bleiben erhalten.

Danach kannst du dir hier aus dem Archiv das entsprechende PHPbb 3.0.x Version downloaden und die Dateienn komplett austauschen ( bis auf config.php und evtl. htaccess die Ordner /files, /images und falls benutzt /store und /download evtl. noch andere Ordner die du angelegt hast)

Wenn du dann das Forum startest, solltest du ein phpbb Version 3.0.x haben was ohne Mods fehlerfrei läuft, sofern das stk (support tool kit) korrekt gearbeitet hat.

Mit diesem kannst du dann ein update machen.

Wichtig auf jeden Fall immer vorher komplett Backup machen (Datenbank und Dateien va FTP)

Drachenzuechter
Mitglied
Beiträge: 63
Registriert: 24.09.2010 14:59
Wohnort: Im Winter Shiverpool, im Sommer Pen-Gu Eiland

Re: [3.2] Umzug von 3.0.7.PLI, Äbhängigkeiten bei identischer DB?

Beitrag von Drachenzuechter » 06.07.2019 23:22

Ahoi Zusammen,

ich finde nicht immer Zeit zum Basteln, daher dauert es manchmal mit den Reaktionen ;-)

Habe jetzt mehrmals getestet, mit dem stk die Mods entfernt und das Forum soweit unter der neuen Url lauffähig.
Eine Sache nervt mich aber kolossal und zwar bekomme ich die Impressum-Mod von Dinseprinz nicht raus.

Ich kann zwar unter ACP/Anpassen neue Erweiterungen aktivieren aber nicht unter ACP/Erweiterungen konfigurieren,
weil mir immer folgende Fehlermeldung angezeigt wird:

Allgemeiner Fehler
Kann Modul ./../includes/acp/acp_impressum.php nicht finden

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 573
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()


Spaßeshalber habe ich die acp_impressum.php aus dem alten Forum eingespielt-
wie zu erwarten, hat das aber nicht funktioniert und wurde mit einer weißen Seite "honoriert"

Mit dem STK für 3.2.5 bekomme ich das über die Datenbankbereinigung auch nicht raus.

Ich freue mich über Eure Anworten.

Antworten

Zurück zu „Support-Forum“