Seite 1 von 2

[3.2] HTTP-Fehler bei Dateianhängen

Verfasst: 15.05.2019 21:24
von maik63de
Hallo,

ich habe das Update auf 3.2.7 gemacht, hat auch alles super geklappt.

Bis auf einem kleinem Problem:

wenn ich z.B. ein Bild als Anhang an ein Posting hänge, kommt am Ende des Hochladens meistens ein "HTTP-Fehler".
Das aber auch nur bei größeren Dateien. Bis 1,7 MB konnte ich gerade fehlerfrei anhängen, ab 1,8 MB kam der Fehler wieder.
Dateiart spielt auch keine Rolle.

Hat jemand eine Vermutung, was das sein könnte?

Re: [3.2] HTTP-Fehler bei Dateianhängen

Verfasst: 15.05.2019 21:45
von Mahony
Hallo
Das wird wohl daran liegen, dass auf dem Server eine Begrenzung für das hochladen gesetzt wurde.

Die höchstmögliche Größe der Dateien, die hochgeladen werden können, ist abhängig von den Einstellungen in der php.ini des Servers.
Relevante Werte sind hier post_max_size und upload_max_filesize
Überprüfen kannst du diese Werte unter ACP -- Allgemein -- PHP-Information --> dort nach post_max_size und upload_max_filesize suchen und die Werte ablesen.

...wenn ich z.B. ein Bild als Anhang an ein Posting hänge, kommt am Ende des Hochladens meistens ein "HTTP-Fehler"..

Wie lautet denn die Fehlermeldung?

Grüße: Mahony

Re: [3.2] HTTP-Fehler bei Dateianhängen

Verfasst: 16.05.2019 09:38
von maik63de
Moin Mahony,

die Werte für lauten:
post_max_size: 76M
upload_max_filesize 64M

Die Fehlermeldung lautet einfach nur "HTTP-Fehler." mehr nicht. Ich habe gerade im ACP im Fehler-Protokoll geschaut, auch dort wird keine Fehlermeldung ausgegeben.

Re: [3.2] HTTP-Fehler bei Dateianhängen

Verfasst: 16.05.2019 16:51
von Dr.Death
Schau mal in das SERVER Log von Deinem Provider nach...... dort sollte etwas zu dem Zeitpunkt sichtbar sein.

Re: [3.2] HTTP-Fehler bei Dateianhängen

Verfasst: 16.05.2019 17:44
von maik63de
Dr.Death hat geschrieben:Schau mal in das SERVER Log von Deinem Provider nach...... dort sollte etwas zu dem Zeitpunkt sichtbar sein.


Hi Dr.Death,

ich habe gerade nochmal versucht eine Datei hochzuladen, Fehler kam, im Fehler-Log steht aber kein Eintrag zu zu dem Zeitpunkt.
Der letzte Eintrag ist von 12.20 Uhr.
Es sind aber sehr viele Einträge, mit denen ich nichts anfangen kann.

Hier nur die Letzten 10 Einträge:

Code: Alles auswählen

16.05.2019 10:13:22 www.carcassonne-forum.de [client 66.249.66.0] AH02811: script not found or unable to stat: /home/strato/http/premium/rid/42/89/53944289/htdocs/test4/styles/app.php
16.05.2019 10:13:22 www.carcassonne-forum.de [client 66.249.66.0] AH02811: script not found or unable to stat: /home/strato/http/premium/rid/42/89/53944289/htdocs/test4/styles/app.php
16.05.2019 11:17:46 www.carcassonne-forum.de [client 66.249.66.0] AH02811: script not found or unable to stat: /home/strato/http/premium/rid/42/89/53944289/htdocs/test4/styles/app.php
16.05.2019 11:17:46 www.carcassonne-forum.de [client 66.249.66.0] AH02811: script not found or unable to stat: /home/strato/http/premium/rid/42/89/53944289/htdocs/test4/styles/app.php
16.05.2019 11:17:58 www.carcassonne-forum.de [client 66.249.66.0] AH02811: script not found or unable to stat: /home/strato/http/premium/rid/42/89/53944289/htdocs/test4/styles/app.php
16.05.2019 12:18:11 www.carcassonne-forum.de [client 66.249.66.0] AH02811: script not found or unable to stat: /home/strato/http/premium/rid/42/89/53944289/htdocs/test4/styles/app.php
16.05.2019 12:18:14 www.carcassonne-forum.de [client 66.249.66.0] AH02811: script not found or unable to stat: /home/strato/http/premium/rid/42/89/53944289/htdocs/test4/styles/app.php
16.05.2019 12:18:18 www.carcassonne-forum.de [client 66.249.66.0] AH02811: script not found or unable to stat: /home/strato/http/premium/rid/42/89/53944289/htdocs/test4/styles/app.php
16.05.2019 12:20:38 www.carcassonne-forum.de [client 87.175.38.0] AH01215: sh: command: not found: /home/strato/http/premium/rid/42/89/53944289/htdocs/test4/posting.php
16.05.2019 12:20:50 www.carcassonne-forum.de [client 87.175.38.0] AH01215: sh: command: not found: /home/strato/http/premium/rid/42/89/53944289/htdocs/test4/posting.php

Re: [3.2] HTTP-Fehler bei Dateianhängen

Verfasst: 16.05.2019 21:53
von canonknipser
Was du versuchen kannst, ist mit den Entwicklungs-Tools deines Browser (z.B. Firefox F12) zu schauen, ob du in dem plupload-script einen Fehler zu sehen bekommst. Den solltest du, wenn überhaupt, in den Netzwerk-Informationen finden können.

Re: [3.2] HTTP-Fehler bei Dateianhängen

Verfasst: 16.05.2019 22:29
von maik63de
Hi canonknipser,

wenn ich das jetzt richtig gemacht habe, zeigt das Entwickler-Tool bei Netzwerkanalyse beim Upload an:

bei einer kleinen Grafik kommt 200 OK.
bei einer großen Grafik kommt 408 Request Timeout.

Re: [3.2] HTTP-Fehler bei Dateianhängen

Verfasst: 16.05.2019 22:43
von canonknipser
Ja, da liefert dein Server einen Timeout zurück. Da musst du wohl den Wert für die php-Variable max_execution_time erhöhen (lassen)

Re: [3.2] HTTP-Fehler bei Dateianhängen

Verfasst: 16.05.2019 22:55
von maik63de
Hi,

ich habe im Root-Verzeichnis eine php.ini mit dem Eintrag:

max_execution_time = 600

Aber in den PHP-Informationen steht der Wert nur auf 120.

Nachtrag:

Habe jetzt den Wert auf 600 erhöhen können, leider hat das nichts am Verhalten beim Upload geändert. :-?

Re: [3.2] HTTP-Fehler bei Dateianhängen

Verfasst: 17.05.2019 07:22
von Dr.Death
HTTP 408 ist schon eher ein seltener Fehler.

Siehe mal hier:
https://developer.mozilla.org/en-US/docs/Web/HTTP/Status/408
https://www.keycdn.com/support/408-request-timeout

Bitte doch mal Deinen Hoster in seiner Server Konfiguration nachzusehen.