[3.2] Seit einigen Tagen fehler...

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
olli395
Mitglied
Beiträge: 8
Registriert: 24.01.2015 14:43
Kontaktdaten:

[3.2] Seit einigen Tagen fehler...

Beitragvon olli395 » 03.06.2019 07:20

Seit einigen Tagen kommt folgender Fehler, sobald ich irgendetwas im Adminbereich mache. Es reicht schon den cache zu leeren!

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/filesystem/filesystem.php on line 880: is_file(): open_basedir restriction in effect. File(/var) is not within the allowed path(s): (/var/www/vhosts/domain.ro/:/tmp/)

Spiele ich dann ein Backup (ohne DB) auf, ist alles wieder normal!
Der Host Support hat folgendes geantwortet:
Ich habe Ihnen den Wert "open_basedir" auf den Wert in der Fehlermeldung angepasst: "/var/www/vhosts/domain.ro/:/tmp/" bitte prüfen Sie das Ergebnis und erstellen Sie ggf. diesen Ordner.
Das Verzeichnis /tmp existiert und ist auch beschreibbar...
Interessant ist, dass das Testforum auf einer subdomain fehlerfrei läuft (?)
Was könnte das sein?

Achso:
phpbb 3.2.7
php 7.2.18

Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 15745
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.2] Seit einigen Tagen fehler...

Beitragvon Dr.Death » 03.06.2019 08:18

https://www.phpbb.de/kb/open_basedir

Du kannst nachprüfen, ob die Einstellung deines Hosters in Deinem Webspace greift:

ACP -->
Allgemein -->
PHP-Information -->
open_basedir --> [...]:/tmp/

olli395
Mitglied
Beiträge: 8
Registriert: 24.01.2015 14:43
Kontaktdaten:

Re: [3.2] Seit einigen Tagen fehler...

Beitragvon olli395 » 03.06.2019 08:35

Danke für die Antwort.
Dort steht:
open_basedir /var/www/vhosts/bolle-net.ro/:/tmp/ /var/www/vhosts/bolle-net.ro/:/tmp/



Komisch ist, dass das vorher lief, aber seit ca. Freitag nicht mehr...
Auf das Basedir - zeug hat mich Kirk schon hingewiesen, Der Hosting support hat das mittlerweile ja auch eingestellt, nur gebracht hat es nichts...(?)

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11983
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Seit einigen Tagen fehler...

Beitragvon Mahony » 03.06.2019 09:02

Hallo
olli395 hat geschrieben:Dort steht:
open_basedir /var/www/vhosts/bolle-net.ro/:/tmp/ /var/www/vhosts/bolle-net.ro/:/tmp/

Sollte da nicht open_basedir /var/www/vhosts/rumaenienforum.ro/:/tmp/ /var/www/vhosts/rumaenienforum.ro/:/tmp/ stehen?


Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

olli395
Mitglied
Beiträge: 8
Registriert: 24.01.2015 14:43
Kontaktdaten:

Re: [3.2] Seit einigen Tagen fehler...

Beitragvon olli395 » 03.06.2019 09:17

rumaenienforum. ro läuft als addon-Domain.
Der Basisordner ist bolle-net das Forum in einem eigenen Ordner...

Ich habe nun mal das Update (3.2.7) "Drübergebügelt und jetzt läuft wieder alles!

Keine Ahnung was da schief gelaufen ist! - Irgendetwas muss sich "selbstständig" verändert haben...


Zurück zu „Support-Forum“