[3.2] Fehlermeldung im Admin Bereich

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Antworten
dogsch
Mitglied
Beiträge: 50
Registriert: 21.03.2012 12:45

[3.2] Fehlermeldung im Admin Bereich

Beitrag von dogsch » 06.08.2019 15:22

Hallo,

ich habe nach langem Gehakele jetzt endlich die Version 3.2.7 zum Laufen gebracht, jedoch kommt beim Aufruf des Administrations-Bereichs die folgende Fehlermeldung und arunter der "normale" Adminscreen - wie es jedoch aussieht kann dann weiter normal arbeiten und die Fehleranzeige verschwindet dann auch wieder:

[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_main.php on line 496: A non-numeric value encountered
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 137: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3365)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 137: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3365)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 137: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3365)

Was bedeutet diese Anzeige, was hat das evtl. für Folgen und vor Allem, wie bekomme ich die wieder weg?

Gruß

OttoGeorg

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11998
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Fehlermeldung im Admin Bereich

Beitrag von Mahony » 06.08.2019 18:38

Hallo
Hm....nun denn..

Schauen wir uns doch mal die Fehlermeldung ganz genau an
dogsch hat geschrieben:[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_main.php on line 496: A non-numeric value encountered
O.k. der Fehler tritt also auf, wenn die Datei /includes/acp/acp_main.php aufgerufen wird....und zwar tritt der Fehler in Zeile 496 auf.

Wir öffnen also besagte Datei und schauen was dort in Zeile 496 steht.

Folgender Code findet sich in Zeile 496

Code: Alles auswählen

$boarddays = (time() - $config['board_startdate']) / 86400;
Aha...was Schlussfolgern wir nun daraus?

Richtig: Das Feld board_startdate in der Datenbank-Tabelle phpbb_config enthält keinen Numerischen Wert.

Lösung: Einen Numerischen Wert eintragen und das Problem ist gelöst.

P.S. Der einzutragende Wert sollte ein TIMESTAMP Wert sein. Hier findest du einen Converter um den Timestamp zu erstellen >>> https://www.epochconverter.com/

Achso der Wert im Feld board_startdate entspricht dem Feld Board eingerichtet: im Administrationsbereich im Reiter Allgemein (also wann das Forum installiert wurde).


Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

dogsch
Mitglied
Beiträge: 50
Registriert: 21.03.2012 12:45

Re: [3.2] Fehlermeldung im Admin Bereich

Beitrag von dogsch » 31.08.2019 18:09

Mahony hat geschrieben:Hallo
Hm....nun denn..

...

P.S. Der einzutragende Wert sollte ein TIMESTAMP Wert sein. Hier findest du einen Converter um den Timestamp zu erstellen >>> https://www.epochconverter.com/

Achso der Wert im Feld board_startdate entspricht dem Feld Board eingerichtet: im Administrationsbereich im Reiter Allgemein (also wann das Forum installiert wurde).

Grüße: Mahony
Hallo,

habe jetzt den Wert angepaßt:

Epoch timestamp: 1329682074
Timestamp in milliseconds: 1329682074000
Date and time (GMT): Sunday, 19. February 2012 20:07:54
Date and time (your time zone): Sonntag, 19. Februar 2012 21:07:54 GMT+01:00

Den Epoch timestamp: 1329682074 habe ich dann mit phpmyAdmin in der Tabelle php_config ins Feld board_startdate als Value eingefügt (da stand vorher UNIX_timestamp).

Im ACP steht jedoch immernoch:

Board eingerichtet: 01 Jan 1970, 00:00

und diese komischen Zeilen kommen nachwievor.

Ist ja eigentlich nur nicht schön, oder?
Könnte ich dann mit Leben, da ich der alleinige Admin bin.

Danke % Gruß

OttoGeorg

Automatisch dem Beitrag hinzugefügt nach 4 Minuten 8 Sekunden. Bitte Regel für „Topic-Bumping“ beachten. Danke.

ooops, jetzt hat er ja doch etwas übernommen, jedoch steht jetzt als Einrichtungsdatum 12 Mär 2012, 20:07...

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11998
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Fehlermeldung im Admin Bereich

Beitrag von Mahony » 31.08.2019 18:25

Hallo
Hast du anschließend auch den Cache geleert (vom Forum und vom Browser)?

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

Antworten

Zurück zu „Support-Forum“