[3.2] Forum bei Updateversuch unbrauchbar gemacht?

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Antworten
Gast2009283

[3.2] Forum bei Updateversuch unbrauchbar gemacht?

Beitrag von Gast2009283 »

Hallo,
ich habe mein phpBB 3.2.3 Forum aus versehen unbrauchbar gemacht. Ich habe das Forum im ACP deaktiviert, weil ich ein Upgrade auf die neuste phpBB Version durchführen wollte. Danach habe ich die Dateien gelöscht, auch den "Cache" Ordner, zumindest teilweise, weil es nicht funktioniert hat.

Die Dateien sind mittlerweile alle gelöscht (bis auf einen Teil des Cache Ordners / den ich jetzt umbenannt habe), ich habe nur noch die Datenbank bei meinem Webhoster und ein Backup von der config.php und der hochgeladenen "avatars".

Wie bekomme ich das Forum wieder lauffähig?

Mein Webhoster bietet die Möglichkeit an, ein aktuelles phpBB 3.2.7 Forum zu installieren. Könnte ich das nicht durchführen und dann nur die config.php wieder hochladen? Wie muss ich vorgehen, um mein Forum wieder lauffähig zu bekommen?

Danke für Eure Hilfe.
vfrblue
Ehemaliges Teammitglied
Beiträge: 1828
Registriert: 22.11.2016 18:46

Re: [3.2] Forum bei Updateversuch unbrauchbar gemacht?

Beitrag von vfrblue »

Falls du einen FTP-Zugang zu deinem Webspace hast, sollte es kein Problem sein.

Lade dir hier das Installationspaket herunter https://www.phpbb.de/downloads/pakete/, entpacke es und lösche die eventuell vorhandene config.php aus dem Paket. Du kannst dann nach dieser Anleitung vorgehen KB:install32x, wobei die Erstellung der Datenbank und die Einrichtung des Boards entfallen. Wichtig ist eigentlich nur das Hochladen der Dateien auf das Webspace und die Aktualisierung durch Aufruf der Installations-Routine.
Nachdem du die Dateien auf das Webspace hochgeladen hast, müssen die Zugriffsrechte noch gesetzt werden: Alle Dateien CHMOD 644, alle Verzeichnisse, ausser /cache, /files, /store, und eventuell /images/avatars/upload, CHMOD 755, die ausgenommenen Verzeichnisse bekommen CHMOD 777.
Jetzt kopierst du die originale "config.php" auch ins Root des Forums und rufst dann die Installationsroutine auf.
Beachte, dass du die Dateien in das Verzeichnis des alten Forums hochlädst.
Antworten

Zurück zu „Support-Forum“