[3.3] Fehlermeldung bei automatischer Installation von 3.3

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
jarde74
Mitglied
Beiträge: 48
Registriert: 13.12.2019 08:29
Wohnort: Münster
Kontaktdaten:

[3.3] Fehlermeldung bei automatischer Installation von 3.3

Beitrag von jarde74 »

Hallo,

ich habe gerade versucht die automatische installation zu starten, nachdem ich die Verzeichnisse "Install" und "Vendor" in das Verzeichniss phpbb veschoben habe.
Leider kann ich die automatische Installation nicht starten da ich eine Fehlermeldung erhalte, mit der ich nichts anfangen kann.

[phpBB Debug] "Declaration of phpbb\template\twig\loader::findTemplate($name) should be compatible with Twig\Loader\FilesystemLoader::findTemplate($name, $throw = true)" in file /mnt/web516/a0/09/510266909/htdocs/phpBB_01/phpbb/template/twig/loader.php on line 19

Ich wäre über hilfe sehr froh.

Danke
Das Sportforum
www.sportlichfit.com
Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 11010
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: [3.3] Fehlermeldung bei automatischer Installation von 3.3

Beitrag von Crizzo »

Hi,

ich verstehe nicht, was du genau machst bzw. machen willst.

Willst du jetzt ein frisches phpBB 3.3.0 installieren? Falls ja, dann gibt dieser Schritt gar keinen Sinn:
jarde74 hat geschrieben:
06.02.2020 20:47
nachdem ich die Verzeichnisse "Install" und "Vendor" in das Verzeichniss phpbb veschoben habe.
Die Installation geht so: https://www.phpbb.de/kb/install33x

Wenn du ein Update von 3.2.x auf 3.3.0 machen willst, dann ist dieser Schritt auch nicht wirklich sinnvoller.

Folge beim Update bitte dieser Anleitung: https://www.phpbb.de/kb/phpBB33_upgrade_from_32

Grüße
jarde74
Mitglied
Beiträge: 48
Registriert: 13.12.2019 08:29
Wohnort: Münster
Kontaktdaten:

Re: [3.3] Fehlermeldung bei automatischer Installation von 3.3

Beitrag von jarde74 »

Hallo,

crizzo danke für deine Tips. Der Fehler lag bei mir, ich habe die Falsche updatedatei hochgealden.

Jetzt komme ich mit dem Update weiter, aber nicht bis zum ende :roll:

Bei dem letzten Schritt "Dateien aktualisieren " UND dann "Mit dem Update fortfahren" das klappt nicht.
Ich habe die geänderten Daten heruntergeladen und auf den Server gebracht, aber es geht da nicht weiter.

Es ist nur der Button "Daten erneut prüfen" unterlegt.

Beim KOnventiern bekomme ich diese fehlermeldung:

Der Pfad zu deinem alten Board konnte nicht gefunden werden. Bitte prüfe deine Einstellungen und versuche es erneut.» Der angegebene Quell-Pfad war:
Das Sportforum
www.sportlichfit.com
Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 11010
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: [3.3] Fehlermeldung bei automatischer Installation von 3.3

Beitrag von Crizzo »

Hi,

beim Konvertieren bist du auch ganz falsch.

Zudem, in der Anleitung wird nicht empfohlen das "automatische Update" - Paket zu nehmen, sondern das Komplettpaket.

Daher würde ich empfehlen, du fängst mit dem Update nochmal von vorne an.

Grüße
jarde74
Mitglied
Beiträge: 48
Registriert: 13.12.2019 08:29
Wohnort: Münster
Kontaktdaten:

Re: [3.3] Fehlermeldung bei automatischer Installation von 3.3

Beitrag von jarde74 »

Jetzt habe ich versucht das ganze manuel durchzuführen und auch da klappt es nicht?!

Ich bekomme bei dem versuch den "Install" durchzuführen diese Meldung:

Die Datei Array konnte nicht für den Dateivergleich geöffnet werden.

[phpBB Debug] "file_get_contents(../install/update/new/.htaccess): failed to open stream: No such file or directory" in file /mnt/web516/a0/09/510266909/htdocs/phpBB_01/phpbb/install/module/update_filesystem/task/diff_files.php on line 182

[phpBB Debug] "Array to string conversion" in file /mnt/web516/a0/09/510266909/htdocs/phpBB_01/phpbb/language/language.php on line 313
Das Sportforum
www.sportlichfit.com
Benutzeravatar
Scanialady
Junior Public Relations-Team
Beiträge: 756
Registriert: 23.02.2009 16:29
Wohnort: Velbert (NRW)
Kontaktdaten:

Re: [3.3] Fehlermeldung bei automatischer Installation von 3.3

Beitrag von Scanialady »

Hast du den Vendor-Ordner gelöscht, und dann alle Dateien aus dem Komplettpaket noch einmal vollständig neu hochgeladen (ohne config.php und ggf. ohne .htaccess, falls deine angepasst ist)? Cache manuell und über ACP geleert? Beim Browser ebenfalls Cache geleert?
https://ladyscommunity.de | Deutsche Übersetzungen für Extensionen (ggf. auf Anfrage)
-
Die Bosheit trinkt die Hälfte ihres eigenen Giftes (Lucius Annaeus Seneca)
-
Wenn von etwas kein Backup existiert, dann ist es nicht wichtig.
jarde74
Mitglied
Beiträge: 48
Registriert: 13.12.2019 08:29
Wohnort: Münster
Kontaktdaten:

Re: [3.3] Fehlermeldung bei automatischer Installation von 3.3

Beitrag von jarde74 »

Ich habe mich an folgende ANleitung gehalten:


Im Installationsverzeichnis des Boards alle Dateien/Ordner löschen außer:
config.php
.htaccess (falls modifiziert)
/files
/images
Optional: /ext => wenn installierte Extensions vorhanden sind
Optional: /styles => wenn weitere Styles neben prosilver vorhanden sind, die erhalten bleiben sollen
Optional: /store (hier werden u.a. übers ACP generierte Datenbank-Backups gespeichert)
Den Inhalt des oben ausgepackten Ordners "phpBB3" (minus der config.php ;) ) des Komplettpakets ins Installationsverzeichnis auf dem Server hochladen.
Noch vorhandene Dateien kannst Du dabei überschreiben lassen (deswegen ja auch vorher die config.php aus dem hochzuladenden Komplettpaket entfernen ;) )
Wenn alles erfolgreich und fehlerfrei hochgeladen wurde: im Browser die Adresse des Installationsordners aufrufen => <pfad_zum_board>/install/
(Sollte dies wider Erwarten nicht die Startseite des Updatemoduls aufrufen, dann alternativ mit <pfad_zum_board>/install/app.php erneut versuchen.)
Sollte das Installationsmodul nicht in Deutsch angezeigt werden: dies kann rechts oben in der Sprachauswahl korrigiert werden.
Von den Tabs links oben "Aktualisieren" anklicken
Da bereits alle Dateien durch neue ersetzt wurden bekommst Du als Option nur noch "Datenbankupdate durchführen" angeboten => auswählen und bestätigen, um das DB-Update zu starten.
Wenn dieser Lauf erfolgreich abgeschlossen ist: das /install Verzeichnis auf dem Server löschen oder umbenennen und Dich im ACP anmelden
Die vor Upgradebeginn deaktivierten Extensions nacheinander und einzeln wieder aktivieren und jeweils ausführlich testen. Extensions, die hierbei Fehler aufzeigen, gegebenenfalls bis zur Veröffentlichung einer bereinigten oder für eure 3.3.x-Version validierten Revision deaktiviert lassen.
Wartungsmodus wieder aufheben


Den Cache im Browser habe ich gelöscht, dem im ACP kann ich nicht löschen oder besser ich weiß nicht wo da ich mich nicht einloggen kann.
Neue Dateien hochgalden mit config.php und mit htaccess.

Grüße
Das Sportforum
www.sportlichfit.com
Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 16442
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.3] Fehlermeldung bei automatischer Installation von 3.3

Beitrag von Dr.Death »

Nach dieser Anleitung solltest du nicht das Update Paket hochladen, sonder das Komplettpaket phpBB 3.3.0
Hast Du das gemacht ?
jarde74
Mitglied
Beiträge: 48
Registriert: 13.12.2019 08:29
Wohnort: Münster
Kontaktdaten:

Re: [3.3] Fehlermeldung bei automatischer Installation von 3.3

Beitrag von jarde74 »

Das habe ich auch gemacht, nach der von mir geposteten Anleitung habe ich das Komplettpaket hochgeladen.
crizo hat mir ja empfohlen das ganze zu wiederholen, deshalb habe ich dann die Kompletversion gewählt.

Grüße und danke für eure Unterstützung.
Das Sportforum
www.sportlichfit.com
Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 16442
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.3] Fehlermeldung bei automatischer Installation von 3.3

Beitrag von Dr.Death »

Wenn ich Deine URL aufrufe mit /install am Ender URL sehe ich einen Update Reite, dort klicke ich drauf und sage "Dateien erneut prüfen" wird mir angezeigt, das Du noch Dateien auf dem Server hast die gelöscht werden sollen.
Zu löschende Dateien
» Datei-Liste ein-/ausblenden
Die folgenden Dateien existieren nicht mehr in der neuen Version. Diese Dateien müssen aus deiner Installation gelöscht werden.

STATUS_DELETED
styles/prosilver/template/ucp_remind.html
styles/prosilver/theme/images/bg_header.gif
styles/prosilver/theme/images/bg_list.gif
styles/prosilver/theme/images/icon_download.gif
styles/prosilver/theme/images/icon_offline.gif
styles/prosilver/theme/images/icon_online.gif
styles/prosilver/theme/images/icon_rate_bad.gif
styles/prosilver/theme/images/icon_rate_good.gif
styles/prosilver/theme/images/quote.gif
styles/prosilver/theme/images/quote_rtl.gif
Wie kann das sein, wenn du alle Dateien ersetzt hast?
Du hast also u.a. den Ordner /styles nicht ersetzt, somit ist das kein sauberes prosilver.

Entweder du löscht die angezeigten Dateien, oder du fängst nochmal von von an.
Antworten

Zurück zu „Support-Forum“