Seite 1 von 1

[3.3] /install/app.php: Die Seite kann nicht gefunden werden

Verfasst: 20.08.2020 09:38
von Clara Luka
Hallo!
Ich sitze gerade zum ersten Mal am Update meines Forums und habe bisher das komplette Paket von phpBB 3.3.1 heruntergeladen, entpackt, manche Berechtigungen geändert und alles via FTP auf den Server hochgeladen (und dort die alten Pakete überschrieben). Jetzt versuche ich, über /install/app.php mit der Installation fortzufahren, erhalte aber die Meldung "Die angeforderte Seite konnte nicht gefunden werden".
Habt ihr Ideen, woran das liegen kann?
Liebe Grüße,
Luka

Re: [3.3] /install/app.php: Die Seite kann nicht gefunden werden

Verfasst: 20.08.2020 12:24
von Dr.Death
Hi,

du hast evtl. nicht alle Dateien hochgeladen, oder die Datei "app.php" im Forumsordner "/install" ist nicht vorhanden bzw. nicht lesbar.

Re: [3.3] /install/app.php: Die Seite kann nicht gefunden werden

Verfasst: 20.08.2020 16:46
von Lucan
Benenn testweise - und nur für das Update - Mal die .htaccess im Root Verzeichnis vom Forum um, wenn die oben genannten Tipps nicht um Erfolg führen.

Re: [3.3] /install/app.php: Die Seite kann nicht gefunden werden

Verfasst: 23.08.2020 12:45
von Clara Luka
Danke für die schnellen Antworten! Ich habe den Fehler inzwischen gefunden, da ist was bei der Übertragung in den Server schiefgegangen.
Jetzt bin ich mir (relativ) sicher, dass die Dateien und Verzeichnisse alle ordnungsgemäß hochgeladen sind. Aber: wenn ich jetzt meineseite/install/app.php aufrufe, bekomme ich nur eine leere Seite zu sehen :o
Habt ihr Tipps, woran das liegen könnte?
Danke schonmal im voraus :)

Re: [3.3] /install/app.php: Die Seite kann nicht gefunden werden

Verfasst: 23.08.2020 13:58
von Mike-on-Tour
Wolltest du die Datenbank updaten? Dann sollte es heißen meineseite/install/app.php/update.
Wenn das auch nicht funktioniert, dann müsstest du mal in deinen Fehler-Logs nachsehen (error.log von Apache und/oder php_error.log in deinem php-Verzeichnis), denn eine weiße Seite deutet in der Regel auf einen php-Fehler hin (das Skript geht irgendwo ins elektronische Nirwana und gibt nichts mehr aus).

Re: [3.3] /install/app.php: Die Seite kann nicht gefunden werden

Verfasst: 23.08.2020 15:30
von Scanialady
Es könnte helfen, via FTP in den Ordner /cache auf dem Server zu gehen, und dort alles zu löschen, außer index.htm und .htaccess, und danach noch mal die Installation aufzurufen. Klicke auch mal auf die Sprachauswahl und wähle Deutsch aus - auch wenn es aussieht, als sei es ausgewählt. Erst dann den Update-Tab aufrufen. Das hat mir bei einem ähnlichen Problem geholfen.

Re: [3.3] /install/app.php: Die Seite kann nicht gefunden werden

Verfasst: 16.09.2020 16:08
von f4ce
Hallo zusammen,

ich habe auch das Problem mit der leeren Seite bei Aufruf von /install/app.php
Anbei mal der Error-Log - hoffe es hat jemand eine Idee, danke.
Hoster ist Strato.

16.09.2020 15:54:20 [client 2003:cc:7f00::] Stack trace:
16.09.2020 15:54:20 [client 2003:cc:7f00::] #0 /mnt/web409/b0/01/56905301/htdocs/phpBB3/phpbb/template/twig/loader.php(135): Twig\\Loader\\FilesystemLoader->findTemplate('installer_main....', true)

16.09.2020 15:54:20 [client 2003:cc:7f00::] #1 /mnt/web409/b0/01/56905301/htdocs/phpBB3/vendor/twig/twig/src/Loader/FilesystemLoader.php(150): phpbb\\template\\twig\\loader->findTemplate('installer_main....')

16.09.2020 15:54:20 [client 2003:cc:7f00::] #2 /mnt/web409/b0/01/56905301/htdocs/phpBB3/vendor/twig/twig/src/Environment.php(299): Twig\\Loader\\FilesystemLoader->getCacheKey('installer_main....')

16.09.2020 15:54:20 [client 2003:cc:7f00::] #3 /mnt/web409/b0/01/56905301/htdocs/phpBB3/vendor/twig/twig/src/Environment.php(381): Twig\\Environment->getTemplateClass('installer_main....')

16.09.2020 15:54:20 [client 2003:cc:7f00::] #4 /mnt/web409/b0/01/56905301/htdocs/phpBB3/phpbb/template/twig/environment.php(277): Twig\\Environment->loadTemplate('installer_main....', NULL)

16.09.2020 15:54:20 [client 2003:cc:7f00::] #5 /mnt/web409/b0/01/56905301/htdocs/phpBB3/vendor/twig/twig/src in /mnt/web409/b0/01/56905301/htdocs/phpBB3/vendor/twig/twig/src/Loader/FilesystemLoader.php on line 205

Was ich bereits versucht habe, ist folgendes die Verzeichnisse "vendor" und "phpbb" gelöscht und erneut hochgeladen, danach den cache geleert bis auf die Dateien ".htacess" und "index.html".

Re: [3.3] /install/app.php: Die Seite kann nicht gefunden werden

Verfasst: 16.09.2020 16:13
von Crizzo
Da müsste noch die Fehlermeldung vor dem Stacktrace stehen. Zeig uns die auch nochmal.

Re: [3.3] /install/app.php: Die Seite kann nicht gefunden werden

Verfasst: 16.09.2020 16:16
von f4ce
PHP Fatal error: Uncaught Twig\\Error\\LoaderError: Unable to find template "installer_main.html" (looked into: ). in /mnt/web409/b0/01/56905301/htdocs/phpBB3/vendor/twig/twig/src/Loader/FilesystemLoader.php:205

Automatisch dem Beitrag hinzugefügt nach 48 Minuten 17 Sekunden. Bitte Regel für „Topic-Bumping“ beachten. Danke.

So hat jetzt doch geklappt, ich habe denn Ordner Styles nochmals erneut hochgeladen und jetzt ist die Installation ohne Probleme durchgelaufen.