[3.3] Update auf 3.3.2 funktioniert nicht

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
69bruno
Mitglied
Beiträge: 139
Registriert: 05.06.2020 08:21

[3.3] Update auf 3.3.2 funktioniert nicht

Beitrag von 69bruno »

Hallo,

ich habe eben versucht, mein Testforum upzudaten.

Bin wie folgt vorgegangen:
- Board deaktiviert
- Alle Ext deaktiviert
- phpbb3.3.2 Paket runtergeladen (da kein deutsches Komplettpaket da war, das englische)
- Entpackt, config.php, files, images und store gelöscht.
- .htacces und Verzeichnis ext gelöscht
- Im Boardverzeichnis Verndor und cache gelöscht
- per winscp im Binärformat hochgeladen
- Url mit /install aufgerufen
- Script startet, auf Deutsch "Du" umgestellt
- Auf Aktualisieren geklickt.

Fehlermeldungen:
1.
PHP mbstring support
In order for phpBB to function correctly, the PHP mbstring extension needs to be available.
2.
Es wurde kein Update-Verzeichnis gefunden. Bitte stelle sicher, dass du die richtigen Dateien hochgeladen hast.

Nachtrag:
Zum 3. mal das Paket runtergeladen, config.php, /files, /images, /store, /ext und .htaccess gelöscht.
Diesmal wieder zu einem winzip Archiv konvertiert. Mit Webmin hochgeladen und auf dem Server entpacken lassen. Diesmal startet nicht die Updateversion, sondern die Install-Version.
Fehlermeldung:
PHP mbstring support
In order for phpBB to function correctly, the PHP mbstring extension needs to be available.
Forum: cruiser-lounge.de
PHPBB-Version: 3.3.2
Debian-Linux 10
PHP-Version: 7.3.14
Apache-Sever-Version: 2.4.38
MySQL-Version 10.3.22
Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 16475
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.3] Update auf 3.3.2 funktioniert nicht

Beitrag von Dr.Death »

In deiner verwendeten PHP (nicht phpBB) Version fehlt die : mbstring Unterstützung.
PHP mbstring support
In order for phpBB to function correctly, the PHP mbstring extension needs to be available.
Wende Dich an deinen Hoster, oder an Dich selbst, wenn du PHP selbst auf deinem Host installiert hast.
69bruno
Mitglied
Beiträge: 139
Registriert: 05.06.2020 08:21

Re: [3.3] Update auf 3.3.2 funktioniert nicht

Beitrag von 69bruno »

Hmm....
Ich bin der Hoster selbst.
Wenn für die PHPBB3.3.1 eine mbstring Unterstützng notwendig war, dann ist sie auch da, mein Produktivforum läuft schließlich noch (3.3.1)
Forum: cruiser-lounge.de
PHPBB-Version: 3.3.2
Debian-Linux 10
PHP-Version: 7.3.14
Apache-Sever-Version: 2.4.38
MySQL-Version 10.3.22
Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 16475
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.3] Update auf 3.3.2 funktioniert nicht

Beitrag von Dr.Death »

Kannst Du auf deinem öffentlichen Webspace (der wo dein Forum erreichbar ist) eine php Datei hinlegen mit folgendem Inhalt:

Dateiname: z.B. "test.php"
Datei Inhalt:

Code: Alles auswählen

<?php
phpinfo(INFO_MODULES);

Rufe die Datei mal mit deinem Browser auf, oder verlinke sie mal hier......dann sollte man sehen können ob das mbstring Modul korrekt eingelesen wird.

Die Installationsroutine prüft es ja:

Code: Alles auswählen

	/**
	 * Checks whether PHP's mbstring extension is available or not
	 */
	protected function check_mbstring()
	{
		if (@extension_loaded('mbstring'))
		{
			$this->set_test_passed(true);
			return;
		}

		$this->response_helper->add_error_message('PHP_MBSTRING_SUPPORT', 'PHP_MBSTRING_SUPPORT_EXPLAIN');

		$this->set_test_passed(false);
	}
69bruno
Mitglied
Beiträge: 139
Registriert: 05.06.2020 08:21

Re: [3.3] Update auf 3.3.2 funktioniert nicht

Beitrag von 69bruno »

Bei beiden Foren folgendes Ergebnis:

Code: Alles auswählen

Multibyte decoding support using mbstring 	disabled 
Das Produktivforum läuft aber (3.3.1), ergo muss es ja eine neue Voraussetzung für die Version 3.3.2 geben ?!?!?!

Das einzige, was ich nicht gemacht hatte, war das deutsche Sprachpaket zu deaktivieren.... kann das ein Problam darstellen ?
Forum: cruiser-lounge.de
PHPBB-Version: 3.3.2
Debian-Linux 10
PHP-Version: 7.3.14
Apache-Sever-Version: 2.4.38
MySQL-Version 10.3.22
Benutzeravatar
oxpus
Ehemaliges Teammitglied
Beiträge: 5280
Registriert: 03.02.2003 12:33
Wohnort: Bad Wildungen
Kontaktdaten:

Re: [3.3] Update auf 3.3.2 funktioniert nicht

Beitrag von oxpus »

69bruno hat geschrieben:
08.11.2020 17:08

Code: Alles auswählen

Multibyte decoding support using mbstring 	disabled 
Das Produktivforum läuft aber (3.3.1), ergo muss es ja eine neue Voraussetzung für die Version 3.3.2 geben ?!?!?!
Das ist korrekt. phpBB 3.3.2 prüft jetzt u. a. auch auf das Vorhandensein des mbstring-Modules in PHP.
Wenn das also bei Dir deaktiviert ist, wie du es gepostet hast, musst du es aktivieren, bevor Du auf phpBB 3.3.2 aktualisieren kannst.

Die Funktion steht auch hier mit drinnen: https://www.phpbb.com/support/docs/en/3 ... uirements/
Zuletzt geändert von oxpus am 08.11.2020 17:37, insgesamt 1-mal geändert.
Grüße
OXPUS
Kein Support bei unaufgeforderten PNs, E-Mails oder auf anderem Weg!!
69bruno
Mitglied
Beiträge: 139
Registriert: 05.06.2020 08:21

Re: [3.3] Update auf 3.3.2 funktioniert nicht

Beitrag von 69bruno »

Schon gemacht (gabs da irgendwo einen Hinweis drauf ?),

aber ich kriege kein Update mehr hin, phpbb bietet mir nur noch Vollinstalation an.
Ich hatte das Testforum über meine nächtliche Sicherung zurückgeholt.
Im Boardverzeichnis /cache und /vendor gelöscht und das Paket wieder hochgeladen.
Wie gesagt. Jetzt könnte ich neu installieren, aber nicht updaten.

Wie kriege ich das noch gefixt ?
Forum: cruiser-lounge.de
PHPBB-Version: 3.3.2
Debian-Linux 10
PHP-Version: 7.3.14
Apache-Sever-Version: 2.4.38
MySQL-Version 10.3.22
Benutzeravatar
oxpus
Ehemaliges Teammitglied
Beiträge: 5280
Registriert: 03.02.2003 12:33
Wohnort: Bad Wildungen
Kontaktdaten:

Re: [3.3] Update auf 3.3.2 funktioniert nicht

Beitrag von oxpus »

Am besten folgst Du dieser Anleitung:
https://www.phpbb.com/support/docs/en/3 ... upgrade32/

Das beschreibt zwar das Update von 3.2.x auf 3.3.x, aber das würde ich jedem raten, der das phpBB von 3.x auf 3.x aktualisieren möchte.

Neben den genannten Ordnern und Dateien sollte man aber auch alle anderen Dateien behalten, die man selber hinzugefügt hat.
Das nur als Hinweis an dieser Stelle.
Grüße
OXPUS
Kein Support bei unaufgeforderten PNs, E-Mails oder auf anderem Weg!!
69bruno
Mitglied
Beiträge: 139
Registriert: 05.06.2020 08:21

Re: [3.3] Update auf 3.3.2 funktioniert nicht

Beitrag von 69bruno »

So, testforum umgestellt.
mbstring nachinstalliert, festgestellt, dass die config.php 0 bytes hatte, weil ich sie für's löschen wohl nicht mit einer Markierung erwischt hatte. Hoffentlich habe ich keine andere Datei gelöscht, aber das wird sich ja dann irgendwann zeigen...

Ich bin sehr froh, dass mit dem Testforum gemacht zu haben. Beim Produktivforum hätte ich Schweiß auf der Stirn gehabt..... :D
Forum: cruiser-lounge.de
PHPBB-Version: 3.3.2
Debian-Linux 10
PHP-Version: 7.3.14
Apache-Sever-Version: 2.4.38
MySQL-Version 10.3.22
Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 16475
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.3] Update auf 3.3.2 funktioniert nicht

Beitrag von Dr.Death »

Ein Backup braucht man nur, wenn man keins hat ... 🤓😎
Antworten

Zurück zu „Support-Forum“