[3.3] User Passwort reset

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Benutzeravatar
BNa
Valued Contributor
Beiträge: 2702
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.3] User Passwort reset

Beitrag von BNa »

Also noch anderererers :lol:
Dann ist die Seite nicht erreichbar oder nicht im Zugriff (nginx-Rechte?)
Da ich ein echter Fan *burps von nginx bin,
kann es eigentlich nur mit den Rechten der Datei (des übergestellten Ordners) zusammen hängen,
die den Passwort-Reset managed.
Sonst gibt es für einen 404er eigentlich keinen Grund....
Benutzeravatar
Cowboy of Bottrop
Mitglied
Beiträge: 170
Registriert: 01.02.2017 21:11
Wohnort: Bottrop
Kontaktdaten:

Re: [3.3] User Passwort reset

Beitrag von Cowboy of Bottrop »

Wenn der Zugriff wegen falsch gesetzter Rechte verweigert wird, kommt doch eher ein 503, oder? 404 ist ja nicht gefunden. Da scheint also eher was zu fehlen.

Vielleicht einfach das Archiv erneut entpacken und auf den Server laden, möglicherweise ist beim Upload irgendwas beschädigt worden.
Keep it County,
Markus aka Cowboy
Benutzeravatar
BNa
Valued Contributor
Beiträge: 2702
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.3] User Passwort reset

Beitrag von BNa »

Oder so, ja :wink:
mdkder3
Mitglied
Beiträge: 9
Registriert: 10.11.2020 08:50

Re: [3.3] User Passwort reset

Beitrag von mdkder3 »

So Langsam Jungs und ggf Mädels :( :(

also das Problem bestand schon vor 3.3.2
ich hatte gedacht das es mit dem Update von 3.3.1 auf 3.3.2 vllt weg geht, leider nein


also welche Nginx rechte und wo?

edit:

kann das auch sein das irgendwas gesperrt ist durch die htaccess noch??
69bruno
Mitglied
Beiträge: 140
Registriert: 05.06.2020 08:21

Re: [3.3] User Passwort reset

Beitrag von 69bruno »

Kannst du mal raussuchen, was dein Serverlog sagt ?

Und.... dass die app.php nicht im Link auftaucht, kann man im ACP einstellen.

("Umschreiben von URLs aktivieren:
Wenn aktiviert, werden URLs, die ‚app.php‘ enthalten, umgeschrieben, so dass sie keinen Dateinamen mehr enthalten. (z. B. wird app.php/foo zu /foo).")

Außerdem kannst du in der Boardkonfiguration / Boardeinstellungen bei der hinterlegten URL mal den Port entfernen.
Forum: cruiser-lounge.de
PHPBB-Version: 3.3.2
Debian-Linux 10
PHP-Version: 7.3.14
Apache-Sever-Version: 2.4.38
MySQL-Version 10.3.22
mdkder3
Mitglied
Beiträge: 9
Registriert: 10.11.2020 08:50

Re: [3.3] User Passwort reset

Beitrag von mdkder3 »

Kannst du mal raussuchen, was dein Serverlog sagt ?
ich hoffe das ist das was du wolltest
https://drive.google.com/drive/folders/ ... sp=sharing
Und.... dass die app.php nicht im Link auftaucht, kann man im ACP einstellen.

("Umschreiben von URLs aktivieren:
Wenn aktiviert, werden URLs, die ‚app.php‘ enthalten, umgeschrieben, so dass sie keinen Dateinamen mehr enthalten. (z. B. wird app.php/foo zu /foo).")
ja das habe ich schon raus gefunden bei mir ist das aktiv
Außerdem kannst du in der Boardkonfiguration / Boardeinstellungen bei der hinterlegten URL mal den Port entfernen.
das habe ich auch schon hin bekommen das der Port aus den Mail verschwindet (ich glaube da hatten wir per Mail geschrieben)
aber wenn der Port weg ist und funktioniert der Link nicht mehr nicht mehr wenn z.b.
http://url.xyz:12345 steht
sondern
http://forum.url.xyz in den Mails passiert nix mehr, dann kommt nur die Board Startseite aber z.b. keine Aktivierung des Accounts oder Passwort Änderung
es steht aber der Link komplett richtig in der Adressleiste
69bruno
Mitglied
Beiträge: 140
Registriert: 05.06.2020 08:21

Re: [3.3] User Passwort reset

Beitrag von 69bruno »

Außerdem kannst du in der Boardkonfiguration / Boardeinstellungen bei der hinterlegten URL mal den Port entfernen.
das habe ich auch schon hin bekommen das der Port aus den Mail verschwindet (ich glaube da hatten wir per Mail geschrieben)
aber wenn der Port weg ist und funktioniert der Link nicht mehr nicht mehr wenn z.b.
http://url.xyz:12345 steht
sondern
http://forum.url.xyz in den Mails passiert nix mehr, dann kommt nur die Board Startseite aber z.b. keine Aktivierung des Accounts oder Passwort Änderung
es steht aber der Link komplett richtig in der Adressleiste
Ich würde sowohl bei der Serverkonfiguration als auch in den Boardeinstellungen vollständig auf den Port verzichten. Danach würde ich die Verbindungsprobleme angehen. Wenn bei dir ein anderer Port als 80 vorgegeben ist, würde ich eine Umleitung auf den anderen Port einstellen, aber nicht im Board den Port ständig mitgeben.
wie Du mir geschrieben hattest, liegt dein Borad sozusagen direkt im Verzeichnis var/www/html, ohne Unterordner wie z.B. /phpbb3. Dann würde ich in der Servereinstellung auch den relativen Pfad zur Domain komplett leer lassen. Da Du noch http verwendest, brauchst du auch keine 0 in den Port zu schreiben, wenn du http als Protokoll ausgewählt hast, verwendet das Board standardmäßig Port 80.
Forum: cruiser-lounge.de
PHPBB-Version: 3.3.2
Debian-Linux 10
PHP-Version: 7.3.14
Apache-Sever-Version: 2.4.38
MySQL-Version 10.3.22
mdkder3
Mitglied
Beiträge: 9
Registriert: 10.11.2020 08:50

Re: [3.3] User Passwort reset

Beitrag von mdkder3 »

Ich würde sowohl bei der Serverkonfiguration als auch in den Boardeinstellungen vollständig auf den Port verzichten. Danach würde ich die Verbindungsprobleme angehen. Wenn bei dir ein anderer Port als 80 vorgegeben ist, würde ich eine Umleitung auf den anderen Port einstellen, aber nicht im Board den Port ständig mitgeben.
genau so habe ich es jetzt auch eingetragen,
ich muss ihn aber dazu zwingen wenn ich nicht auf zwang mache nimmt das Board immer den Port mit obwohl ich keinen eingetragen habe.
was noch dazu kommt
wenn ich den zwang am mache, werden alle Bilder aus den Beiträgen gehauen
wie Du mir geschrieben hattest, liegt dein Borad sozusagen direkt im Verzeichnis var/www/html, ohne Unterordner wie z.B. /phpbb3. Dann würde ich in der Servereinstellung auch den relativen Pfad zur Domain komplett leer lassen.
ja da steht jetzt nur "/" ohne irgendwas anderes
Da Du noch http verwendest, brauchst du auch keine 0 in den Port zu schreiben, wenn du http als Protokoll ausgewählt hast, verwendet das Board standardmäßig Port 80.
selbst wenn ich das Port leer lassen nach dem speichern trägt er immer wieder "0" ein.
das ist Normal oder??


Dann habe ich jetzt aber das Problem dass das Board jetzt alles ignoriert was hinter dem .xyz/ kommt





also keine Aktivierung oder Reset möglich ist usw.
69bruno
Mitglied
Beiträge: 140
Registriert: 05.06.2020 08:21

Re: [3.3] User Passwort reset

Beitrag von 69bruno »

Wenn Du
Board- und Browsercache geleert hast und ggfls. den
Server neu gestartet hast, weiß ich dann leider nicht weiter.
Forum: cruiser-lounge.de
PHPBB-Version: 3.3.2
Debian-Linux 10
PHP-Version: 7.3.14
Apache-Sever-Version: 2.4.38
MySQL-Version 10.3.22
mdkder3
Mitglied
Beiträge: 9
Registriert: 10.11.2020 08:50

Re: [3.3] User Passwort reset

Beitrag von mdkder3 »

69bruno hat geschrieben:
11.11.2020 13:16
Wenn Du
Board- und Browsercache geleert hast und ggfls. den
Server neu gestartet hast, weiß ich dann leider nicht weiter.
nein hilft leider nicht
Antworten

Zurück zu „Support-Forum“