[3.3] Update auf 3.3.2: Wrong Info File Format

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Benutzeravatar
Cowboy of Bottrop
Mitglied
Beiträge: 166
Registriert: 01.02.2017 21:11
Wohnort: Bottrop
Kontaktdaten:

[3.3] Update auf 3.3.2: Wrong Info File Format

Beitrag von Cowboy of Bottrop »

Ich habe mit dem deutschen Komplettpaket zwei Boards ohne Probleme von 3.3.1 auf 3.3.2 aktualisiert. Ein drittes Board zickt rum. Nachdem ich auf Aktualisieren geklickt habe, kommen folgende Fehler:

Code: Alles auswählen

WRONG_INFO_FILE_FORMAT
[phpBB Debug] "include(../install/update/index.php): failed to open stream: No such file or directory" in file /www/htdocs/xxxxxxxx/board-root/phpbb/install/module/obtain_data/task/obtain_update_files.php on line 77
[phpBB Debug] "include(../install/update/index.php): failed to open stream: No such file or directory" in file /www/htdocs/xxxxxxxx/board-root/phpbb/install/module/obtain_data/task/obtain_update_files.php on line 77
[phpBB Debug] "include(): Failed opening '../install/update/index.php' for inclusion (include_path='.:/usr/share/php:..')" in file /www/htdocs/xxxxxxxx/board-root/phpbb/install/module/obtain_data/task/obtain_update_files.php on line 77
Ich habe die Dateien alle neu hochgeladen, falls beim ersten Mal was schief gelaufen ist. Der Fehler kommt immer wieder. Das Verzeichnis update unterhalb von install ist nicht vorhanden, folglich auch die dortige index.php nicht.

Das Board liegt beim gleichen Hoster, wie die beiden anderen, nur auf einem anderen Server mit PHP 7.4 und mySQL 5.7.28. Wie bekomme ich dieses zickige Board aktualisiert?
Keep it County,
Markus aka Cowboy
69bruno
Mitglied
Beiträge: 139
Registriert: 05.06.2020 08:21

Re: [3.3] Update auf 3.3.2: Wrong Info File Format

Beitrag von 69bruno »

Das das Updateverzeichnis nicht da war, hatte ich auch. Nachdem ich das Paket auf andere Weise auf den Server gebracht habe (webmin als archiv hochgeladen und auf dem Server entpackt) hatte ich das Problem nicht mehr.
Vorher hatte ich es mit winscp hochgeladen.
Forum: cruiser-lounge.de
PHPBB-Version: 3.3.2
Debian-Linux 10
PHP-Version: 7.3.14
Apache-Sever-Version: 2.4.38
MySQL-Version 10.3.22
Benutzeravatar
Cowboy of Bottrop
Mitglied
Beiträge: 166
Registriert: 01.02.2017 21:11
Wohnort: Bottrop
Kontaktdaten:

Re: [3.3] Update auf 3.3.2: Wrong Info File Format

Beitrag von Cowboy of Bottrop »

Ich hab das einfach im Total Commander per FTP hochgeladen. Bei 2 Boards hat es einwandfrei geklappt, das 3. zickt eben rum.

Aber es ging ja nur noch um das Datenbank-Update auf die neue Version. Was ist denn der Unterschied, außer der angepassten Versionsnummer in der Konfigurationstabelle? Die hab ich einfach via PHP myAdmin geändert und bekomme im Backend die aktuelle Version angezeigt. Scheint alles normal zu funktionieren…
Keep it County,
Markus aka Cowboy
Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 11098
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: [3.3] Update auf 3.3.2: Wrong Info File Format

Beitrag von Crizzo »

Hi,

ne, so macht man das wirklich nicht.

Bitte die Migrations laufen lassen, sonst fliegt dir spätestens beim nächsten Mal der Kram um die Ohren.

Schau halt mal, ob die Datei unbeschädigt an Ort und Stelle ist.
Benutzeravatar
Cowboy of Bottrop
Mitglied
Beiträge: 166
Registriert: 01.02.2017 21:11
Wohnort: Bottrop
Kontaktdaten:

Re: [3.3] Update auf 3.3.2: Wrong Info File Format

Beitrag von Cowboy of Bottrop »

Dass dieser Weg ne unglückliche Krücke ist, weiß ich auch. Aber wie bekomme ich das hin? Ich habe das Komplettpaket mehrmals neu hochgeladen, und weiß da aktuell nicht mehr weiter...

Die Datei ../install/update/index.php ist nicht vorhanden, das Verzeichnis update ja auch nicht. Finde ich im übrigen auch nicht im heruntergeladenen Archiv, obwohl ich genau damit 2 Boards erfolgreich aktualisiert habe...
Keep it County,
Markus aka Cowboy
Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 11098
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: [3.3] Update auf 3.3.2: Wrong Info File Format

Beitrag von Crizzo »

Naja, du nutzt schon das Komplettpaket, oder?

Dann lösche mal die install lock Dateien in store/ Ordner und probiere es nochmal.
Benutzeravatar
Cowboy of Bottrop
Mitglied
Beiträge: 166
Registriert: 01.02.2017 21:11
Wohnort: Bottrop
Kontaktdaten:

Re: [3.3] Update auf 3.3.2: Wrong Info File Format

Beitrag von Cowboy of Bottrop »

Ja, ich nutze das Komplettpaket.

Danke für den Tipp mit den install lock, schaue ich mir heute Abend nach Feierabend an.
Keep it County,
Markus aka Cowboy
Benutzeravatar
Cowboy of Bottrop
Mitglied
Beiträge: 166
Registriert: 01.02.2017 21:11
Wohnort: Bottrop
Kontaktdaten:

Re: [3.3] Update auf 3.3.2: Wrong Info File Format

Beitrag von Cowboy of Bottrop »

Sodele, es gibt im store-Verzeichnis nur eine io.lock, die nach dem Update auch im Verzeichnis bleibt. Das habe ich mit einem der Boards verglichen, bei denen das Update funktioniert hat. Bei dem störrischen Board gab es aber auch eine install.config, die bei den anderen Boards nicht vorhanden war. Nachdem ich diese gelöscht und meine manuelle Änderung der DB rückgängig gemacht habe, ließ sich auch das letzte Board ohne Meckern aktualisieren.

Danke für alle zielführenden Hinweise, ihr seid die Besten! *daumenhoch*
Keep it County,
Markus aka Cowboy
Benutzeravatar
chris1278
Mitglied
Beiträge: 2055
Registriert: 12.11.2007 06:20
Wohnort: Euskirchen
Kontaktdaten:

Re: [3.3] Update auf 3.3.2: Wrong Info File Format

Beitrag von chris1278 »

Also ich lade immer mit FileZilla im binär Modus die Dateien hin und her. Und bisher nie Probleme gehabt.
Benutzeravatar
Cowboy of Bottrop
Mitglied
Beiträge: 166
Registriert: 01.02.2017 21:11
Wohnort: Bottrop
Kontaktdaten:

Re: [3.3] Update auf 3.3.2: Wrong Info File Format

Beitrag von Cowboy of Bottrop »

Mit dem Total Commander hatte ich bisher auch noch keine Probleme, FileZilla steht mir aber auch zur Verfügung.
Keep it County,
Markus aka Cowboy
Antworten

Zurück zu „Support-Forum“