[3.3] Probleme beim Update auf und mit 3.3.2

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Gesperrt
Lehrling
Supporter
Supporter
Beiträge: 3789
Registriert: 15.01.2012 20:00
Kontaktdaten:

[3.3] Probleme beim Update auf und mit 3.3.2

Beitrag von Lehrling »

1. Problem: Nicht unterstützte PHP Version

Wenn Deine PHP-Version kleiner als PHP 7.1.3 ist, kannst Du phpBB 3.3.2 nicht installieren und benutzen.
Wenn Du eine nicht unterstützte PHP Version verwendest, erhält du folgende Fehlermeldung:

Code: Alles auswählen

You are running an unsupported PHP version. Please upgrade to PHP 7.1.3 or higher before trying to install or update to phpBB 3.3
Lösung:
Aktualisiere Deine PHP-Version auf 7.1.3 oder höher. Möglicherweise musst Du Deinen Hoster dazu auffordern oder einfach eine Einstellung im Steuerungsfeld Ihrer Website ändern. Beachte bitte, dass PHP-Versionen manchmal für einzelne Verzeichnisse unterschiedlich eingestellt werden können. Wenn Du diese Fehlermeldung erhältst, wird in diesem Ordner noch eine alte Version ausgeführt. Um dies zu testen, erstelle eine PHP-Datei mit den folgenden Inhalten, um Deine Version anzuzeigen: <?php phpinfo();


2. Problem: Inkompatible Extension / Erweiterung

Wenn Du die folgende Fehlermeldung erhältst, bedeutet dies, dass eine Erweiterung eine veraltete Service Konfiguration verwendet:

Code: Alles auswählen

Exception: The file "/path/to/forum/ext/<author>/<extension name>/config/services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line <number> (near "- @config").
Dieser Definitionsstil war in phpBB 3.2.0 bereits veraltet, aber noch zulässig und wird ab phpBB 3.3.0 nicht mehr unterstützt.

Lösung:
Beziehe eine aktualisierte Version der Extension / Erweiterung vom Autor. Poste NICHT im Support-Forum über dieses Problem.


3. Problem: Das Installationsprogramm hat eine Zeitüberschreitung festgestellt.
Wenn Du diese Meldung nach wenigen Sekunden erhältst, überprüfe das Fehlerprotokoll Deines Servers (nicht das von phpBB), um festzustellen, ob ein unterdrückter PHP-Fehler vorliegt der behoben werden muss.
Wenn dies nach ungefähr 30 Sekunden auftritt, müsstest Du möglicherweise den PHP-Timeout-Wert erhöhen oder die Befehlszeilenmethode zum Aktualisieren verwenden.


4. Problem: Veraltetes Sprachpaket
Auf einigen Seiten wird oben der folgende Fehler angezeigt:

Code: Alles auswählen

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/language/language.php on line <number>: vsprintf(): Too few arguments
Lösung:
Aktualisiere Dein Sprachpaket auf eines, das mit phpBB 3.3.2 kompatibel ist.
Gesperrt

Zurück zu „Support-Forum“