[3.3] Wie installiert man Entwicklerversionen von phpbb?

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Benutzeravatar
HaioPaio
Mitglied
Beiträge: 128
Registriert: 05.11.2017 21:42

[3.3] Wie installiert man Entwicklerversionen von phpbb?

Beitrag von HaioPaio »

Ich habe mich ernsthaft bemüht mit der Suche was zu finden. Leider erfolglos.
Ich würde gerne verstehen wie man eine phpbb Entwicklerversion von Github nutzt um sie für Testzwecke zu installieren.
Gibt es da irgendwo eine Anleitung, oder mag mir jemand Stück für Stück den Weg zeigen?
Englisch wäre kein Problem.
Benutzeravatar
BNa
Valued Contributor
Beiträge: 2750
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.3] Wie installiert man Entwicklerversionen von phpbb?

Beitrag von BNa »

Gib doch mal einen Link zu so einer Entwicklerversion...
Benutzeravatar
HaioPaio
Mitglied
Beiträge: 128
Registriert: 05.11.2017 21:42

Re: [3.3] Wie installiert man Entwicklerversionen von phpbb?

Beitrag von HaioPaio »

Hier im Forum, Downloads, Entwicklung, ganz unten Git Projekte. Einen Github Account habe ich.
Benutzeravatar
BNa
Valued Contributor
Beiträge: 2750
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.3] Wie installiert man Entwicklerversionen von phpbb?

Beitrag von BNa »

Also war ich gezwungen dennoch 3 Klicks zu machen, ok.

Also die Sache ist ganz einfach, github ist garnicht nötig dazu.

Beispiel:
phpBB 4.0.x (tba) - Entwickler Version:
https://github.com/phpbb/phpbb/tree/master
Du gehst auf den grünen Button [ Code ] > Download ZIP
Lädst Dir die zip runter und benutzt nur den Inhalt des Verzeichnisses phpbb-master/phpBB/
um die Entwicklerversion zu installieren > Fertig.

Basis-Bedingungen müssen hier dann natürlich erfüllt werden: SQL-/PHP-Version etc..
Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 11219
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: [3.3] Wie installiert man Entwicklerversionen von phpbb?

Beitrag von Crizzo »

Hi,

da gibt es nicht viel zu machen.

Du gehst hier hin: https://github.com/phpbb/phpbb und clonst das Repository per Git-Client (z. B. Git-Bash) auf dein Server-Verzeichnis:

Code: Alles auswählen

git clone https://github.com/phpbb/phpbb xampp/htdocs/phpbbdev/
Danach gehst du per Kommandoszeile (Ausführen, PowerShell, Git-Bash) in den Ordner "phpbbdev/phpBB":

Code: Alles auswählen

cd xampp/htdocs/phpbbdev/phpBB/
und installierst per Composer die Abhängigkeiten: (setzt voraus, dass die PHP-Installation als Umgebungsvariable eingerichtet worden ist)

Code: Alles auswählen

php ../composer.phar install
Danach wählst du deinen branch im lokalen Git-Repository per:

Code: Alles auswählen

git checkout <branchname>
z. B.:

Code: Alles auswählen

git checkout 3.3.x
Danach kannst du das phpBB ganz normal installieren, surfst also zu "localhost/phpbbdev/phpBB" und rufst die Installation auf.

Bei einem Update des Codes im Repository, musst du den Code nur "abholen":

Code: Alles auswählen

git fetch origin 
git checkout 3.3.x
git merge origin/3.3.x
Alles klar? :)
Benutzeravatar
HaioPaio
Mitglied
Beiträge: 128
Registriert: 05.11.2017 21:42

Re: [3.3] Wie installiert man Entwicklerversionen von phpbb?

Beitrag von HaioPaio »

Crizzo hat geschrieben:
14.02.2021 18:48
Alles klar? :)
Lieber Crizzo
Da hast du sicher "a Spässla gmacht".
Ich verstehe wenig.
Ich habe verstanden dass ich eine Git Anwendung auf dem Rechner installiert haben muss.
Irgendwie werden dann die vielen zusätzlichen Ordner verarbeitet, so dass am Ende eine lauffähige Version von phpbb entsteht.
Diese kann ich dann installieren.

Alles andere sind noch böhmische Dörfer für mich.
Ich arbeite mit einem MacBook und habe MAMP Pro installiert.
Damit habe ich lokal schon phpbb 3.3.3 laufen.

Was muss ich sonst noch installieren? Ich vermute eine lokale Git Anwendung.
Ich suche mal was sich anbietet und werde mich wieder melden wenn ich deinen ersten Schritt ausgeführt habe.
Ok?
Benutzeravatar
BNa
Valued Contributor
Beiträge: 2750
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.3] Wie installiert man Entwicklerversionen von phpbb?

Beitrag von BNa »

Wie gesagt, geht auch so:
viewtopic.php?p=1409536#p1409536

Bei Updates einfach neu runterladen und Daten überschreiben...
Benutzeravatar
HaioPaio
Mitglied
Beiträge: 128
Registriert: 05.11.2017 21:42

Re: [3.3] Wie installiert man Entwicklerversionen von phpbb?

Beitrag von HaioPaio »

Bna
Hast du das schon mal so gemacht? Da sind viele andere Ordner dabei die es in phpbb nicht gibt.
Benutzeravatar
BNa
Valued Contributor
Beiträge: 2750
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.3] Wie installiert man Entwicklerversionen von phpbb?

Beitrag von BNa »

Ja klar, sonst würde ich das ja nicht erzählen.
BNa hat geschrieben:
14.02.2021 18:47
Beispiel:
phpBB 4.0.x (tba) - Entwickler Version:
https://github.com/phpbb/phpbb/tree/master
Du gehst auf den grünen Button [ Code ] > Download ZIP
Lädst Dir die zip runter und benutzt nur den Inhalt des Verzeichnisses phpbb-master/phpBB/
um die Entwicklerversion zu installieren > Fertig.


Basis-Bedingungen müssen hier dann natürlich erfüllt werden: SQL-/PHP-Version etc..
BNa hat geschrieben:
14.02.2021 19:26
Bei Updates einfach neu runterladen und Daten überschreiben...
Benutzeravatar
HaioPaio
Mitglied
Beiträge: 128
Registriert: 05.11.2017 21:42

Re: [3.3] Wie installiert man Entwicklerversionen von phpbb?

Beitrag von HaioPaio »

BNa
Nicht in den falschen Hals bekommen. Danke, klingt überschaubarer. Die volle Variante braucht man möglicherweise nur wenn man im Project mitarbeiten möchte.
Ich werde das gleich mal so machen und berichten.
Vielen Dank.

Parallel dazu werde ich noch an Crizzos Beschreibung arbeiten.
Github Desktop hab ich schon mal installiert.
Da kommen sicher noch Fragen.

EDIT:
BNa hat geschrieben:
14.02.2021 19:59
BNa, bei mir klappt das nicht. Ich habe es mit 3.3.x versucht. Ich habe den Inhalt des phpbb Verzeichnisses in das lokale Verzeichnis über htdocs geladen und /install ausgeführt. Es kommt ein http 500 Fehler.
Wenn das Ganze mit dem offiziellen phpbb 3.3.3 mache, lässt sich install ausführen.

Hab ich was vergessen?
Antworten

Zurück zu „Support-Forum“