[3.1.9] Update und Umzug fehlgeschlagen

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Antworten
borsty
Mitglied
Beiträge: 2
Registriert: 03.06.2021 06:30

[3.1.9] Update und Umzug fehlgeschlagen

Beitrag von borsty »

Moin Zusammen
Habe vor langer Zeit das 4x4travel.org Forum übernommen und kam schon damals an den Anschlag bei nem Umzug zu neuem Hoster. Mahony konnte damals dann helfen. War ein Problem wegen der Datenbank da die Falsche übernommen wurde, respektive plötzlich 2 da waren. Wieso auch immer. Jetzt wurden die Server komplett Neu gemacht und ich kriege die 3.1.9 Version nicht zum laufen. Sehe gar nix und komme nirgends rein ausser auf den Server. Neuinstallation von 3.3 und Übernahme der Datenbank schläglt fehlt. Timeout jedesmal.
Die Server wurden von PHP 5.1.x oder so auf PHP 7.0.x gewechselt. Mitgeteilt wurde mir jetzt das Webseiten mit mindestens PHP 7.0.x nur lauffähig sein sollen. Für welche Version das phpbb 3.1.9 war finde ich in meiner Doofheit nicht raus. Wechseln auf tiefere PHP geht laut Hoster nicht mehr.
Die einzige Fehlermeldung die ab und zu auftaucht ist diese.
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 561: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 569: sizeof(): Parameter must be an array or an object that implements Countable
Das Problem gab es irgendwie schonmal um 2018. Daher wollte ich die 3.3 installieren und die Datenbank übernehmen. Hoffe JEmand kann da helfen.
Sollte doch möglich sein 3.3 Neu zu installieren und das Datenbank Backup in die neuere Version zu holen.
Ich denke zu Wissen das 3.1.9 nicht lauffähig sein ist unter PHP 7.0
Gruss und Danke Uwe
Benutzeravatar
Mahony
Ehemaliges Teammitglied
Beiträge: 12134
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.1.9] Update und Umzug fehlgeschlagen

Beitrag von Mahony »

Hallo
borsty hat geschrieben:
03.06.2021 06:56

Sollte doch möglich sein 3.3 Neu zu installieren und das Datenbank Backup in die neuere Version zu holen.
Nein so funktioniert das nicht. Du kannst nicht einfach ein phpBB3.3 installieren und dann die Datenbank einer älteren phpBB-Version importieren.
Der korrekte Weg wäre, das phpBB3.1.9 upzudaten auf phpBB3.3

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.
borsty
Mitglied
Beiträge: 2
Registriert: 03.06.2021 06:30

Re: [3.1.9] Update und Umzug fehlgeschlagen

Beitrag von borsty »

Hallo Mahony
Mir ging schon das Update auf 3.2.11 in die Hose. Darum wieder zurück gesetzt und so gelassen. Hatten ja schonmal so ein Problem wo nur Du es geschafft hattest. Mir ist auch ein Rätsel wieso ich mit dem blöden Handy ins Forum komme und auch in das ACP und mit keinem meiner PCs weiter als zur Fehlermeldung.
Die Annahme das es nur mit der Datenbank gehen würde war dann die letzte Idee.
Vorallem ist es nicht einfach wenn man unter Zeitdruck wegen der Umstellung es machen sollte.
Naja, kommt Zeit kommt vielleicht Rat. Ansonsten bleibts einfach off. Habe Dir mal ne PN geschrieben.
Gruss und Danke erstmal.
Uwe
Antworten

Zurück zu „Support-Forum“