[BETA][3.2][3.3] Kalender

In diesem Forum können Extension-Autoren ihre Extensions vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
christin
Mitglied
Beiträge: 8
Registriert: 09.02.2020 20:14

Re: [BETA][3.2][3.3] Kalender

Beitrag von christin »

So auf der Neuinstallation funktioniert der Kalender ohne Probleme.
Ich habe den Kalender im Live Forum nochmal komplett deinstalliert (inkl. Arbeitsdateien Löschen), das musste ich zwei mal machen und anschließend habe ich ihn wieder aktiviert und er hat gleich funktioniert.

wernerz
Mitglied
Beiträge: 90
Registriert: 22.10.2014 09:16
Kontaktdaten:

Re: [BETA][3.2][3.3] Kalender

Beitrag von wernerz »

Hi,

da mein Forum unter 7.4.2 läuft und ich auch aus bestimmten Gründen nicht zurück kann, wollte ich mal Fragen wann die fehlerbereinigte Version kommt?
Gruß Werner

Indy1
Mitglied
Beiträge: 1
Registriert: 14.02.2020 13:46

Re: [BETA][3.2][3.3] Kalender

Beitrag von Indy1 »

Hi !

Die Erweiterung funktioniert grundlegend gut - nur ist mir aufgefallen das es zwar Dropdowns für Start und Endzeit gibt, ich diese aber nicht auswählen kann...
Woran könnte das liegen ?

lg Indy

stefan-franz
Mitglied
Beiträge: 253
Registriert: 24.02.2019 13:22

Re: [BETA][3.2][3.3] Kalender

Beitrag von stefan-franz »

Indy1 hat geschrieben:
14.02.2020 13:48
Hi !

Die Erweiterung funktioniert grundlegend gut - nur ist mir aufgefallen das es zwar Dropdowns für Start und Endzeit gibt, ich diese aber nicht auswählen kann...
Woran könnte das liegen ?

lg Indy
Das liegt an der Extension selbst, nach meiner Information. Das ist bei mir unter 3.2.8. auch schon immer so. Ich meine der Entwickler macht das irgendwann noch fertig.
Lg Stefan Franz

christin
Mitglied
Beiträge: 8
Registriert: 09.02.2020 20:14

Re: [BETA][3.2][3.3] Kalender

Beitrag von christin »

Geht doch noch nicht richtig, wenn ich allerdings beim Datum das Jahr weg lasse, können Anmeldungen gelistet werden.
In der DB steht dann als Datum 0000-XX-XX (für X steht der Monat und der Tag)
Ja die Uhrzeit geht bei mir auch nicht.

Ach ja noch was. Wenn das Jahr ausgewählt ist, wird der Eintrag zwar in der DB hinterlegt, allerdings im Kalender nicht angezeigt.

EDIT: So ich kenne nun das Problem, beim Abspeichern fehlt ein Tag. Trage ich also 2020-03-10 ein wird das in der DB als 2020-03-09 gespeichert.
Den Fehler habe ich im Ordner Events/main_listener.php in Zeile 724 gefunden. Obwohl der ts korrekt ist, wird das Datum um einen Tag subtrahiert.
Ich habe das jetzt erst mal so gemacht das ich dort einen Tag hinzufüge, ich weiß nicht die beste Lösung.
Vielleicht ist die Timezone Falsch oder was anderes, kann es mir grade nicht erklären.

EDIT2: So Fehler gefunden, die Timezone wars, dadurch ist die Zeit um eine Stunde zurückgesetzt worden. Also statt 2020-03-11 00:00:00 bekam ich 2020-03-10 23:00:00. Habe die Zeitzone jetzt auf UTC gesetzt.

HJW
Mitglied
Beiträge: 1101
Registriert: 20.04.2007 20:48
Wohnort: 45481 Mülheim an der Ruhr
Kontaktdaten:

Re: [BETA][3.2][3.3] Kalender

Beitrag von HJW »

Hallo Christin,

bei mir steht im /event/main-listener in Zeile 724:

Code: Alles auswählen

				$pd	= $this->request->variable('d', '', true);
Indy1 hat geschrieben:
14.02.2020 13:48
Hi !

Die Erweiterung funktioniert grundlegend gut - nur ist mir aufgefallen das es zwar Dropdowns für Start und Endzeit gibt, ich diese aber nicht auswählen kann...
Woran könnte das liegen ?

lg Indy
viewtopic.php?f=149&t=233145&start=950#p1399504

christin
Mitglied
Beiträge: 8
Registriert: 09.02.2020 20:14

Re: [BETA][3.2][3.3] Kalender

Beitrag von christin »

EDIT2: So Fehler gefunden, die Timezone wars, dadurch ist die Zeit um eine Stunde zurückgesetzt worden. Also statt 2020-03-11 00:00:00 bekam ich 2020-03-10 23:00:00. Habe die Zeitzone jetzt auf UTC gesetzt.
Das Problem ist die Timezone, das Board was Probleme hatte läuft unter UTC+1 auf dem Test Board ist nur UTC und da gabs keine Probleme.
Der Kalender zieht an einer Ungünstigen stelle, eine Stunde vom Datum ab. Dadurch können die Events nicht zugeordnet werden, weil es an diesem Tag keine Events gibt.

HJW
Mitglied
Beiträge: 1101
Registriert: 20.04.2007 20:48
Wohnort: 45481 Mülheim an der Ruhr
Kontaktdaten:

Re: [BETA][3.2][3.3] Kalender

Beitrag von HJW »

christin hat geschrieben:
15.02.2020 08:19
Der Kalender zieht an einer Ungünstigen stelle, eine Stunde vom Datum ab. Dadurch können die Events nicht zugeordnet werden, weil es an diesem Tag keine Events gibt.
Und wo geschieht das? Scheinbar nicht in der von dir angeführten Zeile 724.

christin
Mitglied
Beiträge: 8
Registriert: 09.02.2020 20:14

Re: [BETA][3.2][3.3] Kalender

Beitrag von christin »

Ich habe in dieser Datei "main_listener.php", die Zeite 404-411 auskommentiert und dahinter date_default_timezone_set('UTC') eingefügt.

Der Hoster ist übrigens 1&1 ionos

Vielleicht ist die Server Konfiguration auch einfach fehlerhaft.

Auf eurem Board "calendar.zoo-am-ring.de" ist das Datum auch UTC+1. Mich würde interessieren welches Datum bei Board-Einstellungen steht. Ist es das jetzige oder wurde eine Stunde abgezogen?

HJW
Mitglied
Beiträge: 1101
Registriert: 20.04.2007 20:48
Wohnort: 45481 Mülheim an der Ruhr
Kontaktdaten:

Re: [BETA][3.2][3.3] Kalender

Beitrag von HJW »

Hallo Christin,

wo wird denn in den auskommentierten Zeilen eine Stunde abgezogen?

Der Hoster von zoo-am-ring.de ist der gleiche wie bei dir.
christin hat geschrieben:
16.02.2020 08:39
Mich würde interessieren welches Datum bei Board-Einstellungen steht
Da steht Europa/Berlin.

Hast du vielleicht das gleiche Problem wie hier: viewtopic.php?p=1401619#p1401619

Antworten

Zurück zu „Extensions in Entwicklung“