[DEV] [3.1] [3.2] SEO URLs

In diesem Forum können Extension-Autoren ihre Extensions vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
Stefan2204d
Mitglied
Beiträge: 34
Registriert: 18.04.2017 21:19

Re: [DEV] SEO URLs

Beitragvon Stefan2204d » 18.07.2017 17:06

Das ergibt folgenden Datenbank Fehler.

SQL-Befehl:
DELETE FROM 'DATENBANK'.'phpbb_ext' WHERE 'phpbb_ext'.'ext_name'='tas2580/seourls' LIMIT 1

MySQL meldet: Dokumentation
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''DATENBANK'.'phpbb_ext' WHERE 'phpbb_ext'.'ext_name'='tas2580/seourls' LIMIT 1' at line 1

:o Update: Ich kann diese Befehle direkt im Browser über die Datenbank löschen, habe beide Einträge gelöscht und es geht.
Es bleibt also dabei, das nur das Sperren von Beiträgen mit der Extension nicht geht.
Zuletzt geändert von Stefan2204d am 18.07.2017 17:11, insgesamt 1-mal geändert.

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11015
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [DEV] SEO URLs

Beitragvon Mahony » 18.07.2017 17:09

Hallo
Statt DATENBANK musst du deinen Datenbank-NAMEN eintragen.

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

Stefan2204d
Mitglied
Beiträge: 34
Registriert: 18.04.2017 21:19

Re: [DEV] SEO URLs

Beitragvon Stefan2204d » 18.07.2017 17:11

Mahony hat geschrieben:Hallo
Statt DATENBANK musst du deinen Datenbank-NAMEN eintragen.

Grüße: Mahony


Das habe ich gemacht, ging auch nicht. Aber ich konnte diese Befehle direkt im Browser löschen, im Datenbank Programm, jetzt sind sie verschwunden. Bleibt also dabei, das man nur Beiträge nicht sperren kann mit der Extensions.

Stefan2204d
Mitglied
Beiträge: 34
Registriert: 18.04.2017 21:19

[3.2] Extension lassen sich nicht mehr installieren

Beitragvon Stefan2204d » 22.07.2017 17:10

Hallo, folgendes Problem. Ich hatte den Ordner "tas2580" inkl. Extensions erst vom Webspace gelöscht. Danach hatte ich ja eine Fehleranzeige. Habe in der Datenbank die Tas2580-Ext gelöscht, also die Einträge dazu. Immer wenn ich nun den Ordner "Tas2580" hochlade, wird er nicht mehr angezeigt, die Extensions lassen sich nicht mehr installieren und erscheinen dort nicht mehr. Gibt es irgendwo noch Einträge die man vorher löschen muss? Cookies geleert und Arbeitsdaten habe ich natürlich.

Benutzeravatar
vfrblue
Junior Supporter
Beiträge: 800
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: [3.2] Extension lassen sich nicht mehr installieren

Beitragvon vfrblue » 22.07.2017 18:17

Stefan2204d hat geschrieben:Hallo, folgendes Problem. Ich hatte den Ordner "tas2580" inkl. Extensions erst vom Webspace gelöscht. Danach hatte ich ja eine Fehleranzeige. Habe in der Datenbank die Tas2580-Ext gelöscht, also die Einträge dazu. Immer wenn ich nun den Ordner "Tas2580" hochlade, wird er nicht mehr angezeigt, die Extensions lassen sich nicht mehr installieren und erscheinen dort nicht mehr. Gibt es irgendwo noch Einträge die man vorher löschen muss? Cookies geleert und Arbeitsdaten habe ich natürlich.


Ḿöchtest du weiterhin Support haben, dann setze bitte das Copyright wieder ein: https://www.phpbb.de/kb/copyright
Gruß Hermann

Forum VFR-OC
User: phpbbtest PW: vfroc

Stefan2204d
Mitglied
Beiträge: 34
Registriert: 18.04.2017 21:19

Re: [3.2] Extension lassen sich nicht mehr installieren

Beitragvon Stefan2204d » 22.07.2017 21:49

vfrblue hat geschrieben:
Stefan2204d hat geschrieben:Hallo, folgendes Problem. Ich hatte den Ordner "tas2580" inkl. Extensions erst vom Webspace gelöscht. Danach hatte ich ja eine Fehleranzeige. Habe in der Datenbank die Tas2580-Ext gelöscht, also die Einträge dazu. Immer wenn ich nun den Ordner "Tas2580" hochlade, wird er nicht mehr angezeigt, die Extensions lassen sich nicht mehr installieren und erscheinen dort nicht mehr. Gibt es irgendwo noch Einträge die man vorher löschen muss? Cookies geleert und Arbeitsdaten habe ich natürlich.


Ḿöchtest du weiterhin Support haben, dann setze bitte das Copyright wieder ein: https://www.phpbb.de/kb/copyright


Danke für deine Hilfe zu meinem Beitrag vom 16.07.2017!

Lizardx
Mitglied
Beiträge: 171
Registriert: 20.05.2006 18:35

Re: [DEV] SEO URLs

Beitragvon Lizardx » 24.07.2017 15:32

ich habe noch immer ein großes Problem mit zu vielen 404 Seiten. Aktuell habe ich über 40.000 404 Seiten!
Dies betrifft Themen die mehr als eine Seite haben, also aus mehr als 15 Beiträgen pro Thread bestehen. Früher lauteten die Urls so: post9144.html
Nun lauten die Urls aber so: topic1185-s30.html

Ist es möglich diese Urls mit Mod Rewrite umzuschreiben?

Benutzeravatar
tas2580
Ehemaliger
Beiträge: 2803
Registriert: 01.07.2004 05:42
Wohnort: /home/tas2580
Kontaktdaten:

Re: [DEV] SEO URLs

Beitragvon tas2580 » 24.07.2017 18:29

Lass die alten Rewrite Regeln drin und ändere [L] in [L,R=301]

Gruß Tobi
Heute ist ein guter Tag um dein Forum zu testen.
Ehemaliger Benutzername: [BTK] Tobi

_Jo_
Mitglied
Beiträge: 37
Registriert: 29.10.2017 21:05

Re: [DEV] SEO URLs

Beitragvon _Jo_ » 08.11.2017 00:17

Hallo Tobi,

habe unter 3.2.1 die Ext installiert und die Ergänzungen im der .htacces gemacht. (allerdings hab eich an 2 stellen "RewriteEngine on" enthalten)
und das Portal add von Board3 Portal.

Gibt es in dieser Kombi evtl. Besonderheiten? Denn die URl werden nach wie vor

Code: Alles auswählen

/portal?sid=dcc277671cad5e8fc6fe9955482a355f oder /viewtopic.php?f=14&t=3&sid=dcc277671cad5e8fc6fe9955482a355f
angezeigt

Vielen Dank

heute bekomme ich wenn ich direkt über den Forum INdex zugreifen will folgende Meldung:

Code: Alles auswählen

No route found for "GET /ich-bin-der-neue-f5/ich-bin-der-admin-jo-t2.html" (from "http://seitexx.de/index.php?sid=c92d4a265b67b6ffeaf91448b5f8313b")

wäre schön wenn jemand Hilfe kennt
Danke

juliokr
Mitglied
Beiträge: 478
Registriert: 06.02.2015 12:54
Wohnort: Paris
Kontaktdaten:

Re: [DEV] [3.1] [3.2] SEO URLs

Beitragvon juliokr » 12.12.2017 11:19

poste doch mal deinen .htaccess

"RewriteEngine on"
brauchst Du nur 1 mal und zwar oben


Zurück zu „Extensions in Entwicklung“