[ABD] Benutzer Karte

In diesem Forum können Extension-Autoren ihre Extensions vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 5721
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: [DEV] Benutzer Karte

Beitragvon Kirk » 10.12.2015 16:36

Der Web Developer im FF gibt mir folgende Fehlermeldung aus:
Fehler: TypeError: returndata.forEach is not a function

zu finden in der overall_footer_after.html ab Zeile: 18

chrsla
Mitglied
Beiträge: 501
Registriert: 13.08.2007 17:48

Re: [DEV] Benutzer Karte

Beitragvon chrsla » 10.12.2015 17:46

Also mir gefällt die Ext ganz gut.
Ich finde es gut, dass man eigene Marker noch definieren kann und diese auch sogar bestimmten Usergruppen zuordnen kann.

Allerdings habe ich ein Berechtigungsproblem.
Als Admin hat man in den Profileinstellungen zwei neu Felder für den Längen- und Breitengrad.
Logge ich mich aber als "normaler" User ein, fehlen diese Felder.
Die Gruppenrechte sind aber richtig konfiguriert.
Dennoch fehlen die Felder im Profil.

Klicke ich aber auf die Karte und füge die Markierung per Rechtsklick hinzu, klappt das ohne Probleme und wird auch gespeichert.

Das Problem mit den Markern habe ich nicht. Zumindestens in der großen Karte nicht. Es gibt ja aber die Möglichkeit direkt im Profil sich die Karte anzuschauen. Da fehlen die Marker.

Benutzeravatar
tas2580
Ehemaliger
Beiträge: 2971
Registriert: 01.07.2004 05:42
Wohnort: /home/tas2580
Kontaktdaten:

Re: [DEV] Benutzer Karte

Beitragvon tas2580 » 11.12.2015 02:17

Update auf 0.1.2:

  • Marker wird im Profil jetzt wieder angezeigt
  • Fehlermeldung bei AJAX Fehler
  • Benutzer haben die Möglichkeit ihren Marker auf der Karte auszublenden
  • Gruppen können in der Legende ausgeblendet werden

@BertB und @Kirk
Versucht doch nach dem Update nochmal ob die Marker immer noch nicht angezeigt werden oder ob ihr eine Fehlermeldung bekommt.

Gruß Tobi
Heute ist ein guter Tag um dein Forum zu testen.
Ehemaliger Benutzername: [BTK] Tobi

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 5721
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: [DEV] Benutzer Karte

Beitragvon Kirk » 11.12.2015 09:24

Der Marker wird auf der Karte im Profil angezeigt.
Ruft man die Benutzer Karte auf, so bekomme ich folgende AJAX Fehler Meldung:
[phpBB Debug] PHP Notice: in file [ROOT]/ext/tas2580/usermap/controller/main.php on line 134: Undefined index: SELECT
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/json_response.php on line 29: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
[{"marker":"admin.png","lon":"11.5779","lat":"49.9426","title":"Kirk<\/a>","distance":"0 Kilometer"}]

In viewtopic bekommt man folgende Debug Meldung:
[phpBB Debug] PHP Notice: in file [ROOT]/ext/tas2580/usermap/event/listener.php on line 210: Undefined index: user_id
[phpBB Debug] PHP Notice: in file [ROOT]/ext/tas2580/usermap/event/listener.php on line 216: Undefined index: distance

BertB

Re: [DEV] Benutzer Karte

Beitragvon BertB » 11.12.2015 10:13

Hallo,

ich werkel mich gerade durch, bekomme aber bereits bei Eingabe der Koordinaten im ACP die Fehlermeldung: ERROR_GET_KOORDINATES

Die Map im Profil wird nicht angezeigt - gestern war es aber dort korrekt.

Information: Klick mit der rechten Maustaste auf die Karte um dich einzutragen!

Funzt auch nicht.

Nachtrag:
Map wird nun im Profil angezeigt, mehr aber auch nicht. Sobald ich die Koordinaten eingebe, erscheint obrige Fehlermeldung. Gleich so wie im ACP.

Gruß

pierredu
Mitglied
Beiträge: 9
Registriert: 11.12.2015 17:41

Re: [DEV] Benutzer Karte

Beitragvon pierredu » 11.12.2015 17:51

Hallo,

Ich bin dabei, die Karte zu testen. Die Extension wird im ACP installiert und parametriert. Alles läuft bestens.
Das einzige Problem ist, daß die Karte in der Index-Leiste nicht erscheint. Wenn ich auslogge, Wunder, ist die Karte in der Leiste wieder da.

Ich sehe nicht ein, wie so was passieren kann. Ich habe versucht, das Forum in Deutsch oder English. Kein Unterschied.

Version des Forums: 3.1.6
Ich habe alle anderen Erweiterungen ausgeschaltet. Die Karte ist somit die einzige Erweiterung.

Hat jemand (Tobias?) eine Idee?
DIV

BertB

Re: [DEV] Benutzer Karte

Beitragvon BertB » 11.12.2015 18:05

Hallo,

schau doch mal im ACP unter Berechtigungen - Gruppenrechte, ob dort alles korrekt freigegeben wurde. Das würde mir jetzt spontan einfallen.

Gruß
Bert

pierredu
Mitglied
Beiträge: 9
Registriert: 11.12.2015 17:41

Re: [DEV] Benutzer Karte

Beitragvon pierredu » 11.12.2015 21:04

Danke für deine Nachricht.
Ich sehe jedoch nicht, was ich dabei korrigieren sollte.
Dieses Forum wird von mir als Testforum benutzt. Das heißt, daß es ziemlich klar ist.

Änderung: ich habe die frz. Texte geändert.

Benutzeravatar
tas2580
Ehemaliger
Beiträge: 2971
Registriert: 01.07.2004 05:42
Wohnort: /home/tas2580
Kontaktdaten:

Re: [DEV] Benutzer Karte

Beitragvon tas2580 » 11.12.2015 21:23

Schau doch mal bei den Rechten ob das Recht "Kann die Benutzer Karte anschauen" für angemeldete Benutzer vergeben ist. Denn über das Recht wird geregelt ob man die Karte aufrufen darf oder nicht.

Ich habe nochmal ein paar Dinge überarbeitet, so das es jetzt zu keinen Fehlermeldungen mehr kommen dürfte. Die Eingabe der Koordinaten wird jetzt auch nochmal besser geprüft.

Gruß Tobi
Heute ist ein guter Tag um dein Forum zu testen.
Ehemaliger Benutzername: [BTK] Tobi

pierredu
Mitglied
Beiträge: 9
Registriert: 11.12.2015 17:41

Re: [DEV] Benutzer Karte

Beitragvon pierredu » 12.12.2015 09:13

Alle Rechte mit der Karte sind vergeben.
Ich bin ratlos.


Zurück zu „Extensions in Entwicklung“