[ABD] Benutzer Karte

In diesem Forum können Extension-Autoren ihre Extensions vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
Benutzeravatar
tas2580
Ehemaliger
Beiträge: 2803
Registriert: 01.07.2004 05:42
Wohnort: /home/tas2580
Kontaktdaten:

Re: [DEV] Benutzer Karte

Beitragvon tas2580 » 21.02.2017 13:27

Yetikisdorf hat geschrieben:Mir fehlt die Möglichkeit Gäste von der Karte auszusperren, oder übersehe ich das nur?

Schau mal in die Benutzerechte, dort kannst du Gästen das Recht um die Karte anzuzeigen wegnehmen.

Gruß Tobi
Heute ist ein guter Tag um dein Forum zu testen.
Ehemaliger Benutzername: [BTK] Tobi

Benutzeravatar
Yetikisdorf
Mitglied
Beiträge: 60
Registriert: 02.07.2007 22:41

Re: [DEV] Benutzer Karte

Beitragvon Yetikisdorf » 02.03.2017 22:52

Danke, funktioniert klasse!

Daniel26
Mitglied
Beiträge: 2
Registriert: 27.01.2017 16:42

Re: [DEV] Benutzer Karte

Beitragvon Daniel26 » 14.03.2017 15:52

Danke, habs hinbekommen.
Nur wird mir bei eigegtragenen Usern kein marker dargestellt.

Fehlermeldung Im Server-Log dazu:
Cannot serve directory /srv/www/htdocs/phpbb/ext/tas2580/usermap/marker/groups/: No matching DirectoryIndex (index.html,index.html.var,index.php4,index.php5,index.php) found, and server-generated directory index forbidden by Options directive
Warum will der nen Directory-Index?

Gruß

Daniel

Benutzeravatar
AndreasFischer
Mitglied
Beiträge: 12
Registriert: 18.02.2017 14:35

(3.2.0.) Extension gelöscht- Fehlermedlung

Beitragvon AndreasFischer » 15.03.2017 10:40

Ich brauche Hilfe

Ich hatte die Extension Usermap installiert
https://tas2580.net/downloads/phpbb-usermap/
War auch alles ok aber es liess sich auf einmal die Markierung, wenn einmal gesetzt, nicht mehr ändern.
Da das Forum eh noch nicht veröffentlicht ist, es ausser einem Admin, einem Mod und einem Testuser noch keine User gibt, .... da dachte ich mir, "lösch das teil und installiere es neu"
Extension ersteinmal deaktiviert und es kam eine Fehlermeldung in irgendeiner Datei und Zeile xy sei ein Fehler
Extension wieder aktiviert, noch eine Fehlermeldung
Extension wieder deaktiviert und die Arbeitsdateien gelöscht, wieder eine Fehlermeldung
Extension per ftp vom Server genommen und neu installiert ... Fehlermeldung

zru Zeit sehe ich im APC unter "Anpassen" bei den deaktivierten Erweiterungen folgendes
Die Erweiterung „tas2580/usermap“ ist ungültig.
Die angegebene Datei konnte nicht gefunden werden: ./../ext/tas2580/usermap/composer.json



Nachtrag;
wenn ich versuche die Arbeitsdateien jetzt zu löschen bekomme ich folgende Fehlermeldung
Fatal error: Uncaught exception 'phpbb\module\exception\module_exception' with message 'CANNOT_REMOVE_MODULE' in /www/htdocs/w00819dd/musik-instrument-spielen/forum/phpbb/module/module_manager.php:448 Stack trace: #0 /www/htdocs/w00819dd/musik-instrument-spielen/forum/phpbb/db/migration/tool/module.php(371): phpbb\module\module_manager->delete_module(223, 'acp') #1 [internal function]: phpbb\db\migration\tool\module->remove('acp', 'ACP_CAT_DOT_MOD...', 'ACP_USERMAP_TIT...') #2 /www/htdocs/w00819dd/musik-instrument-spielen/forum/phpbb/db/migration/tool/module.php(405): call_user_func_array(Array, Array) #3 [internal function]: phpbb\db\migration\tool\module->reverse('add', 'acp', 'ACP_CAT_DOT_MOD...', 'ACP_USERMAP_TIT...') #4 /www/htdocs/w00819dd/musik-instrument-spielen/forum/phpbb/db/migrator.php(711): call_user_func_array(Array, Array) #5 /www/htdocs/w00819dd/musik-instrument-spielen/forum/phpbb/db/migrator.php(658): phpbb\db\migrator->run_step(Array, NULL, false) #6 /www/htdocs/w00819dd/musik-instrument-spielen/forum/p in /www/htdocs/w00819dd/musik-instrument-spielen/forum/phpbb/module/module_manager.php on line 448


versuche ich die Extension wieder zu aktivieren, erhalte ich folgende fehlermeldung:

Allgemeiner Fehler
SQL ERROR [ mysqli ]

Table 'd0257b7a.phpbb_busermap_things' doesn't exist [1146]

SQL

SHOW COLUMNS FROM phpbb_busermap_things

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 999
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 885
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 902
CALL: phpbb\db\tools\tools->sql_list_columns()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 541
CALL: phpbb\db\tools\tools->sql_column_exists()

FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\db\tools\tools->perform_schema_changes()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 711
CALL: call_user_func_array()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 658
CALL: phpbb\db\migrator->run_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 400
CALL: phpbb\db\migrator->process_data_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 288
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 241
CALL: phpbb\db\migrator->update_do()

FILE: [ROOT]/phpbb/extension/base.php
LINE: 78
CALL: phpbb\db\migrator->update()

FILE: [ROOT]/phpbb/extension/manager.php
LINE: 185
CALL: phpbb\extension\base->enable_step()

FILE: [ROOT]/includes/acp/acp_extensions.php
LINE: 197
CALL: phpbb\extension\manager->enable_step()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_extensions->main()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()

Benutzeravatar
tas2580
Ehemaliger
Beiträge: 2803
Registriert: 01.07.2004 05:42
Wohnort: /home/tas2580
Kontaktdaten:

Re: [DEV] Benutzer Karte

Beitragvon tas2580 » 17.03.2017 17:24

Daniel26 hat geschrieben:Nur wird mir bei eigegtragenen Usern kein marker dargestellt.

Hast du der Hauptgruppe der Benutzer einen Marker zugeteilt?

@AndreasFischer:
Hast du beim wieder hoch laden der Extension die selbe Version die du auch schon vorher installiert hattest benutzt?

Gruß Tobi
Heute ist ein guter Tag um dein Forum zu testen.
Ehemaliger Benutzername: [BTK] Tobi

Benutzeravatar
Tastenplayer
Mitglied
Beiträge: 621
Registriert: 02.07.2010 19:35
Wohnort: Zuchwil/SO - Schweiz
Kontaktdaten:

Re: [DEV] Benutzer Karte

Beitragvon Tastenplayer » 17.03.2017 18:13

Ich habe Probleme mit dem Icon der Usermap.
Im TB lokal auf dem PC werden in phpbb3.2.0 zwei Globusse angezeigt - da anscheinend bereits ein icon fa-globe in phpbb 3.2.0 integriert ist.

Klar kann ich alle Icons in der extension löschen - jedoch es bleibt ein zu grosser Abstand zur vorherigen extension.
Ich habe die Usermap deaktiviert - cache geleert - die icons in der ext. gelöscht - cache geleert - Userkarte aktiviert - cache geleert - keine Veränderung zu grosser Abstand ist geblieben.

Klar im TB kann ich auch noch die Arbeitsdaten löschen - jedoch im Liveboard geht das nicht gut. Müssten sich die Mitglieder schon wieder neu eintragen.
Startseite: https://www.my-tastenworld.ch
Mein Portal: https://www.portal.my-tastenworld.ch/Mein Forum: https://www.forum.my-tastenworld.ch/

Be the best version of yourself rather than a bad copy of someone else!

Benutzeravatar
tas2580
Ehemaliger
Beiträge: 2803
Registriert: 01.07.2004 05:42
Wohnort: /home/tas2580
Kontaktdaten:

Re: [DEV] Benutzer Karte

Beitragvon tas2580 » 17.03.2017 18:16

Tastenplayer hat geschrieben:Ich habe Probleme mit dem Icon der Usermap.

Siehe: https://phpbb.tas2580.net/user-map-f7/b ... tml#p10257

Der "Bug" ist bekannt und wird mit der nächsten Version behoben.

Gruß Tobi
Heute ist ein guter Tag um dein Forum zu testen.
Ehemaliger Benutzername: [BTK] Tobi

Benutzeravatar
Tastenplayer
Mitglied
Beiträge: 621
Registriert: 02.07.2010 19:35
Wohnort: Zuchwil/SO - Schweiz
Kontaktdaten:

Re: [DEV] Benutzer Karte

Beitragvon Tastenplayer » 17.03.2017 18:19

Ach so - kein Problem
Ich bin am Style erstellen für 3.2.0 und habe extreme Platzprobleme(rechts kommt nur noch 0 0) - deshalb wollte ich dieses Problem beheben um zu schauen, ob es dann genug Platz hat.

Bei einigen extensions wäre es gut, man hätte mehr platzierungs Möglichkeiten :wink:
Startseite: https://www.my-tastenworld.ch
Mein Portal: https://www.portal.my-tastenworld.ch/Mein Forum: https://www.forum.my-tastenworld.ch/

Be the best version of yourself rather than a bad copy of someone else!

opossum
Mitglied
Beiträge: 2
Registriert: 26.03.2017 00:30

Re: [DEV] Benutzer Karte

Beitragvon opossum » 26.03.2017 00:55

Hallo,

ich hatte auch diesen Fehler mit dem Deaktivieren/Löschen der Arbeitsdaten etc. Habe nun ein Backup der Datenbank gemacht, dann in diesem Backup nach "tas2580" und "usermap" gesucht. Dann alle Stellen in der Datenbank bereinigt, damit konnte ich den Fehler beseitigen. Nun traue ich mich jedoch nicht, die Extension wieder zu installieren. Daher die Frage: Gibt es schon eine ungefähre Vorstellung, wann das Teil zu 3.2.0 kompatibel ist. Würde so lange lieber auf diese Extension verzichten. Aber meine User möchten die gern wieder haben.

Vielen dank.

Viele Grüße
opossum

Superstar
Gesperrt
Beiträge: 19
Registriert: 14.03.2017 13:17

Re: [DEV] Benutzer Karte

Beitragvon Superstar » 26.03.2017 03:02

Hallo
Ich verstehe euch nicht ganz
Es steht doch eindeutig die Erweiterung ist in Entwicklung
Wieso downloaded ihr wahllos die Erweiterung und postet dann nur Probleme damit
Als erstens ist es doch konfortabler ein Backup der DB und Daten zu machen
Wenn dann etwas schief geht könnt ihr doch ohneweiteres wieder Wiederherstellen des funktionierendem Forums
Das mit den Problemen ist so gemeint das welche so schlau sind die Erweiterungen direkt ins ori Forum zu installieren
Sind die unnötigen Postes wirklich sinnvoll ?? :oops:

Will mal so sagen habe die Benutzerkarte installiert und no Probleme damit und das beste ist dabei funktioniert zu 100% bei phpbb 3.2


Deinstallation ebenfalls ohne Fehler :o


Zurück zu „Extensions in Entwicklung“