[ABD] Benutzer Karte

In diesem Forum können Extension-Autoren ihre Extensions vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
BertB

Re: [DEV] Benutzer Karte

Beitragvon BertB » 12.12.2015 10:18

Hallo Tobi,

neue Version verwendet - leider wird kein Fähnchen angezeigt.
Bekomme auch immer noch: Fehler - ERROR_GET_COORDINATES - beim Eintrag der Koordinaten.

Gruß
Bert

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 5793
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: [DEV] Benutzer Karte

Beitragvon Kirk » 12.12.2015 11:35

Bei mir werden die Marker jetzt korrekt angezeigt.
Wenn in einem Thema ein Beitrag eines gelöschten User vorhanden ist, bekommt man folgende Debug Meldung:
[phpBB Debug] PHP Notice: in file [ROOT]/ext/tas2580/usermap/event/listener.php on line 216: Undefined index: distance


@BertB,
Hast du vorher die alte Version komplett entfernt?

BertB

Re: [DEV] Benutzer Karte

Beitragvon BertB » 12.12.2015 12:36

Hallo Udo,

ich habe die Ext. entfernt - bis auf die Arbeitsdateien.
Was ich aber auch festgestellt habe - lädt man diese über den automatischen uploader im ACP hoch, dann gibt es sofort eine Fehlermeldung und die Extension wird nicht korrekt installiert. Dies dient mir nur als Kontrolle.
Via ftp kein Thema.
Ferner wird mir obwohl ich eine neue Version von Tobi runter geladen habe im ACP nur 0.1.2 angezeigt. =>Version: 0.1.2
Die Fähnchen fehlen nach wie vor.

Update:
Extension deaktiviert und gelöscht
Arbeitsdaten gelöscht
von Tobi die neue Version 0.1.3 herunter geladen
Browsercache gelöscht
Cache im ACP gelöscht
Ext. neu hochgeladen und aktiviert
Sie wird mir als 0.1.2 angezeigt
Meine Koordinaten eingetragen - Google Maps Api Key eingetragen
Im ACP "Meine Koordinaten eintragen" angeklickt => Fehler ERROR_GET_COORDINATES
Im UCP "Meine Koordinaten eintragen" angeklickt => Fehler ERROR_GET_COORDINATES

Update 2:
Beim erneuern der Koordinaten im ACP unter Benutzerverwaltung folgender Übersetzungsfehler: ACP_USERMAP_HIDE: ACP_USERMAP_HIDE_DESCRIPTION




Gruß
Bert

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 5793
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: [DEV] Benutzer Karte

Beitragvon Kirk » 12.12.2015 14:53

Mit Google Maps habe ich es noch nicht getestet, funktioniert es bei dir mit der Open Streat Maps?

BertB

Re: [DEV] Benutzer Karte

Beitragvon BertB » 12.12.2015 14:57

Hallo Udo,

yepp - jedenfalls teilweise. Mir fehlt auch dort unter der Karte die Legende. War vorher dort - nun bekomme ich sie nicht mehr rein.
In Profil wird sie mit Markierung angezeigt.
Ist doch schon mal was.
Nun funktioniert auch endlich der Rechts-Klick. Ist bei Google Maps nicht der Fall gewesen.


Gruß
Bert

chrsla
Mitglied
Beiträge: 501
Registriert: 13.08.2007 17:48

Re: [DEV] Benutzer Karte

Beitragvon chrsla » 12.12.2015 18:36

Also bei mir funktioniert erstmal alles soweit. Auch das Thema mit den Berechtigungen passt jetzt bei mir.

Was mir persönlich noch gefallen würde ist, wenn neben dem Nickname noch der Rang angezeigt werden würde.
Wenn man auf der Karte auf einen Marker klickt, wird ja in einer Sprechblase ja der Name des Users und die Entfernung angezeigt. Cool wäre es jetzt noch, wenn neben dem Namen dann in Klammern sein Benutzerrang, bzw. der Gruppenrang angezeigt wird.

pierredu
Mitglied
Beiträge: 9
Registriert: 11.12.2015 17:41

Re: [DEV] Benutzer Karte

Beitragvon pierredu » 13.12.2015 11:50

Hallo,

Ich habe gefunden. Es gab 'Nie' für die Karteneinträge bei verschiedenen Benutzergruppen.
Nun werde ich richtig testen können.

BertB

Re: [DEV] Benutzer Karte

Beitragvon BertB » 13.12.2015 12:31

Hallo,

chrsla hat geschrieben:Was mir persönlich noch gefallen würde ist, wenn neben dem Nickname noch der Rang angezeigt werden würde.


Das meinte ich ja mit der fehlenden Legende unter der Karte. Dort waren die "Fähnchen-Farben" mit Rang aufgelistet. Nun aber fehlen sie bei mir. Vllt, stellt ihr ja mal einen Link zu euren Karten - sofern sie im Web liegen - hier ein, damit man Vergleiche hat, was nun wo anders dargestellt wird.
Meine Karte.

Gruß
Bert

chrsla
Mitglied
Beiträge: 501
Registriert: 13.08.2007 17:48

Re: [DEV] Benutzer Karte

Beitragvon chrsla » 13.12.2015 13:58

Eine Gruppe und ein Rang sind ja zwei unterschiedliche Dinge. Die Legende zeigt nur die Gruppen an und das sollte auch so bleiben. Aber es gibt ja noch pro Benutzer die Möglichkeit Ränge zu definieren. Das fände ich noch cool, wenn es neben dem "Namen" in Klammern stehen würde.

Zu deinem Problem BertB.

Wie sind denn die Gruppen bei dir definiert.
Ich denke hier ist nämlich noch ein Fehler in der Beschreibung.

In der Legende verbergen:
Wenn gesetzt wird der Marker der Gruppe in der Legende ausgeblendet.


Eigentlich geht man ja davon aus, dass wenn der Haken gesetzt ist, die Gruppe nicht angezeigt wird in der Legende.
Es ist aber genau andersrum. Wenn der Haken NICHT gesetzt ist, wird die Gruppe bei mir nicht angezeigt. Ist der Haken gesetzt, wird die Gruppe angezeigt.
Vielleicht ist das dein Problem.

BertB

Re: [DEV] Benutzer Karte

Beitragvon BertB » 13.12.2015 15:53

Hallo chrsla,

da muß ich dir voll und ganz Recht geben, Gruppe-Rang - mal wieder nicht richtig gelesen - sorry. :oops: Asche auf mein Haupt. :lol:

Es ist tatsächlich im ACP die verkehrte Beschriftung der Gruppenanzeige. Sollte man wohl mal in der Sprachdatei ändern - auch in den kommenden Versionen.
Habe gerade nochmals umgestellt auf Google Maps - keine Fähnchen in der Karte zu finden.

Gruß
Bert


Zurück zu „Extensions in Entwicklung“