Seite 1 von 1

[3.2] Lightbox Highslide Einbindung

Verfasst: 19.01.2017 19:07
von Digidani
Ich nutze derzeit neben meinem Forum noch eine Galeriewebseite. Dort stellen die Forenmitglieder ihre Bilder rein und dann wird automatisch ein Link unter dem Bild erzeugt, der kopiert und ins Forum eingefügt werden kann. Dieser Link erstellt im Forum ein Thumbnail, darunter den Link direkt in die Galerie als Bildtitel aus der Galerie. So schaut dieser erzeugte Link aus:

Code: Alles auswählen

[light=http://www.GALERIEWEBSEITE.DE/4images/data/media/45/foto.jpg]http://www.GALERIEWEBSEITE.DE/4images/data/thumbnails/45/foto.jpg[/light][size=85][break][URL=http://www.GALERIEWEBSEITE.DE/4images/details.php?image_id=7553] >>> BILDTITEL[/URL][/break][/size]


Im Forum selbst gibt es einen BBCode "light", der derzeit wie folgt konfiguriert ist:

Code: Alles auswählen

[light={URL1}]{URL2}[/light]

Code: Alles auswählen

<div class="highslide-gallery" style="display:inline;">
       <a href="{URL1}" class="highslide" onclick="return hs.expand(this)"><img src="{URL2}" alt="" title="Klicken zum Vergr&ouml;&szlig;ern" style="max-width:600px;" /></a>
    </div>


Das alles läuft derzeit mit einem älteren Highslide-Plugin von hier: http://www.phpbbguru.net/

Nach dem Update auf die 3.2 habe ich nun den Effekt, dass die Lightbox erst öffnet, wenn mehr als ein Bild verlinkt ist. Das ist natürlich nicht so dolle. Andere Lightboxen wiederrum sprechen "nur" auf IMG-Links an.

Gibt es eine Lösung, um z.B. eine der sonstigen Lightbox-Extensions so zu modifizieren, dass die auch für den "light"-BBCode funktioniert?