Seite 1 von 3

Probleme beim Gallery Mod seit phpBB 3.2.0 und PHP7

Verfasst: 06.02.2017 19:21
von Ramona_FP
Hallo zusammen,

folgende Mods sind installiert und aktiv:

Advanced BBCode Box 3.1.3
Collapsible Forum Categories 1.0.1
External Links Open in New Window 1.0.5
Nv who was here 1.2.2
phpBB Gallery 1.2.0
phpBB Gallery Add-on: ACP Cleanup 1.2.0
phpBB Gallery Add-on: ACP Import 1.2.0
phpBB Gallery Add-on: Exif 1.2.0
Profile on Leftside 1.0.2
smilies scroll box 1.0.3
VigLink 1.0.0

Seit dem Update auf phpBB 3.2.0 und gleichzeitiger Umstellung auf PHP7 tauchen (unter anderem) im Gallery Mod folgende Probleme auf:

beim Bildupload bzw. beim Absenden folgende Meldung:

Code: Alles auswählen

Fatal error: Uncaught Error: Call to a member function load_users() on null in /www/htdocs/xxx/xxx/forum/ext/phpbbgallery/core/notification/events/phpbbgallery_new_image.php:87 Stack trace: #0 /www/htdocs/xxx/xxx/forum/phpbb/notification/manager.php(273): phpbbgallery\core\notification\events\phpbbgallery_new_image->find_users_for_notification(Array, Array) #1 /www/htdocs/xxx/xxx/forum/ext/phpbbgallery/core/notification/helper.php(80): phpbb\notification\manager->add_notifications('notification.ty...', Array) #2 /www/htdocs/xxx/xxx/forum/ext/phpbbgallery/core/notification/helper.php(262): phpbbgallery\core\notification\helper->notify('new_image', Array) #3 /www/htdocs/xxx/xxx/forum/ext/phpbbgallery/core/controller/upload.php(307): phpbbgallery\core\notification\helper->new_image(Array) #4 [internal function]: phpbbgallery\core\controller\upload->main('3') #5 /www/htdocs/xxx/xxx/forum/ve in /www/htdocs/xxx/xxx/forum/ext/phpbbgallery/core/notification/events/phpbbgallery_new_image.php on line 87


Das Bild wird allerdings hochgeladen.

Ein Darstellungsfehler, der mir auch in anderen Ext begegnet ist (z.B. Recent Topics):

[ externes Bild ]

Frage 1: Kann mir da jemand evtl. weiterhelfen? :-)
Frage 2: Gibt es evtl. irgendwo schon eine Liste, welche Ext phpBB 3.2.0 und PHP7 fähig sind?

Re: Probleme beim Gallery Mod seit phpBB 3.2.0 und PHP7

Verfasst: 06.02.2017 20:00
von Melmac
Hi,

nicht alle Extensions (nicht "MODs" :wink: ) für phpBB 3.1.x sind kompatibel mit 3.2.0 und/oder PHP 7.x.

Zur installierten Gallery-Version: so wie es aussieht ist dies sogar noch eine der Entwicklerversionen, oder?
Generell: Version 1.2.0.x, wie sie in der CDB zu finden ist, ist nur mit phpBB 3.1.x kompatibel und nicht mit 3.2.0. Für letztere wird es die Version 1.2.1 geben, die sich aktuell aber noch in Entwicklung befindet.

Ähnliches dürfte auch für einige der anderen Extensions gelten, aber dies müsstest Du zur Not in den jeweiligen Supportbereichen der Downloadseiten nachprüfen können.

Für 3.2.0 validierte Extensions findest Du hier - noch nicht validierte und sich noch in Entwicklung befindliche Extensions solltest Du generell nicht in einem Live Board installieren (wenn doch, dann geschieht dies auf eigenes Risiko).
Vielleicht hilft Dir auch dieses Topic auf .com weiter, zumindest wenn es um die Identifizierung der (noch) nicht mit 3.2 kompatiblen 3.1-Extensions geht.

Re: Probleme beim Gallery Mod seit phpBB 3.2.0 und PHP7

Verfasst: 06.02.2017 20:06
von Ramona_FP
Huhu,

vielen Dank schonmal, lese mir alles durch :) (die Galerie war schon vorher da, bin die Updates immer "mitgegangen")

@Mods; nutze phpBB seit 2.irgendwas, das sitzt einfach noch hihi.... :D

Re: Probleme beim Gallery Mod seit phpBB 3.2.0 und PHP7

Verfasst: 07.02.2017 19:30
von Ramona_FP
Huhu nochmal,

ich war bei 1.2.0 - habe jetzt mal todesmutig -mangels Alternativen- :wink: die sich in Entwicklung befindende Version genommen und es ist wieder alles top :grin:

Re: Probleme beim Gallery Mod seit phpBB 3.2.0 und PHP7

Verfasst: 07.02.2017 20:45
von Melmac
Sichere dann aber regelmäßig deren Daten :wink:

Wenn ich den Entwickler richtig in Erinnerung habe, wird sich der Code von 1.2.1 stark von dem der 1.2.0 Version unterscheiden und auch noch so einiges an neuen Features hinzu kommen. Durchaus möglich also, dass sich im Laufe der weiteren Entwicklungsarbeit noch einiges ändern kann - dabei ist dann nie so ganz auszuschließen, dass es einmal keine einfache Migrationsmöglichkeit von einer DEV-Version zur nächsten geben könnte und die bereits vorhandenen Arbeitsdaten so im Nirvana landen :wink:

Re: Probleme beim Gallery Mod seit phpBB 3.2.0 und PHP7

Verfasst: 08.02.2017 10:54
von vfrblue
Das hört sich ja nicht schön an. Ich habe extra nicht auf 3.2 umgestellt, da es für einige Ext., die ich unter 3.1.10 installiert habe, noch keine stabile Version gibt.
Hoffentlich kann man die "alten Einstellungen übernehmen.

Re: Probleme beim Gallery Mod seit phpBB 3.2.0 und PHP7

Verfasst: 08.02.2017 18:29
von Melmac
Hi,

dies sollte normalerweise problemlos möglich sein - im Prinzp führst Du ja nach dem Upgrade auf 3.2.0 "nur" noch ein Update all derjenigen Extensions durch, die noch für den Einsatz unter eben dieser neuen phpBB-Linie angepasst werden müssen.
Einfach mal die zugehörigen Supportbereiche der betreffenden Extension oder deren Entwicklertopics verfolgen und/oder dort zur Not mal nachfragen.

Re: Probleme beim Gallery Mod seit phpBB 3.2.0 und PHP7

Verfasst: 19.03.2017 11:27
von Tastenplayer
Mir stellt sich hier die Frage:
kann man die 1.2.0 Version in einem 3.2.0 Board installieren, ohne dass das Forum gecrasht wird? (Wäre nur im lokalen TB um die Platzverhältnisse der Navi abzuchecken im neuen Style)
Erledigt - habe einfach eine Pages mit Titel Galerie eingefügt.

Re: Probleme beim Gallery Mod seit phpBB 3.2.0 und PHP7

Verfasst: 07.04.2017 22:37
von NicoM
Hallo,

und mir stellt sich die Frage, wann ich endlich unsere Galerie wieder ans Laufen kriege, die in der alten nickvergessen-Version wunderbar mit PhpBB 3.0.12 zusammenarbeitete. Jetzt haben wir das Forum auf 3.2.0 upgedated und die Galerie läuft nicht mehr. Wisst Ihr, wann mit einer fertigen, funktionierenden Gallery 1.2.1 zu rechnen ist? Oder gibt es eine Alternative?

Re: Probleme beim Gallery Mod seit phpBB 3.2.0 und PHP7

Verfasst: 07.04.2017 23:47
von Hinnerk
Eine Version 1.2.1 der Galerie für phpBB 3.2.0 gibt es doch bereits. Die läuft bei mir fehlerfrei:

https://github.com/satanasov/phpbbgallery/tree/1.2.1