[3.2.1]Problem mit "emailonbirthday"

Du hast Probleme beim Installieren oder bei der Benutzung einer Extension? In diesem Forum bist du richtig.
Forumsregeln
Bei Fragen zu einer bestimmten Extension sind Extension-Name und die Downloadquelle der Extension erforderlich. Letztere in Form der URL zum Download. Hiervon kann lediglich bei sehr bekannten und verbreiteten Extensions abgesehen werden, soweit eindeutig ist, um welche Extension es sich handelt. Es liegt allerdings im Ermessen der Moderatoren, das Thema ggf. zu schließen, daher sollte im Zweifel der Link angegeben werden.
Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1642
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2.1]Problem mit "emailonbirthday"

Beitragvon canonknipser » 05.02.2018 16:03

Mahony hat geschrieben:Hm...nicht ganz... Das Problem liegt hierbei wohl an der Verwendung von PHP 7
In PHP 7 darf split nicht mehr verwendet werden (Function split() is deprecated).
Jein, deprecated schon in PHP 5.3.0 und gelöscht in PHP 7.0.0 ;) ->
http://php.net/manual/en/function.split.php
Also stimmt meine Aussage, dass es die Funktion nicht gibt ;)
Die hätte schon ab 5.3 nicht mehr verwendet werden sollen / dürfen, vor allem nicht in einer Extension, die (wie auf phpBB 3.1) als Mindestanforderung PHP 5.3.3 angibt.

Aber schön, dass es wieder läuft.

Ich hab in dem github-Repo mal ein Issue aufgemacht -> https://github.com/ForumHulp/emailonbirthday/issues/20
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

eumelchen
Mitglied
Beiträge: 515
Registriert: 09.02.2008 08:28
Wohnort: Gottin

Re: [3.2.1]Problem mit "emailonbirthday" FEHLER WIEDER DA!

Beitragvon eumelchen » 06.02.2018 09:38

Nachdem es gestern funktioniert hatte wurde heute leider keine Mail an das heutige "Geburtstagskind" geschickt.
Folgende Info steht in der Server-Log-Datei:
[Tue Feb 06 08:25:07 2018] [-:error] [pid 5020] [client 2.164.133.147] [host test.chiforum.de] PHP Fatal error: Uncaught Error: Call to undefined function forumhulp\\emailonbirthday\\lang_manager\\split() in /is/htdocs/wp67211_MOYUN7QYCB/www/test/ext/forumhulp/emailonbirthday/lang_manager/lang_manager.php:56\nStack trace:\n#0 /is/htdocs/wp67211_MOYUN7QYCB/www/test/ext/forumhulp/emailonbirthday/cron/task/core/birthday.php(77): forumhulp\\emailonbirthday\\lang_manager\\lang_manager-]numbertext('28', 'de')\n#1 [internal function]: forumhulp\\emailonbirthday\\cron\\task\\core\\birthday-]run()\n#2 /is/htdocs/wp67211_MOYUN7QYCB/www/test/phpbb/cron/task/wrapper.php(104): call_user_func_array(Array, Array)\n#3 /is/htdocs/wp67211_MOYUN7QYCB/www/test/cron.php(78): phpbb\\cron\\task\\wrapper-]__call('run', Array)\n#4 {main}\n thrown in /is/htdocs/wp10567211_MOYUN7QYCB/www/test/ext/forumhulp/emailonbirthday/lang_manager/lang_manager.php on line 56

Wieder stehe ich davor wie der sprichwörtliche Ochse vorm offenen Scheunentor.

Wer kann mir helfen?

LG Rolf (eumelchen)

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11528
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2.1]Problem mit "emailonbirthday"

Beitragvon Mahony » 06.02.2018 09:48

Hallo
Das ist der gleiche Fehler, wie gestern.
eumelchen hat geschrieben:Uncaught Error: Call to undefined function forumhulp\\emailonbirthday\\lang_manager\\split()

Du hast anscheinend die unveränderte original-Datei wieder hoch geladen (bzw. ist es wohl ein anderes Forum >>> http://test.chiforum.de vorher war es wohl das hier >>> http://chiforum.de )

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

eumelchen
Mitglied
Beiträge: 515
Registriert: 09.02.2008 08:28
Wohnort: Gottin

Re: [3.2.1]Problem mit "emailonbirthday"

Beitragvon eumelchen » 06.02.2018 11:11

Danke, Mahony, ich hatte nur mein aktives Forum geändert. Mein Test-Forum ist auf dem gleichen Server, deshalb die Fehlermeldung.
Jetzt ist auch mittlerweile in meinem aktiven Forum die Geburtstagsmail verschickt worden. Ich habe nie herausbekommen wann die Mail verschickt wird und was der Auslöser ist.

Aber Entwarnung! Alles OK!

Ja, ja, wer lesen kann ist echt im Vorteil. :lol: :lol: :lol:

Benutzeravatar
Kurt W
Mitglied
Beiträge: 345
Registriert: 15.07.2017 10:37
Kontaktdaten:

Re: [3.2.1]Problem mit "emailonbirthday"

Beitragvon Kurt W » 23.07.2018 17:22

Funktioniert die Ext jetzt schon Problemlos unter 3.2 und PHP 7.0?

Oder muss man da noch was "manuell" verändern?

Gibt es dafür auch eine de?

Weil die würde mir noch in meiner Sammlung fehlen.

Gruß Kurt

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 3401
Registriert: 15.10.2012 03:27

Re: [3.2.1]Problem mit "emailonbirthday"

Beitragvon Melmac » 23.07.2018 17:42

Laut diesem Commit hier sollte die hier angesprochene Codeanpassung inzwischen im im Repo enthalten sein.

Kurt W hat geschrieben:Funktioniert die Ext jetzt schon Problemlos unter 3.2 und PHP 7.0?

Sie ist, so weit ich sehen kann, noch nicht in der CDB für phpBB 3.2 validiert veröffentlicht, also gilt dann auch für sie das gleiche, was generell in Zusammenhang mit Entwickler- bzw. nicht validierten Versionen gilt: alles auf eigenes Risiko :wink:
Das wirst also Du im Zweifel selbst austesten müssen, wie stabil sie läuft - ich finde aus dem Stegreif noch nicht einmal ein entsprechendes Entwicklertopic auf .com ...
(btw.: Stichwort => "lokale Testumgebung" :wink: )

Kurt W hat geschrieben:Gibt es dafür auch eine de?

Im Repo ist zumindest kein deutsches Sprachpaket enthalten. Falls sich hier niemand finden sollte, der bereits eines selbst erstellt hat und es Dir zur Verfügung stellt, kannst Du die Übersetzung aber auch selbst vornehmen.
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

Benutzeravatar
Kurt W
Mitglied
Beiträge: 345
Registriert: 15.07.2017 10:37
Kontaktdaten:

Re: [3.2.1]Problem mit "emailonbirthday"

Beitragvon Kurt W » 23.07.2018 17:49

Danke dir.

Dann werde ich das mal Testen. Vielleicht hat ja schon jemand eine de dafür.

Wäre sehr Dankbar, wenn ich die haben könnte.

Gruß Kurt

Benutzeravatar
Kurt W
Mitglied
Beiträge: 345
Registriert: 15.07.2017 10:37
Kontaktdaten:

Re: [3.2.1]Problem mit "emailonbirthday"

Beitragvon Kurt W » 23.07.2018 20:15

Gerade installiert und es kommt folgende Fehlermeldung:

Information

Forumhulp helper application does not exist!
Download forumhulp/helper and copy the helper folder to your forumhulp extension folder.

Gruß Kurt

eumelchen
Mitglied
Beiträge: 515
Registriert: 09.02.2008 08:28
Wohnort: Gottin

Re: [3.2.1]Problem mit "emailonbirthday"

Beitragvon eumelchen » 23.07.2018 20:17

Hast Du die forumhulp helper installiert?

Benutzeravatar
Kurt W
Mitglied
Beiträge: 345
Registriert: 15.07.2017 10:37
Kontaktdaten:

Re: [3.2.1]Problem mit "emailonbirthday"

Beitragvon Kurt W » 23.07.2018 20:21

Wo finde ich den denn?? :oops:

Gruß Kurt


Zurück zu „Extension Support“