Contact Admin Extension weisses Bild nach Formular absenden

Du hast Probleme beim Installieren oder bei der Benutzung einer Extension? In diesem Forum bist du richtig.
Forumsregeln
Bei Fragen zu einer bestimmten Extension sind Extension-Name und die Downloadquelle der Extension erforderlich. Letztere in Form der URL zum Download. Hiervon kann lediglich bei sehr bekannten und verbreiteten Extensions abgesehen werden, soweit eindeutig ist, um welche Extension es sich handelt. Es liegt allerdings im Ermessen der Moderatoren, das Thema ggf. zu schließen, daher sollte im Zweifel der Link angegeben werden.
Schwarzbueb
Mitglied
Beiträge: 45
Registriert: 23.01.2009 09:59
Wohnort: CH
Kontaktdaten:

Contact Admin Extension weisses Bild nach Formular absenden

Beitragvon Schwarzbueb » 06.10.2019 10:30

Halli Hallo

Habe mir gestern HIER die neuste 1.1.10 Contact Admin Extension runtergeladen und auf meinem 3.2.8 phpbb installiert.
Danach im ACP aktiviert und konfiguriert, hat auch prima geklappt, jedoch störte mich, dass im ACP alles Englisch war und habe daher eine DE Übersetzung kreiert und hochgeladen. Auch dies hat zunächst prima funktioniert, jedoch musste ich öfters ein paar Schreibfehler korrigieren und das ganze immer wieder hochladen.
Dann auf einmal, nach gefühlten 100 hochgeldenen Korrekturen und Cache Löscherei, kam nach dem Absenden des Kontaktformulars nur noch ein weisser Bildschirm den ich bis jetzt nicht weg bekommen habe.
Extension wurde bereits deinstalliert (in der DB war der Eintrag weg) und neu im Original wieder installiert und auch Englisch belassen, der Browsercache und den Forencache x-mal gelöscht, jedoch ohne Erfolg.
Ebenso habe ich einen anderen Browser getestet, was auch nicht funktionierte.

Wer hat einen Tip oder Rat für mich?

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 10343
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: Contact Admin Extension weisses Bild nach Formular absenden

Beitragvon Crizzo » 06.10.2019 10:44

Hi,

was sagt der PHP error.log dazu?

Schwarzbueb
Mitglied
Beiträge: 45
Registriert: 23.01.2009 09:59
Wohnort: CH
Kontaktdaten:

Re: Contact Admin Extension weisses Bild nach Formular absenden

Beitragvon Schwarzbueb » 06.10.2019 11:05

Also im Fehler Protokoll des Forums finde ich nichts.
Falls du einen anderen Log meinst, weiss ich nicht wo ich den finden kann.

EDIT: Habe im Firewall Protokoll des Hostings evtl. was passendes gefunden, die IP sollte meine sein.

AH01071: Got error 'PHP message: PHP Fatal error: Uncaught Error: Call to undefined function rmcgirr83\\stopforumspam\\event\\user_ban() in /var/www/vhosts/fischerforum.ch/httpdocs/phpBB3/ext/rmcgirr83/stopforumspam/event/main_listener.php:438\nStack trace:\n#0 /var/www/vhosts/fischerforum.ch/httpdocs/phpBB3/ext/rmcgirr83/stopforumspam/event/main_listener.php(141): rmcgirr83\\stopforumspam\\event\\main_listener->ban_by_ip('109.106.54.8')\n#1 /var/www/vhosts/fischerforum.ch/httpdocs/phpBB3/vendor/symfony/event-dispatcher/EventDispatcher.php(184): rmcgirr83\\stopforumspam\\event\\main_listener->user_sfs_validate_registration(Object(phpbb\\event\\data), 'rmcgirr83.conta...', Object(phpbb\\event\\dispatcher))\n#2 /var/www/vhosts/fischerforum.ch/httpdocs/phpBB3/vendor/symfony/event-dispatcher/EventDispatcher.php(46): Symfony\\Component\\EventDispatcher\\EventDispatcher->doDispatch(Array, 'rmcgirr83.conta...', Object(phpbb\\event\\data))\n#3 /var/www/vhosts/fischerforum.ch/httpdocs/phpBB3/phpbb/event/dispatcher.php(62): Symfony\\Component\\EventDispatche...\n', referer: https://www.fischerforum.ch/phpBB3/app. ... 2e4bf6f315

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 10343
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: Contact Admin Extension weisses Bild nach Formular absenden

Beitragvon Crizzo » 06.10.2019 11:16

Das scheint aber diese Extension zu sein: rmcgirr83\\stopforumspam

Und ich meinte den Error.log vom Server zu PHP. Den kriegst du nicht im phpBB ACP, sondern bei deinem Webhoster oder der liegt aufm Server.

Schwarzbueb
Mitglied
Beiträge: 45
Registriert: 23.01.2009 09:59
Wohnort: CH
Kontaktdaten:

Re: Contact Admin Extension weisses Bild nach Formular absenden

Beitragvon Schwarzbueb » 06.10.2019 11:57

Hmm? dies ist der einzige Fehler der passen würde, am Schluss der Fehlermeldung wird aber noch "app.php/contactadmin" erwähnt.
Habe die error.log vom Server angesehen, dort steht dasselbe drin, eine explizite php Log habe ich nicht gefunden.

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 6419
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: Contact Admin Extension weisses Bild nach Formular absenden

Beitragvon Kirk » 06.10.2019 12:33

Deaktiviere die EXT stopforumspam, löscht das Protokoll deines Forums und kontrollierst ob dieser Fehler immer noch auftritt.

Schwarzbueb
Mitglied
Beiträge: 45
Registriert: 23.01.2009 09:59
Wohnort: CH
Kontaktdaten:

Re: Contact Admin Extension weisses Bild nach Formular absenden

Beitragvon Schwarzbueb » 06.10.2019 13:22

Also habe alles nochmals gelöscht, neu von der Seite runtergeladen und mit einer DE Version von der Seite ergänzt und neu hochgeladen, was auch nichts brachte.
Habe dann nach Kirk gehandelt, und die Stop Forum Spam Extension deaktiviert, die Arbeitsdaten, den Cache und die Protokolle gelöscht.
Fazit, mit deaktiviertem Stop Forum Spam funktionierte es tadellos, also habe ich Stop Forum Spam wieder aktiviert und es scheint immer noch zu funtionieren.
Anscheinend werde ich als Spamer von meinem eigenen Forum (Stop Forum Spam) geblockt :lol: :
No soup for you! It looks like you have been flagged as a spammer.
If you feel this decision was made in error contact the board admin.


Könnte es darum jemand von euch testen, ob die Kontaktfunktion nun funktioniert?

Danke für die Hilfe

Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 15792
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: Contact Admin Extension weisses Bild nach Formular absenden

Beitragvon Dr.Death » 06.10.2019 15:32

done, klappt.

Schwarzbueb
Mitglied
Beiträge: 45
Registriert: 23.01.2009 09:59
Wohnort: CH
Kontaktdaten:

Re: Contact Admin Extension weisses Bild nach Formular absenden

Beitragvon Schwarzbueb » 06.10.2019 15:41

Ja ist angekommen, danke für die Hilfe.
Welches CAPTCHA empfiehlst du?

Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 15792
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: Contact Admin Extension weisses Bild nach Formular absenden

Beitragvon Dr.Death » 07.10.2019 07:44

Ich persönlich ?

Sortable Captcha (aber du musst in der Version 2.0 noch den Fix einbauen)


Demo? Auf meiner Seite


Zurück zu „Extension Support“