[3.2] Darstellung "Schmales Leerzeichen" klappt nicht

Alles zu Styles, Templates, Icons und Smilies für phpBB 3.1/3.2, sowie allgemeine Designfragen zur Integration von phpBB in bestehende Websites.
Forumsregeln
Bei Style spezifischen Fragen ist der Stylename und die Downloadquelle des Styles erforderlich, besser noch die URL vom betroffenen Forum.
Antworten
peter2019
Mitglied
Beiträge: 23
Registriert: 08.10.2019 22:31

[3.2] Darstellung "Schmales Leerzeichen" klappt nicht

Beitrag von peter2019 » 15.10.2019 20:30

Hallo,
ich kopiere ab und zu Texte, die für die Darstellung in HTML sind, in ein phpBB-Forum.
Dort werden verwendete "Schmale Leerzeichen" - also im Prinzip HTML-Code nicht entsprechend dargestellt, sondern eben als HTNL-Code, im Falle eines schmalen Leerzeichens als " ".
Gibt es eine Möglichkeit, das zu ändern?
Mit der Wortzensur habe ich es nicht geschafft, aus &  oder nur   und der Darstellung " " ein " " zu wandeln.
Mit Smilies den Code   in ein transparentes GIF mit bestimmten Abmessungen zu wandeln, klappt auch nicht.
Hat einer eine andere Idee, wie das gehen würde.
Übrigens, ein – in einen längeren Bindestrich zu wandeln, klappt entsprechen auch nicht.
Vielleicht gibt es eine einfache Lösung, oder ich habe etwas falsch gemacht oder nicht richtig verstanden?
Danke für alle Hinweise!
Peter
P.S.: Style ist prosilver

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 2053
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Darstellung "Schmales Leerzeichen" klappt nicht

Beitrag von canonknipser » 15.10.2019 22:26

Du kannst dir dafür einen BBCode erstellen
BBCode-Benutzung

Code: Alles auswählen

[thin][/thin]
HTML-Ersetzung

Code: Alles auswählen

 
Tipp-Anzeige

Code: Alles auswählen

thin space
&ndash entsprechend mit einem weiteren BBCode ;)
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

peter2019
Mitglied
Beiträge: 23
Registriert: 08.10.2019 22:31

... klappt nicht ganz

Beitrag von peter2019 » 15.10.2019 22:52

Oder ich habe mich missverständlich ausgedrückt. :oops:
Mit Deinem [thin][/thin] wird im Text erfolgreich ein geschützes Leerzeichen ausgegeben.
Ich möchte aber einen im Beitrag eingegebenen Text z.B.
"Der Baum ist 15 m hoch" automatisch umgewandelt als
"Der Baum ist 15 m hoch" lesen.
Geht das irgendwie?

Benutzeravatar
BNa
Valued Contributor
Beiträge: 2550
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.2] Darstellung "Schmales Leerzeichen" klappt nicht

Beitrag von BNa » 16.10.2019 00:37

Das könnte evtl funktionieren..
https://www.phpbb.com/community/viewtop ... #p13146705
Mglw. ist etwas weiteres Umbauen für 3.2 nötig....
Das hier** ist aktuell getestet und funktioniert:
http://4seven.bplaced.net/forum/6test/v ... f=19&t=379

Hier steht testthinsptest (ohne Leerstelle)
http://4seven.bplaced.net/forum/7test/v ... 3&p=10#p10

Wichtig:   funktioniert nicht im Post, thinsp jedoch wird korrekt in   umgewandelt.

Auf deutsch: Gibst Du testthinsptest ein, gehts. Analog zu Deinem Satz > Der Baum ist 15thinspm hoch

Dein "thinsp"-Beispiel ist in die Anleitung** integriert, ..viel Erfolg...

peter2019
Mitglied
Beiträge: 23
Registriert: 08.10.2019 22:31

Zusammenfassend kann man also sagen ...

Beitrag von peter2019 » 16.10.2019 13:21

... die Eingabe von   in einem Beitrag und die Erwartung, dass das in der Anzeige des Beitrages als schmales Leerzeichen dargestellt wird, ist nicht wirklich elegant umzusetzen. Ich werde daher Beiträge gleich von " " u.ä. befreien.

Benutzeravatar
BNa
Valued Contributor
Beiträge: 2550
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.2] Darstellung "Schmales Leerzeichen" klappt nicht

Beitrag von BNa » 16.10.2019 14:49

wie gesagt, die o.g. lösung funktioniert.

peter2019
Mitglied
Beiträge: 23
Registriert: 08.10.2019 22:31

Du meinst die Lösung ...

Beitrag von peter2019 » 16.10.2019 16:03

... in viewtopic.php und mit str_replace?
OK., das versuche ich vielleicht mal ...

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 2053
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Darstellung "Schmales Leerzeichen" klappt nicht

Beitrag von canonknipser » 16.10.2019 16:22

Denk aber dran, dass du das bei jedem Update des Bords wieder neu einbauen musst.


Da phpBB aus Sicherheitsgründen keine Eingabe von HTML in Postings erlaubt (und dazu gehören nun mal auch benannte Entitäten), bleiben dir nur die genannten Möglichkeiten:
  • BBCode
  • Word-Zensor resp. Posting-Editor angepasst
In beiden Fällen musst du den originären html-Quelltext deines Beitrages anpassen und die Vorkommen von   ersetzen entweder durch [thin][/thin] oder durch thinsp - dann kannst du es auch gleich durch ein normales Leerzeichen ersetzen.

Es gibt Editoren, die sind Makrofähig (z.B. Ultraedit, Notepad++ etc.), da kannst du das dann quasi automatisch erledigen lassen
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

peter2019
Mitglied
Beiträge: 23
Registriert: 08.10.2019 22:31

OK...

Beitrag von peter2019 » 16.10.2019 17:35

...es ist in Summe einfacher, den Text gleich von den   etc. zu brefreien und "clean" einzustellen. :)

Benutzeravatar
BNa
Valued Contributor
Beiträge: 2550
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: Du meinst die Lösung ...

Beitrag von BNa » 17.10.2019 01:47

peter2019 hat geschrieben:... in viewtopic.php und mit str_replace?
OK., das versuche ich vielleicht mal ...
Nein, ich meinte die für Dich angepasste Lösung hier:
BNa hat geschrieben:Das hier** ist aktuell getestet und funktioniert:
http://4seven.bplaced.net/forum/6test/v ... f=19&t=379

thinsp .. wird korrekt in   umgewandelt.
...
Dein "thinsp"-Beispiel ist in die Anleitung** integriert..
Doch ist's ja jetzt Einerlei, weils nun Jacke ist :lol:

Antworten

Zurück zu „Styles, Templates und Grafiken“