Diskussion zu "phpBB 3.1: Wartungszeitrahmen angepasst (EOM:

Projekte der phpBB.de-Community und Feedback zu phpBB.de.
juliokr
Mitglied
Beiträge: 431
Registriert: 06.02.2015 12:54
Wohnort: Paris
Kontaktdaten:

Re: Diskussion zu "phpBB 3.1: Wartungszeitrahmen angepasst (

Beitragvon juliokr » 30.12.2016 15:55

Red-Benz hat geschrieben:zudem wird es php 5.5 und php 5.6 noch lange geben da sonst vermutlich das halbe Internet nicht mehr läuft, auf jeden Fall noch länger als 2 Jahre


php5.5 - Security Support Until mitte 2016 !!!
php5.6 - Security Support Until 31 Dec 2018 - also genau 2 Jahre

Quelle : http://php.net/supported-versions.php
Mal davon abgesehen das die meiste Hoster ein reelles Interesse daran haben php 7.0 und höher zu pushen (da schneller und damit weniger Server Belastung)
Also wenn in 2 Jahren dein phpBB 2 nur noch ein weiße Seite anzeigt beschwer dich nicht das dich niemand gewarnt hat !

Talk19zehn
Ehemaliger
Beiträge: 4289
Registriert: 08.06.2009 12:03

Re: Diskussion zu "phpBB 3.1: Wartungszeitrahmen angepasst (

Beitragvon Talk19zehn » 30.12.2016 16:18

Hello, es wird immer Kenner und Könner geben, die in der Lage sind PHP auf neuere Versionen anzupassen. Insofern sei dahingestellt, was wo, wann und wie funktioniert. Das, was er aufzeigt, ist laut Aussage bereits mit php-5.6 kompatibel und zudem eine Rarität. Das hat was und verdient meinen Respekt!

LG @ALL



Derzeitiger Stand der Information: 30.12.2016, 17:00 zum Thema
BTW: Diskussion zu phpBB 3.1: Wartungszeitrahmen angepasst ...
Die Wartungsmodi werden mit Erscheinen der phpBB-Version-3.2.0 (Final) im Januar 2017 wohl erneut angepasst:

•Fehlerkorrekturen werden eingepflegt bis: Juni 2017 (End of Maintenance)
•Sicherheitslücken werden geschlossen bis: Dezember 2017 (End of Life)

Siehe auch: viewtopic.php?p=1360225#p1360225
Zuletzt geändert von Talk19zehn am 30.12.2016 17:05, insgesamt 1-mal geändert.
Angaben ohne Gewähr, da von zahlreichen Komponenten abhängig. 8)

Benutzeravatar
Red-Benz
Mitglied
Beiträge: 265
Registriert: 17.03.2006 23:05
Wohnort: Hamburg
Kontaktdaten:

Re: Diskussion zu "phpBB 3.1: Wartungszeitrahmen angepasst (

Beitragvon Red-Benz » 30.12.2016 16:48

juliokr hat geschrieben:
Red-Benz hat geschrieben:zudem wird es php 5.5 und php 5.6 noch lange geben da sonst vermutlich das halbe Internet nicht mehr läuft, auf jeden Fall noch länger als 2 Jahre


php5.5 - Security Support Until mitte 2016 !!!
php5.6 - Security Support Until 31 Dec 2018 - also genau 2 Jahre

Quelle : http://php.net/supported-versions.php
Mal davon abgesehen das die meiste Hoster ein reelles Interesse daran haben php 7.0 und höher zu pushen (da schneller und damit weniger Server Belastung)
Also wenn in 2 Jahren dein phpBB 2 nur noch ein weiße Seite anzeigt beschwer dich nicht das dich niemand gewarnt hat !


Wenn man bedenkt das auf dem Server auf dem mein Forum läuft selbst PHP 5.2 noch aktiv ist ( wird ende Januar 2017 entfernt ) von der der Support schon vor Jahren zu Ende ging, dürfte selbst wenn der Support von 5.6 ende 2018 endet die Version noch Jahre auf den Servern zur Auswahl stehen und bis dahin dürfte ich auch fertig sein mein Forum auf PHP 7 lauffähig zu haben !

Das Forum auf PHP 5.6 zu bekommen war nur wenige Tage Arbeit und wesentlich schneller als alle MODS für ein neueres Forum zu entwickeln !

Mit den Mods bin ich eh schon seit Jahren eigene Wege gegangen und hab lieber alles eigene entwickelt als schlecht gemachte aus der Mod Datenbank zu verwenden, ich habe dort kaum Fehlerfreie gefunden und bei so vielen Änderungen wie in meinem Forum sollten auch alle Änderungen ineinander greifen und Fehlerfrei arbeiten !!

Neue Forensoftware zu entwickeln ist eine wichtige und lobenswerte Aufgabe weil ja ständig neue Foren eröffnet werden aber für langjährige Foren ist eine Umstellung mit allen Erweiterungen die im laufe der Zeit gemacht wurden so gut wie aussichtslos.

Gruß
Red Benz
Hilfe, ich brauche mehr Steuern, ich habe noch Geld !

http://www.tuning-crew-nord.com

Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 1314
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: Diskussion zu "phpBB 3.1: Wartungszeitrahmen angepasst (

Beitragvon Joyce&Luna » 30.12.2016 16:57

Nicht jeder kann das mal eben auf eine andere php Version umstricken.
Da du dies wohl kannst, wünsche ich dir natürlich weiterhin viel Erfolg damit :D

Vielleicht solltest du für andere phpBB 2 Nutzer, die nicht auf phpBB 2 verzichten wollen Hilfe anbieten.

Anke
phpBB-Style-Design.de

Es kommt nicht darauf an, mit dem Kopf durch die Wand zu gehen, sondern mit den Augen die Tür zu finden.
Support zu meinen Styles, bitte die Fragen im Forum stellen und nicht per PN. Danke!

juliokr
Mitglied
Beiträge: 431
Registriert: 06.02.2015 12:54
Wohnort: Paris
Kontaktdaten:

Re: Diskussion zu "phpBB 3.1: Wartungszeitrahmen angepasst (

Beitragvon juliokr » 30.12.2016 17:06

Red-Benz hat geschrieben:Wenn man bedenkt das auf dem Server auf dem mein Forum läuft selbst PHP 5.2 noch aktiv ist ( wird ende Januar 2017 entfernt ) von der der Support schon vor Jahren zu Ende ging ...


Na dann hast Du wohl einen "Oldie-friendly Hoster" :wink: Bei meinem wird gerade mal noch 5.4 momentan "geduldet"

Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 1314
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: Diskussion zu "phpBB 3.1: Wartungszeitrahmen angepasst (

Beitragvon Joyce&Luna » 30.12.2016 17:11

Mein Anbieter duldet ab php 5.5, 5.2, 5.3, 5.4 werden nächsten Monat entfernt.
Da ich eh alles auf php 5.6 und php 7 am laufen habe, betrifft mich das ganze gar nicht.

Anke
phpBB-Style-Design.de

Es kommt nicht darauf an, mit dem Kopf durch die Wand zu gehen, sondern mit den Augen die Tür zu finden.
Support zu meinen Styles, bitte die Fragen im Forum stellen und nicht per PN. Danke!

Benutzeravatar
Red-Benz
Mitglied
Beiträge: 265
Registriert: 17.03.2006 23:05
Wohnort: Hamburg
Kontaktdaten:

Re: Diskussion zu "phpBB 3.1: Wartungszeitrahmen angepasst (

Beitragvon Red-Benz » 30.12.2016 17:23

Juppi hat geschrieben:Mein Anbieter duldet ab php 5.5, 5.2, 5.3, 5.4 werden nächsten Monat entfernt.
Da ich eh alles auf php 5.6 und php 7 am laufen habe, betrifft mich das ganze gar nicht.

Anke


Das war ja auch bei mir der Grund auf 5.6 zu gehen, 5.2, 5.3, 5.4 werden am 23.01.2017 entfernt (ALL-INKL.COM)


Juppi hat geschrieben:
Vielleicht solltest du für andere phpBB 2 Nutzer, die nicht auf phpBB 2 verzichten wollen Hilfe anbieten.

Anke


Habe ich auch schon überlegt, Zeit genug habe ich dafür (Frührentner) :grin:


Gruß
Red Benz
Hilfe, ich brauche mehr Steuern, ich habe noch Geld !

http://www.tuning-crew-nord.com

Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 1314
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: Diskussion zu "phpBB 3.1: Wartungszeitrahmen angepasst (

Beitragvon Joyce&Luna » 30.12.2016 17:31

Wir haben den gleichen Anbieter :D

Es gibt bestimmt einige die nicht wechseln wollen.
Aber meist ist es so, Rentner haben nie Zeit, sind immer voll im Stress :grin:

Anke
phpBB-Style-Design.de

Es kommt nicht darauf an, mit dem Kopf durch die Wand zu gehen, sondern mit den Augen die Tür zu finden.
Support zu meinen Styles, bitte die Fragen im Forum stellen und nicht per PN. Danke!

Benutzeravatar
Red-Benz
Mitglied
Beiträge: 265
Registriert: 17.03.2006 23:05
Wohnort: Hamburg
Kontaktdaten:

Re: Diskussion zu "phpBB 3.1: Wartungszeitrahmen angepasst (EOM:

Beitragvon Red-Benz » 13.05.2017 21:51

Hi Leuts

Nur mal so zur Info was alles möglich ist wenn man wirklich will...........

Ich habe jetzt mein GUTES ALTES phpBB2 Forum in der altertümlichen Version 2.0.23 tatsächlich komplett mit der PHP Version 7.1 ans Laufen bekommen, war ein hartes Stück Arbeit und es ist nun sau-schnell :grin:

Zur Zeit nur auf einem Test-Server aber in Kürze auf dem eigentlichen...............

den meisten Stress hat die bbcode.php gemacht aber auch die läuft nun perfekt :D


Gruß

Red-Benz
Hilfe, ich brauche mehr Steuern, ich habe noch Geld !

http://www.tuning-crew-nord.com

Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 1314
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: Diskussion zu "phpBB 3.1: Wartungszeitrahmen angepasst (EOM:

Beitragvon Joyce&Luna » 13.05.2017 22:53

Aber der Inhalt ist trotzdem veraltet.

Man sollte mit der Zeit gehen, denn es hat sich vieles verändert.

Anke
phpBB-Style-Design.de

Es kommt nicht darauf an, mit dem Kopf durch die Wand zu gehen, sondern mit den Augen die Tür zu finden.
Support zu meinen Styles, bitte die Fragen im Forum stellen und nicht per PN. Danke!


Zurück zu „Community Talk“