Diskussion zu "phpBB 3.3.0-Beta 1 erschienen"

Projekte der phpBB.de-Community und Feedback zu phpBB.de.
Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 10382
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: Diskussion zu "phpBB 3.3.0-Beta 1 erschienen"

Beitrag von Crizzo » 28.10.2019 17:44

Mehr Arbeit wird es halt, wenn man noch den Code der Extension für PHP 7.1 und höher anpassen muss.

Benutzeravatar
Gumfuzi
Ehemaliger
Beiträge: 2425
Registriert: 26.03.2004 22:25
Wohnort: Linz, AT
Kontaktdaten:

Re: Diskussion zu "phpBB 3.3.0-Beta 1 erschienen"

Beitrag von Gumfuzi » 28.10.2019 21:45

ok, bei mir läuft schon php 7.2 - dann sollte das zumindest wegfallen ;)
Du kannst niemals alle mit deinem Tun begeistern. Selbst wenn du über's Wasser laufen kannst, kommt einer daher und fragt, ob du zu blöd zum Schwimmen bist.
https://www.deskmodder.de

Benutzeravatar
chris1278
Mitglied
Beiträge: 1527
Registriert: 12.11.2007 06:20
Wohnort: Euskirchen
Kontaktdaten:

Re: Diskussion zu "phpBB 3.3.0-Beta 1 erschienen"

Beitrag von chris1278 » 30.10.2019 16:24

Also ich würde mal die Behauptung in den Raum stellen das die Extensions die jetzt unter phpbb 3.2.x und php 7.2.x laufen auch unter phpbb 3.3.x und php 7.3.x laufen werden.

Ich hab mal auf meinem Server das Phpbb 3..3 beta installiert und die .yml Dateien mit dem Tool, was weiter oben erwähnt wurde, angepasst. Damit lässt sich z.B. das Board3 Portal ohne Probleme installieren und am Laufen erhalten.

Ob diese Änderungen auch fürs phpbb 3.2.x brauchbar sind muss ich noch testen.

Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 15804
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: Diskussion zu "phpBB 3.3.0-Beta 1 erschienen"

Beitrag von Dr.Death » 30.10.2019 17:45

Ich stelle mal eine andere Behauptung in den Raum: Nicht alle Extensions die unter phpBB 3.1. und / oder phpBB 3.2 laufen, werden unter phpBB 3.3 laufen.....

Meine z.B. nicht, siehe: https://area51.phpbb.com/docs/dev/3.2.x ... _rhea.html
Bereich Deprecating Route Pattern

Daher kannst du nicht pauschal Deine Behauptung aufrecht erhalten :roll: :ugeek: :cookie:
Doc.
verlinken => KB:81

Benutzeravatar
chris1278
Mitglied
Beiträge: 1527
Registriert: 12.11.2007 06:20
Wohnort: Euskirchen
Kontaktdaten:

Re: Diskussion zu "phpBB 3.3.0-Beta 1 erschienen"

Beitrag von chris1278 » 02.11.2019 17:36

Okay dann nehme ich meine Behauptung zurück. Ich habe jetzt mal getestet, nachdem ich das Portal, mit dem Tool was etwas weiter oben gepostet wurde, die yml Dateien gepasst habe, mit phpbb 3.2.8 zu installieren. Ich muß sagen das die Änderungen auch abwärtskompatibel funktionieren wie es ausschaut.

Antworten

Zurück zu „Community Talk“